• You don't get fast in order to take part in club races, you take part in club races to get fast!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. #GiveAwayFriday. Win a copy of F1 2017 - The Game. Click here to join.

Oh Dear!

Discussion in 'rFactor 2' started by jimortality, Apr 19, 2016.

  1. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    My RF2 seems to be broken :(:(:(:(:( It's when I go into controls and try and set up my wheel then everything I press seems to be delayed by about 10 secs or more and when I do finally get to the garage, there is some serious lag and everything is juttering like mad. I've done re-install and even re-installed steam but I'm stumped. I thought it may be some mods but even with just ISI content it does the same thing. When I try to exit out, it takes ages and also when the tracks are loading, they take forever and If I press the escape key that seems to help it along lol!
     
  2. tpw

    tpw

    Messages:
    328
    Ratings:
    +129
    Are you running Windows 10 and a Thrustmaster wheel? There's a thread on this issue on the ISI forums and it seems some combination of rF2 1080 update, Thrustmaster drivers and Windows 10 is giving issues. I have a T300/TH8A/T3PA-PRO setup with no problems under Windows 7.
     
  3. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    Yes thanks I saw that thread and posted over there.
     
  4. William Wester

    William Wester
    Premium

    Messages:
    1,132
    Ratings:
    +382
    TX/TH8A/T3PA here, and Windows 10. So far I haven't had a problem with rF2 1080.

    EDIT: I did update my Thrustmaster drivers a couple days ago, I'm not sure it that made a difference.
    http://www.bsimracing.com/thrustmaster-new-drivers-and-firmware-available/
     
  5. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    Yes William we have done that but it seems there is an issue with that, the latest 1080 update
     
  6. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    I just rolled back the drivers for my wheel and it's all working great now.
     
  7. JoelGL

    JoelGL

    Messages:
    1,063
    Ratings:
    +73
    Sorry, where do you get the lower versions (to rollback)?
     
  8. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    I still had mine in my download folder.
     
  9. William Wester

    William Wester
    Premium

    Messages:
    1,132
    Ratings:
    +382
    I guess I had the same problem but didn't notice as I was just going into rF2 and racing. After hearing of your issue I then went into controller setup and noticed the severe delay.
    I reinstalled the old Windows driver and all is good. I will have to experiment a little with the new driver before writing it off.
     
  10. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    It's not the windows driver but the Thrustmaster driver William.
     
  11. William Wester

    William Wester
    Premium

    Messages:
    1,132
    Ratings:
    +382
    You misunderstood me, I'm talking of the Thrustmaster Windows driver. We are talking the same language but terminology is getting in the way.
     
    • Haha Haha x 1
  12. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    I've read the new notes for the firmware but all it says about the TX is updated drivers for pc but all the other wheels have had some noted changes.
     
  13. William Wester

    William Wester
    Premium

    Messages:
    1,132
    Ratings:
    +382
    Thrustmaster hasn't released new TX "firmware" for a while. I was/am running the latest firmware but their latest Windows driver is what seems to be causing the problem.
    The thing is, rF2 drove fine with the new driver but we couldn't change the controller settings. I haven't done any further research yet on this other than our conversation here on RD.
     
  14. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    Well I posted over on the official forum as T300 owners are having the same issue.
     
  15. JoelGL

    JoelGL

    Messages:
    1,063
    Ratings:
    +73
    Can I request a copy of this previous driver you're using (via PM)? I just acquired a T300base/Alcantara and the driver downloaded/installed was already the latest v25. So I have a fallback after I update rF2 when I return home from the US. TIA.
     
  16. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    Mine is the TX wheel so it's different drivers I'm afraid.
     
    • Like Like x 1
  17. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
  18. St3fan

    St3fan
    Premium

    Messages:
    670
    Ratings:
    +396
    Just FYI if you need to roll back to an earlier RF2 version if you are on Steam, right click on RF2 in the library, click "properties" and choose "beta" tab, and you can find earlier builds there.
     
    • Like Like x 1
  19. jimortality

    jimortality
    Premium

    Messages:
    3,441
    Ratings:
    +906
    Ok thanks