1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Joystick problems

Discussion in 'Racer Problems & Fixes' started by KS95, Aug 15, 2010.

  1. KS95

    RACER Moderator

    Hey :)

    For some reason, when I try and use my steering wheel and/or joystick (as shifter) I get about 1FPS max.. and a whole bunch of errors.

    I tried it without the joystick (shifter) to see if that was the problem. I got more errors.. for some reason..

    This is what I got:

    Sun Aug 15 12:36:38 (WARN): QDXJoy: can't create/find joystick #1
    Sun Aug 15 12:36:38 (ERR): RJoystickController:Connect(); can't open controller joystick1 (gamecontroller index 1)
    Sun Aug 15 12:36:38 (WARN): RControllerEngine: controller 3 (joystick1) didn't connect
    Sun Aug 15 12:36:41 (WARN): QDXJoy: can't create/find joystick #1
    Sun Aug 15 12:36:41 (WARN): QDXJoy:Unacquire(); failed (DIERR_???/0x1)

    Can anyone help?

    Thanks, KS95. :)
  2. Same issue, FPS drops with controller

    I go from 94 FPS to .7 FPS once I plug in my old USB steering wheel.
  3. KS95

    RACER Moderator

    I found this problem with all Racer versions from the current version, to 0.7.3 and 0.6.5b4 and even 0.6.3

    I never got this problem before my hard drive was wiped.
  4. Did you set it up in the "controller" folder?
  5. KS95

    RACER Moderator

    What do you mean? I just set it up in Racer as I always have done before.
  6. as in, in the Control menu in game or manually in the default.ini?
  7. KS95

    RACER Moderator

    In the control menu ingame. I always have, and it's always worked! I don't get why it won't work now after my HDD was wiped :(
  8. well first I'd check that your computer see's all your game controllers, then make sure Racer see's all your game controllers in the control menu. if both these check out I'd re map the controls, and see if that helps any.

    But what do I know, I've been using the same controller ini for like years now lmao.
  9. KS95

    RACER Moderator

    Yep, all done, all recognised etc.

    You're not the only one, I don't think my steering wheel and joystick have been in production for like 7-8 years lol
  10. I tried to use my old 0.63 default_keyboard.ini by copying it to 'controller' folder but racer's config.exe in 0.8.20 doesn't seem to read it any more.

    Do I have to set it all in the controls menu in game's main menu one more time and then change the name to keyboard.ini ? Driving with mouse is a bit annoying...

    Edit:I think I'll just set it in the ingame controls menu and then just copy the values and key sets from the old one.