1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC Issues with some mod cars

Discussion in 'Assetto Corsa' started by RC45, Jul 7, 2016.

  1. RC45

    RC45
    Premium Member

    I understand some older mods no longer work, but I was hoping to try use this opportunity to work on my own car mod.

    I have downloaded a number of existing mods, some very new some about a year old.

    All of them will load up and appear in game (latest patched Steam AC), but a few cars the AI just sits on the grid hitting the rev limiter and is not able drive the car off the line.

    Any idea where to start looking to resolve this issue?

    The Mercedes 300 Gullwing is gets stuck on th egrid, the 300SEL sedan works.

    Any pointers would be greatly appreciated

    Thanks
     
  2. Stereo

    Stereo
    Premium Member

    That would be the AI's upshift/downshift settings. It used to use the same auto transmission as the player.
     
  3. RC45

    RC45
    Premium Member

    Ah - so is this a per vehicle AI behaviour setting or is there a way to allow the car to default to take instruction the game engine?

    Is this documented for the newer game engine behaviour? And suggested reading in the context of the AC altered game engine?

    Do I need to be making changes in drivetrain.ini?
    this section particularly?

    [AUTO_SHIFTER]
    UP=5000
    DOWN=2500
    SLIP_THRESHOLD=1.1
    GAS_CUTOFF_TIME=0.15
     
    Last edited: Jul 7, 2016
  4. RC45

    RC45
    Premium Member

    Issue resolved and learned a little along the way.

    For the AI I had to change the value in the ai.ini file to be within the torque curve of the motor...

    The clue was when I tried to drive the car as an auto and it would not shift to 2nd gear.

    Made the human driver change in drivetrain.ini
    [AUTO_SHIFTER]
    UP=5500
    DOWN=2200
    SLIP_THRESHOLD=0.95
    GAS_CUTOFF_TIME=0.33

    And the AI driver change in ai.ini
    [GEARS]
    UP=5850
    DOWN=3700
    SLIP_THRESHOLD=0.95
    GAS_CUTOFF_TIME=0.23

    I was able to give the AI a wider rpm range it seems. Weird.

    Thanks for the pointer to get me going.

    Now I can race against a bunch of cool muscle cars that all had the same AI stuck on the grid issue.
     
    • Like Like x 1