1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

I am unable to map the clutch to any button or pedal

Discussion in 'DiRT Rally' started by Sk3ptik0n, May 3, 2015.

  1. Sk3ptik0n

    Sk3ptik0n
    Premium Member

    I finally found where the H-pattern is (under profile) and I switched to H-pattern + clutch.

    Then I went to map my gars and my clutch pedal. The gears were really easy. The clutch pedal not so much. Everythime I tried to map it it would tell me that there was no mapping for the clutch. I then tried to map it to a digital button and got the same result. I cannot even come out of the mapping screen as it tells me that without mapping the clutch the whole thing is incomplete and I cannot save it.

    Finally, I had to exit, choose the H-pattern without Clutch and things worked fine.

    Is there a trick I don't know? Anyone else having this problem?
     
  2. I have the same problem, I am guessing its because I have g25 pedals hooked up to a fanatec wheel, i can use my h shifter but clutch will not assign ??
     
  3. I have the same problem. You will find that you can actually map it to any button or axis except clutch pedal. Looks like it's an issue with Fanatec pedals. I saw many people with Fanatec wheels where complaining. Hopefully they will fix it with next patch.
     
  4. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    @Sk3ptik0n Go and choose your wheel from the presets, then it will automagically be assigned. This must be done after H+Clutch is chosen.
     
  5. Sk3ptik0n

    Sk3ptik0n
    Premium Member

    I'll try the suggestions, but I forgot to point out that I am using a Thrustmaster wheel with G25 pedals hooked up to the wheel through an adapter.

    But I have tried to map a simple button from the wheel itself to the clutch and that doesn't work either.
     
  6. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    Ah, I guess that is a problem indeed.

    As far as I can understand, It seems like the game struggles with such "custom-made" stuff. And that it only works well on original wheels, like the came from the manufacturer.
     
  7. Im choosing my fanatec wheel but i have g25 pedals connected directly to it. Throttle and brake are mapped fine and i can map the clutch to a button or keyboard key but clutch pedal wont do nothing.
     
    • Agree Agree x 1
  8. @Ole Marius Myrvold it's not working for me.

    @Steven Andrew Yupp, that's a bug and it's on the feedback list written by codies. As I wrote earlier, hopefully it wil lbe fixed in next patch.
     
  9. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    Isn't the fanatec sets "custom". In the way that you can order what you want and put them together!
     
  10. I don't understand what you mean by that, but for me (and couple of others Fanatec users), the game does not recognize 3rd pedal.

    But I just realized that I have all the time connected Logitech gamepad (via bluetooth so wasn't so obvious). I'll try to unplug it today and try again. Fingers crossed.
     
  11. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    I mean that you buy pedals, steering wheel and gear-stick separate. So you can decide yourself what you want (not like G27, which comes with a standarized set. That everyone gets)
     
  12. Problem is the game recognises the fanatec wheel and is probably ok with fanatec pedals hooked up. I can select h pattern and clutch in preferences but it will not let me assign my g25 clutch to an axis, even though the g25 pedals are 100% compatible and plug straight into fanatec wheels. I believe codies know about the issue so hopefully there is a fix, although there is some work arounds I am reading now in the simvibe forums, which for anyones info works by fooling sim commander into using dirt 2 profiles ;-P
     
  13. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    Ye, then we are on to the custom thingys again - they are compatible, but not stock. It does seem like everything that's not stock, and in a complete package from the manufacturer struggles to work correct in DiRT Rally.

    That being said, I cannot map things when choosing H + Clutch either, but when I choose the G27 presets (using G27 wheel) again, it is automapped! :)
     
  14. Turk

    Turk
    Premium Member

    I'm having this same problem but I can't assign the clutch to anything, it just says unassigned after I try. It won't recognize the clutch pedal on my fanatec CSR elite pedals, it won't accept a button on the wheel (Fanatec CSR) and it won't accept a key on the keyboard. It picked up the h-shifter (fanatec clubsport) straight away and the accelerator and brake pedal works fine.

    The weird thing is it will accept the third pedal as a handbrake.
     
  15. Has this changed now with the new patch today? I'm still at work and won't be able to test until tonight. I have a Fanatec GT2 with CSR Elite Pedals, same issue here where the wheel works, shifter works, gas and brake work but clutch remains as "unassigned". Has anybody tested it yet?
     
  16. I have this, my clutch isn't recognized in the game. Any help?
     
  17. I had the same problem (using T300 with G27 pedals / shifter and DIY handbrake), to fix it I had to go into the G27 file from the Dirt Rally input folder and copy and paste the gears / clutch lines into the T300 file and save. Then I loaded the T300 profile from within the game again.

    If there are any missing functions and it STILL doesn't let you assign them from the main options menu, just exit out of that screen, revert back to previous setup when prompted, then start a driving stage.

    Once it starts go into the controls settings from the pause menu and assign the missing functions from within the pause menu here and it should be fine.
     
  18. So its now August and my csr clutch still isn't recognised, tried a few things, slider_0 to slider_1 in XML files, changed from manual h + clutch to manual h, changed back, reloaded profiles etc, I tried mapping the clutch on xpadder but its unusable really, I don't mind not having it so much apart from on the start line, I hold my handbrake, put it in gear, rev and wait for go but sometimes it goes on its own, and I'm like AAARGH WTF!, restart blah blah, if this happened in MP it would be disastrous. Does anyone have a fix for the clutch that works and also to make my USB handbrake recognised by the game as I am having to use xpadder to map 'B' on there....thanks.
     
  19. Forgot to say I am on a fanatec gt2 wheel, csr pedals, g27 shifter (USB), homemade analogue handbrake.