• Blurring the line between real and virtual motorsports
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to tweak the native deadzone for logitech wheel on F1 2010.

Discussion in 'F1 2010 - The Game' started by Ivan Gjorgjievski, Oct 27, 2010.

  1. I have this stupid problem with my f1. I own a logitech force fx wheel, and is doing great for me, but only problem is that, in game, i have something like 5 -10% deadzone, and i cannot do minor corrections on track. Also, when i try to turn the wheel slowly in any direction, onscreen wheel stays put for a while (no movement) and then all of a sudden it moves to reach the position of the logitech wheel. It is not happening due to a lag to the game.

    So my question is, how to modify the native deadzone, or if any of you know why is this happening to me.

    ps: i am using logitech profiler for setting up the wheel.
  2. Hi If you have not alread yremoved the dead zone from your controller via the game then you need to go in game to controls
    so while sat in padock goto My F1 then Diving Controls there you have 4 options you need to goto either Advanced Wheel Set up or Force Feedback Settings there you can remove all deadzones asigned to your wheel and pedals
    If you have already done this and you still have a dead zone then I would reinstall the latest drivers for that wheel

    If i was you I would Not use the Logitech profiler I have it installed but never use it It runs as soon as i Plugin my G25 but thats as far as It goes with that software I run Win7 so I goto Control panel the Devices and Printers there I find My logitech G25 I right click it and at the top of the list is Game Contorller Settings this is were I set my wheel up it then carries my Whell setting in to everygame I have.

    My wheel settings in Window7 controllers settings
    185 Degrees Rotaion(this means my hands never cross and my hands move at the exact same time and distance to the ones shown on screen in game.

    then next 3 options are for Dampner springs and forcefeed back settings and the last option is centering spring all of the other options I have set to 35%
    I also then tick the box that allows the game to make changes to the wheel settings
    Now when I enter a game for the first time 90% of my whell settings are perfect I then use the game settings to fine tune the wheel to that individual game is a sence it makes a profile for every game with out having to find the .exe for the game and make every profile from scratch.

    Ill add some screenshots toexplain it. I have raced sim games for yeas and I have Foun d this to be the best way to set up my wheel after you have set up your wheel here it really is a quick set up in game to fine tune it to a specific game







    On Vista it is the same and on XP it is a bit different on control panel it is under Game Controllers then your wheel but apart from that it is the same

    I hope this helps
  3. yes you can put deadzone on zero on controller menu in game
  4. In the game is set on 0.. so i don't know where more to look..
    Also, my wheel doesnot have the same properties in control panel as the G25.. as it is cheaper one..
  5. can you set those numbers in the advanced setting wheel 0% 100% 50% 0% 100% 0% 100% and look if it's better ?
  6. I have degrees of rotation set at 240 and 260 for Monaco with DFGT. 200 deg is good with the DFGT.

    Logitech profiler
    OES 100
    SES 0
    DES 0

    CSS 0

    check boxes in menu

    ingame 0, 100, 50, 0, 100, 0, 100
  7. [​IMG]

    What you described is the fine tuning I had to do for this game
    but My Wheel settings have remained the same In win7 control panel as it will for every game meaning the Logitech profiler that was mentioned in the first post it over complicated because for every profile you wish to set up you have to go find the .exe make all settings changed needed fo that game and then save it then when you run that .exe the logitech profiler will load your settings
    my way means you find a wheel rotaion and FFB setting you like and click OK then your wheel is set how you like it then when you get a new game you enter goto the settings tweak it and your done. I just feel it is easier than making a lot of different profiles
  8. i have the number set just like you, 0 100 , 50 0 100 50, and i still get the same thing.. i will make a video tonight, tomorrow i'll upload it, so you can see what is happening..
  9. this must be unplayable. nothing about that on internet
    did you try to delete and reinstall the lastest driver ?
    in profiler you enable the case "allow game to adjust" ?
  10. get rid of the logitech profile just delete it and set it via windows
    Unless it is the wheel I would most def download and install the latest drivers for my wheel