1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

G27 Steering Not Detected

Discussion in 'Richard Burns Rally' started by yzed608, Jan 28, 2012.

  1. Hey guys, just got RBR and I'm having some problems. I'm on Windows 7 and did not install to C:\Program Files (put it on a different drive). The game seems to work fine but when I'm setting up my controls it doesn't detect the steering for the g27 at all. It detects the pedals fine, it detects the buttons on the h-shifter fine, it even detects the buttons on the wheel fine, but it doesn't do anything when I turn the wheel.

    Tried setting up a separate profile for RBR in the Logitech Profiler but that didn't help any. If it means anything I'm using the Mulligatawny profile, I don't think that matters though.

    The wheel does work still, just tried it in LFS real quick and everything is fine with it.
  2. Warren Dawes

    Warren Dawes
    Premium Member

    Did you install the 2 official RBR Patches?
    Patch 1.02 is needed for many steering wheels.
  3. Sorry, forgot to say I did install both patches.
  4. I solved it, I had to unplug my Xbox 360 controller for it to work. I guess it used that as the primary device over the wheel.
  5. Warren Dawes

    Warren Dawes
    Premium Member

    Thanks for letting us know, might be useful to others.