1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC G27 force feedback under Bootcamp

Discussion in 'Assetto Corsa' started by sbishop1488, Jan 6, 2015.

  1. Hi,

    I have a Mac with Assetto Corsa running under bootcamp (which it runs perfectly) but I'm thinking I'd quite like a Logitech G27 rather than using a Xbox controller.

    I know you can run a Logitech FF mod to get force feedback working on the Mac side for games like Dirt 2, F1 etc but I wondered if anyone has this wheel with it working with force feedback under bootcamp with Assetto Corsa?

  2. Frank

    Administrator Staff Premium Member


    Bootcamp simply installs Windows on Apple's hardware (which is no different than any other PC nowadays) so it will be using Windows drivers, you should not have any issues.
    • Agree Agree x 2
  3. Great, thanks, looks like I'll be picking up a G27 next week!
  4. As I thought force feedback isn't working, not sure if the actual Logitech software is installing since I can see nothing anywhere related to Logitech.
  5. You already solved any issues, is the wheel working as it should using the bootcamp? If not, give details.
  6. Frank

    Administrator Staff Premium Member

    I just tried installing a g27 on a Macbook Pro with Windows 7, works fine. I just used the drivers from logitech's website.
  7. Thanks, got it working in the end. The driver wouldn't install but when I calibrated the wheel with the standard windows calibration tool, restarted the Mac and then attempted another reinstall it worked fine, very very happy.
    • Winner Winner x 2
  8. Yes the wheel is working 100% fine with full force feedback. The rev/led doesn't work but this hasn't being programmed into Assetto yet, works ok in F1 2014.

    If i started again i would plug in the wheel, calibrate it with the standard windows tool restart, install the driver (if that fails to install) restart PC and try again. Once the installer actually works and just doesn't skip to complete it works a treat.
  9. Frank

    Administrator Staff Premium Member

    Sounds like you got USB 3 ports.
  10. Yes, late 2012 Mac, 4 USB 3.0 ports. It seems like the developers of the hardware have got lazy with updating their drivers, USB 3.0 is supposed to be 100% backward compatible with USB 2.0, obviously not with the developers drivers. A lot of these products are expensive and top of the line, you'd think these large organisations would have resolved these issues by now, a lot of high spec new motherboards have USB 3.0 ports only for PC's, this is only going to disgruntle customers.
  11. Frank

    Administrator Staff Premium Member

    Most wheels + USB 3 have the issue you describe. It is a complicated matter, not something you can fix with drivers as it is a firmware issue.