1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

G27 centering spring...

Discussion in 'F1 2010 - The Game' started by Eric Parker, Jun 16, 2011.

  1. So I broke down (got drunk) and decided to buy one. And its nice and what not, but my problem is every time I load the game the auto center spring comes on and really stiffly too. In the logitech profiler I have the centering spring strength set to 0% but it still is there in game. Being quite unfamiliar with the wheel I am sure its just something I am overlooking, but I must say its pretty annoying. Thanks.
     
  2. Do you have "allow game to change settings" checked in the windows settings? If so, try unchecking it.
     
  3. Hmm, nope. Still doing the same rotten thing.
     
  4. There are numerous threads scattered around here about the g25/27 regarding this. I'm guessing that when it returns to centre it judders rather violently right?

    Ok, I'll recap what I can.

    Don't put any settings to over 100%.

    Delete your F1 2010 logitech profile. You must not have a F1 2010 profile to start with, get it working as a default global profile first.

    Reset both Global device settings and Global profiler settings. In global device settings, press set default.

    Global device settings:

    overall effects str 100% (you can put this lower if it's still too strong, but never over 100%)
    spring effect 0%
    Damper effect 0%
    enable center spring in FF games = ON
    centr spring str = 0%
    report combine pedals = OFF
    degrees of rotation = 200
    Allow game to adjust settings = ON

    This should make your steering wheel good.

    You can add a profile, once you have the global device settings working, but set the profile settings the same as the global settings. You must use the file "F1_2010_Game.exe" otherwise I think it goes wrong.

    Firstly, I'd like you to tell me how the steering wheel is without a F1 profile. Lets get that working first, as there are a few other things that you might need to do to fix it, but i'd rather not do these if necessary, it requires that you uninstall the usb drivers for the wheel.
     
  5. Why do you enable the center spring in FF games if you then set it too 0%? Why not just disable it? Does it make any difference between the Enabling the center spring and set it to 0% vs just not enabling it at all (and leave the % to whatever).
     
  6. It probably doesn't, it's just the settings that I have and it works, so I don't fix it. You can probably just switch the centre spring off and it'll be ok.

    On a different note, F1 2010 doesn't do the G27 justice with the FF. Unless there are some magical settings that make the FF work much more realistic than I have used above. I did do some experimenting, but came to no valid setup. When you lose grip in a turn, the wheel should provide some feedback and give less opposing force to the turn, (ie go loose as the car wheels have much less friction to oppose the turn) However, the steering wheel only goes loose when you totally spin out, even then it is very unnoticeable. If you compare this to rFactor for example, soon as you loose grip, the steering wheel makes this noticeable, F1 2010 does not.
     
  7. Hmm, still seems to be doing it, though I am either getting use to it or just ignoring it by man handling the wheel. I wonder if its a matter that I am running through Steam, or if I should try the 32bit version instead of 64bit (even though I am running Win7, don't know the steam version of the game might run as 32bit). Don't know, but thanks. And yes I had looked up the settings threads before, but didn't see anything about this little problem.
     
  8. Hi Eric,

    I've also struggled with many different g27 setups when i started with f1 2010, and this one is the best one imo (of course you can change the FFB settings to your liking ingame):

    http://community.codemasters.com/forum/f1-2010-game-1316/429418-g27-wheel-f1-2010-a.html

    On a side note: It's true that the g27 FFB is mediocre in f1 2010, but that's just Codies fault. When you get used to it the low FFB settings are actually an advantage. I race alot of long (50% and up) races in different leagues and with a strong FFB you will be exhausted halfway the race, the setup posted above is much better in that case.

    Side note 2: The specific game settings in logitech profiler do NOT work properly for f1 2010, you will have to use the global device settings instead (as stated in the link).

    Good luck!

    *edit* Kinda looked over your issue with the centering spring.. :p I have both the DVD version and the steam version of the game. When you start the game through steam the wheel is supposed to start rotating to its steering limits up and down once, and then reset back at the center position (at least in my case the wheel does this everytime i start the game).
     
  9. I have the steam version running Win 7 64 bit, using 64 bit logitech keyboard and wheel profiler (G15 & G27) Both work fine.

    I have posted several comments about this issue before, I think they are in the main thread, not setup thread.

    If you haven't already, try uninstalling the Logitech stuff from Human Interface Devices:
    Logitech G27 Racing Wheel USB
    Logitech G27 Raching Wheel USB (HID)
    Logitech Virtual HID Device (maybe 2 of these)

    reset as many options in the wheel profiler as possible, set default etc.

    You shouldn't have a profile for F1, if you do, then delete it and get it working without one.
    Options->Global profiler settings -> Defaults
    Options->Global Device settings -> Defaults

    What are you in game FF settings?
     
  10. For some reason it seems to be attached to the "over all" FFB effect, but considering I don't like to rattle my desk apart, this can be mitigated.