• Racing is not a matter of life and death. It's much more important than that!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. If you have any questions, please don't hesitate to ask. There's no such thing as a stupid question.

Fixing the sound

Discussion in 'F1 2013 - The Game' started by smasha, Dec 27, 2013.

  1. smasha

    smasha
    Premium

    Messages:
    166
    Ratings:
    +42
    Got this in the steam sales and have had sound problems galore with it.
    Narration videos work now and then and the car engines sound goes silent after switching to the next scenario.

    Thank God I didn't buy it at full price.
    A buggy mess.
     
  2. smasha

    smasha
    Premium

    Messages:
    166
    Ratings:
    +42
    I'm getting a sound problem as soon as I go to the next scenario.
    The video narratives go silent as does the sound of my car engine.
    Anyone know a fix?

    I've put the same question on the Steam forums and no answers.
     
  3. smasha

    smasha
    Premium

    Messages:
    166
    Ratings:
    +42
    Tried disabling cloud,running direct x setup,turning off in game community.
    I also verified the integrity of the game.
    Sound bug still there.

    And I get black screens after a few laps.
    Ran benchmark and I'm getting a solid 60fps.

    This game is so buggy.
    Googled for answers but couldn't find anything.
    All other racing games /sims working fine soundwise.
    Only this POS not working.

    F1 2012 works fine.

    Just lucky I got it on Steam sale because all my other F1's don't do this.
     
    Last edited: Dec 27, 2013
  4. smasha

    smasha
    Premium

    Messages:
    166
    Ratings:
    +42
    Does not work for me as I have that setting anyway.
    F1 2013 is a big pooey load of buggy soup.
     
  5. Bram

    Bram
    #27 | Roaring Pipes Maniacs Staff Premium

    Messages:
    41,656
    Ratings:
    +15,962
    You have now replied to three threads stating the same problem. Merged them all back into this single topic.

    No need to dig up more all sound threads and bump them.

    When using "pooh", "buggy", "mess" and such words I doubt anyone will spend their time replying to this thread either.

    If you request for help try to be a bit more friendly.
     
  6. smasha

    smasha
    Premium

    Messages:
    166
    Ratings:
    +42
    Sorry Bram but I start going into boiling kettle mode when I can't fix something after a few hours.
    I'll try running the exe as administrator.

    My last hope.
     
  7. Bram

    Bram
    #27 | Roaring Pipes Maniacs Staff Premium

    Messages:
    41,656
    Ratings:
    +15,962
    Or post some system specs otherwise its like looking for a needle in a haystack.

    Running games as an admin is always recommended, so thats a good one.
     
    • Like Like x 1
  8. smasha

    smasha
    Premium

    Messages:
    166
    Ratings:
    +42
    Seems to have fixed it lol.
    Should have done that in the first place but sometimes you don't trust your instincts.
     
  9. Bram

    Bram
    #27 | Roaring Pipes Maniacs Staff Premium

    Messages:
    41,656
    Ratings:
    +15,962
    Running as admin did the trick?
     
  10. smasha

    smasha
    Premium

    Messages:
    166
    Ratings:
    +42
    I'll try a few more scenarios to be sure.
     
  11. Chris Jenkins

    Chris Jenkins
    Driving til the wheels fall off

    Messages:
    2,562
    Ratings:
    +515
    I keep getting sound issues on the PS3 version.
    Whenever I select 'Flying Lap' in the garage on career mode, I get a massive loud distorted noise until I pause the game, then once I un-pause, I get no engine sound.

    Seems to happen every time.