1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Fanatec CSR

Discussion in 'Stock Car Extreme' started by litnin, Jul 13, 2012.

  1. I've just downloaded the game but i'm having trouble mapping my Fanatec CSR.
    If i click on for example 'throttle' it automatically binds the mouse to the throttle.
    No matter what i click on it just binds my mouse to anything i try to map.
    I have the same problem with simraceway (its rfactor based as well).
    Really frustrating as i'm dying to try this out after reading so much about it. My trial is about to run out too so i'd like to get this sorted b4 i buy.
     
  2. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Are you sure its not a problem with your mouse as it happens in multiple games?
     
  3. No i'm fairly sure its the wheel as i can select a bind normally when the wheel is turned off.
     
  4. If I were you I would backup my controller folder somewhere just in case, then delete everything inside that folder within the games directory, restart all your mapping. As well have you tried another mouse?
     
  5. Well unfortunately my trial period has expired. I had to play with the G25 profile on auto gears. Got a few laps in and it did seem really good but unless i can guarantee it'll work i'm not willing to buy just yet.
     
  6. I can confirm that GSC works with the Fanatec CSR (non elite version). I've been using it for over a month without issue. I setup a custom profile and was able to map the buttons without the problem you are describing..

    I wonder if this might be a driver/firmware issue? Do you know what versions you are using? I'm using driver 115, firmware 737. I specifically have not upgraded to the beta firmware/drivers because I'm afraid it will break GSC.

    You might want to send Reiza and email describing the problem you had, and ask them for an additional trial period. Good luck - I really hope you can get things working because the game is totally worth it.
     
  7. Thanks rakke17 thats what i've wanted to hear, another CSR user. Ok, i've tried two dif drivers 116 and the new 129 but i'm gona download and try the 115 drivers now. I'm not sure about the firmware tho. I thot 737 was beta?
     
  8. I have CSR with 129 beta drivers + 742 firmware and GSC is working fine.
     
  9. This is driving me nuts!!!
    Jari or rakke can one of you please send me the profile you use for your CSR. Its the .ini file in the userdata\controllerr folder.

    Cheers for all the replies guys.
     
  10. Sorry Litnin - I would do so in a second, but I'm out of town now and don't have access to my gaming pc (no GSC for two weeks is killing me). Hopefully Jari or someone else can beat me to it.

    Otherwise I will do so once I return. Good luck!
     
  11. Didn't work Jari, but thanks for trying. The configuration was completely different for some reason :(
     
  12. Did you try clearing all mapped wheel keys and remapping them ?.
    Also changing the wheel, mouse and any other device to another USB port is one thing you could try.
     
  13. Thats the problem, i can't remap any wheel keys. As soon as i click on something it binds right away and doesn't give me a chance to select a new key.
     
  14. Did you try connectig your devices on different USB ports ?.
    Also disabling USB legacy support from BIOS is wort trying.
    I have run out of suggestions. :)
     
  15. lol me too. tried dif USB ports. Dif mouse. Just about everything.
    I'll try the Legacy.
    Thanks for all your help Jari. I'll post back when i get it sorted :)
     
  16. I guess i'm too late to help but just in case anyone else has a similar issue....

    If you have the H-Pattern shifter plugged in but haven't configured it then this would be one reason why other buttons can't be mapped.

    Search for how to configure you H-pattern shifter and follow the instructions.
     
  17. Is your H shifter not perhaps selected in a gear in stead of being in neutral?