1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Error: Could not find any compatible Direct3D devices

Discussion in 'Richard Burns Rally' started by bigmastersabre, Aug 23, 2011.

  1. Hello, can anyone help me? I wanted to play RBR after some time and this message occured: Could not find any compatible Direct3D devices... I've tried to reinstall directx and graphic drivers as well as the game itself but nothing works. Got Win7 Ultimate 64bit, Athlon 64 X2 2200 MHz, 4GB DDR2, ATI Radeon HD 4850, Asus M2A-VM motherboard and the newest graphical drivers and newest DirectX drivers, please HELP!
     
  2. What screen resolution are you trying to run the game in? I've had that message before when I've tried to run the game in a resolution not supported by my graphics card.
     
  3. That is really weird, I had reinstalled the game one more time and now it is working perfectly well even in resolution 1680x1050, but thanks.
     
  4. Decenten

    Decenten
    Driver of the #73 Team OGMRZ Holden V8SC Premium Member

    Hey guys got the game now and have this issue. I run 1920x1280 and I get this error
     
  5. Warren Dawes

    Warren Dawes
    Premium Member

    Two basic things to check first (assuming you are running the base RBR, not RSRBR2015):
    1. Have you installed the two official Patches 1.01 and 1.02?
    2. Have you tried running a different Resolution?
     
  6. Decenten

    Decenten
    Driver of the #73 Team OGMRZ Holden V8SC Premium Member

    I fixed it in the end. I used dxdiag and found that the resolution I needed was actually 1920x1080. Now just need to get RSRBR 2015 going and I am set.
     
    • Like Like x 1