1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

DDS Alpha Problem... Or Is It?

Discussion in 'Off Topic' started by Drummer, Jul 13, 2012.

  1. Hi all!

    I'm hoping someone can help me with this, as I've asked about this numerous times, but received no help with it. I created a DDS of an armco barrier with an alpha transparency for the slots in it. I'm placing it onto a wall which I've shaped to resemble an armco in BTB and exported it to Rfactor. It seems no matter what I do I'm getting a translucent effect throughout the entire wall. I've tried importing it to 3DSimEd and setting it to double sided, but I can still see through the whole thing, as if it's made of plastic film. The black and white on the DDS' alpha channel are 0, 0, 0, and 255, 255, 255 respectively, so there ought to be no shades of grey there. Maybe I could send someone the DDS to look at, please? I'm getting towards the end of my tether with this and I really hope someone can help! It's the first DDS with an alpha that I've ever done, so I'm well aware that it's likely what's causing the problem, but I just don't really know what I'm looking at to be honest.

    Many thanks.
     
  2. Double check your 'compression' setting. When saving an alpha dds in Gimp I choose BC3 / DXT5 as the compression level. There are other DXT5 options that for me have never been anything but trouble. I think you can choose the lower options for that sort of on/off alpha, but I always stick with the setting I mentioned.

    Failing that, check your material settings in 3dSimed. The blend mode should be 'Simple'. If the material has multiple channels (e.g. normal map and spec map) maybe BTB has assigned the wrong textures to the channels. If the shader is, say, "bump specular map T1", check the sections below to see if your specular map and bump maps have been assigned the correct texture.

    I haven't used the beta version of BTB so this is just a guess, but it could be that you've selected 'diffuse, bump and specular' but for some reason it's exported it as 'diffuse, multiply and add'.

    If you check those things but they all seem fine then I think you should upload the texture. I can't guarantee that I'll be able to look at it, or that I'll know what to do, so I recommend posting it publicly so that anyone who's passing can have a look.
     
  3. Hi again, Soul!
    Thankyou very much for your help! I've re-saved the DDS with the compression settings you specified, applied it with SimEd and set it up the way you've advised and I did notice that it's applying the default cement wall maps on the other channels. Baring in mind I don't yet have a bump or specular map for this yet, I decided to try the T1 diffuse shader, but the armco still appears translucent ingame.

    Something else I tried was removing the reverse face of the wall that I created, because all my armcos were coming up single sided. I tried this because I noticed the 'double sided' checkbox in SimEd. So, I've checked it and tried it out, but the armco is still showing as single sided. It was the close proximity of the rear facing surface to the forward facing one which was causing my horrible shadows, so a shadow only wall looks to be the best seller for that, but I just can't think for the life of me why it's still showing translucent!

    What I'll do is try and create an xpack of the wall cross section and upload it somewhere. Where's the best place to upload it for folks on here?

    Many thanks for your help. I really hope we can get there with it, as I want some nice screenies to put into a WIP topic. :'(

    [EDIT] I tried and tried and tried and I finally got the 'ump and decided to scrap the idea of a DDS altogether and go with a jpg texture and sacrifice the little slots in the armco, but the problem is exactly the same with the jpg! Just to be sure it wasn't the actual shape of the wall, I tried one of the default concrete wall textures on it and it looks fine (apart from being concrete instead of steel)!

    I'll upload the DDS somewhere and hope that someone can help, because this is just beyond me completely! :confused:

    Rapidshare link to my armco DDS file: https://rapidshare.com/files/3906992560/armco with transparency.dds

    Can someone please take a look at this and see why it's misbehaving, please? Feel free to use it for whatever you like, if you can get it working. :-/ (Copy/paste it with the spaces, sorry)
     
  4. There's nothing wrong with the texture. From your description it sounds like BTB is assigning the wrong shader. Are you using the beta version (0.8.9)?

    When you set the material to use a jpg, did you remember to reset the Transparency to None? Maybe the bug is triggered by the chroma or alpha setting.

    When you tried resetting the material in 3dSimed, did you export the object to the correct folder? You might have accidentally chosen the wrong one so the old objects didn't get overwritten.
     
  5. It's more than likely in the GMT settings. I have had issues with them occasionally.

    Edit.

    Yes, made a GMT in 3D simed, and loaded it up in rfactor, Perfect. Settings default except transparency blend set on multiple.
     
  6. When I used the jpeg I did remember changing the transparency to none, yes. I didn't export the object, I exported the entire circuit to Rfactor from SimEd; is that bad?

    Gazzari, could you explain exactly what you did please? I'm very unfamiliar with using SimEd in this way. I'd rather keep all my armco walls from BTB, as they're all placed and have their cross sections edited properly.

    Many thanks for your time!
     
  7. No, that's okay. Exporting the circuit exports each object, so no harm done.
     
    • Like Like x 1
  8. I'm still no closer to figuring this out. Can anyone advise, please?
     
  9. It's been a month folks; if you're able to get it in and working properly, how are you doing it, please? What exactly are all the settings that you're using and where? How do I apply these settings? Maybe someone can send me a cross section or something? I really am completely stuck on this and it's looking like a project stopper and all because people aren't talking to me. Come on, I'm not asking much, am I?
     
  10. Here's the BTB project in which I tested your dds file:
    http://www.mediafire.com/?89f3tvh73msnqx7
    Extract to ...\BobsTrackBuilder\My Projects

    These zip files need to be copied from your ...\BobsTrackBuidler\XPacks folder to your project's "XPacks" folder:
    Common.zip
    Default.zip

    This was made in BTB Pro version 0.8.0.3.

    Check the venue materials ([​IMG]) and look for Wall\Cement\AlphaArmco
    -----
    Edit

    Here's the rFactor track:http://www.mediafire.com/?qs0rbobhu8e1var
    Compare the armco material settings in this to the one used by your own track.
     
  11. Thankyou very much for your help! Yes, your track's armco appears just fine in my Rfactor and, when I check those materials in 3DSimEd, they are different. However, I'm having trouble saving my newly edited track from SimEd, as it doesn't appear to be updating the original. I've been to The Pits forum and asked for help there and am awaiting a response, but I think this is where my problem lies, so if I can just get what I have in SimEd into Rfactor, I think I may be well away.

    I'll keep you posted on the outcome, of course. Thankyou again for your help!

    [EDIT] Sorry, I forgot to mention that your project file won't load in my BTB; probably because mine's a different version (0.8.0.0) so I'm unable to check the materials on it. I'll keep trying with SimEd though and see where it gets me.
     
  12. Ok, I've tried and tried and tried until I'm almost sick. I've given myself countless headaches and even brought on a migraine over this, it's ridiculous, I've no idea what the Hell is going on as nothing I try to do is working for me at all. I'm willing, as a last resort before I delete the entire damn thing from my computer and kill the whole project stone dead, to send this project file to someone, in the hope that they can fix it. Once they have it, it's free for them to do with as they please, as long as it's never released publicly or passed on to anyone else; it must be kept to yourself.

    It's still very much a WIP, but I'm going no further with any of it until I know for an absolute fact that I'm not going to keep suffering with this stupid error with the materials.

    So, is there anyone out there who'd like me to send them this circuit, with a view to fixing the problem, please? If so, please tell me exactly what to do; every little bit. I don't know if I need to simply zip up the project folder and you'll be able to see it, or if I have to include other things or what the heck I have to do, so please tell me everything that's needed, in what order and everything. Treat me like I can't even understand plain English, I don't mind, as long as it's completely and utterly 199% obvious what I need to do, because this entire thing has become a complete and utter damned farce for me, I can't even get my head around how to paint a friggin' gravel trap onto my grassy areas without it looking shockingly bad, so please don't doubt my sheer ignorance and stupidity. I know literally nothing about any of this! ;)

    I really hope this gets fixed, one way or the other, because it'd be a horrible shame to waste all this work. I really need a partner to help me with it, but there you go.

    Many thanks.

    Forget that, I won't bother with these stupid walls. -.-