• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Have a chance to win a copy of F1 2017 The Game (PC) by following RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and / or YouTube.

CPU usage - stuttering AI

Discussion in 'rFactor 2' started by dave kirk, Mar 11, 2017.

  1. dave kirk

    dave kirk
    Premium

    Messages:
    163
    Ratings:
    +36
    Hi everyone,
    I've had the game/sim for about 4 months and it has always run perfect for me, but the last week the AI has started to stutter when it previously didn't, I checked the CPU and it has gone upto 100% in places, I don't understand why this has started to happen when it didnt previously, I run a AMD 4.3ghz processor, I am not too tech savvy so I am looking for advice/remedies

    Thanks in advance
     
  2. John-Eric Saxén

    John-Eric Saxén

    Messages:
    1,389
    Ratings:
    +746
    rF2 AI are CPU hungry, in particular on banked oval tracks. It also depends how many AI you run and what car/track combo, as I would assume some mods are not very optimized. There is no setting in the game that will reduce AI CPU usage I'm afraid, but you could try to overclock the CPU. AMD FX CPU's, which I assume you have, have poor single-core performance, so it translates to poor gaming performance in most games.
     
  3. dave kirk

    dave kirk
    Premium

    Messages:
    163
    Ratings:
    +36
    I understand that and I have had no problem until a few days ago, i run high frame rates and was less than 50% CPU at all times, it seems that since the last update something has changed in my settings, I still get high frame rate but the CPU is always 75%-100% and my car phsyics are most of that,
     
  4. Mark Greenall

    Mark Greenall

    Messages:
    3,221
    Ratings:
    +2,527
    Delete replays maybe? Sometimes if Harddrive is near full this happens.
     
  5. Ace King

    Ace King

    Messages:
    396
    Ratings:
    +77
    Your CPU usage will considerably be reduced by lowering the "Visible Vehicles" thus allowing you to race with many more AI. As an example there is a great looking Spa track converted from AC but it's poorly optimized and runs my CPU at 100% with 30 AI but if i set my "Visible Vehicles" to "18" i can easily run a full grid with no issues!

    Sometimes after a new build it's necessary to delete your old "player.json" and config.ini if experiencing issues:
    1) Remove the player.json and config.ini (cut/past to desktop to keep a back-up)
    2) Launch rF2 and it will create a new clean config.ini and player.json.

    Another Note:
    Go in your "Task Manager" to observe if there are any processes using excessive CPU usage thus reducing the available CPU power needed for rF2.
     
    Last edited: Mar 12, 2017
  6. dave kirk

    dave kirk
    Premium

    Messages:
    163
    Ratings:
    +36
    Thanks for the help guys, I have tried all that and the CPU still runs nearly full all the time when previously it was half, it all seems to be since i installed the 1988 F1 mod with the tracks and stuff, could this have caused it?
     
  7. dave kirk

    dave kirk
    Premium

    Messages:
    163
    Ratings:
    +36
    I seem to have fixed the issue
    I changed default for Controller.JSON value “Use thread” from “false” to “true”.
    Then I used my Radeon graphics cards settings to override the Rf2 ingame ones and now it runs at approx 50% most of the time going upto 80% absolute max, with all the settings on full or high
     
  8. dave kirk

    dave kirk
    Premium

    Messages:
    163
    Ratings:
    +36
    false alarm, NOT FIXED :)
     
  9. dave kirk

    dave kirk
    Premium

    Messages:
    163
    Ratings:
    +36
    Finally fixed, very strange
    I underclocked my CPU and now it never goes over 50%, all I can think of is that it was overheating and losing performance
     
  10. Ace King

    Ace King

    Messages:
    396
    Ratings:
    +77
    Overclocking needs to have excellent cooling on the CPU plus good case airflow or it will affect the lifespan of not only your CPU but all components. Monitor those temps!

    Good to hear you discovered your problem before any component failure.
     
    Last edited: Mar 13, 2017
  11. dave kirk

    dave kirk
    Premium

    Messages:
    163
    Ratings:
    +36
    Thanks, the CPU was overclocked slightly when I got it, so it must have spent a year getting too hot, now I have another problem though lol.
    Now I have a 1-2 second freeze every so often, i don't understand why it is happening, the CPU is running at 50% the GPU is having no problems either?
     
  12. Ace King

    Ace King

    Messages:
    396
    Ratings:
    +77
    A background process might very well be the cause of this freeze.
     
  13. dave kirk

    dave kirk
    Premium

    Messages:
    163
    Ratings:
    +36
    That's what I thought, but I turned off everything else, disconnected from my network, turned off anti-virus software, all notifications etc were blocked and it still happens
    So confusing as the game worked perfected until about 2 weeks ago
     
  14. Marc Collins

    Marc Collins

    Messages:
    570
    Ratings:
    +166
    Get rid of all overclocking and overclocking-related monitoring software for CPU and GPU. Also, make sure you use only a WHQL graphics driver, not necessarily the latest one available. I am 99.9% sure everything will be back to smooth sailing if you do the aforementioned. You need to be tech savvy to overclock without causing more problems than you cure and even then it is rarely worth it. Just save up for newer/better equipment and replace as you can. In the meantime, live within the performance of your current equipment.
     
    • Agree Agree x 1