• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

CPU Occupancy 99% | How to solve (Hardware advises)

Discussion in 'Assetto Corsa' started by Shadowoff, Sep 3, 2017.

  1. Shadowoff

    Shadowoff

    Messages:
    108
    Ratings:
    +41
    Heyy,
    I have some trouble playing with a lot of AI's. Everytime I play with 40+ the CPU occupancy warning pops up. I already use half FFB rate, enabled multiple cores in Windows and lowered my graphical settings but its still a thing. So i guess that my hardware might not be the best anymore. My question is know: Which kind of hardware do I have to update?
    I have actually no clue at all so Im glad that this forum exists ;)
     
  2. RasmusP

    RasmusP
    AC Stuff and G27 help Staff Premium

    Messages:
    2,099
    Ratings:
    +784
    Hey man,
    AI is CPU (processor) only! And at 40+ of them, most overclocked i7 are already dying so don't wonder! There are no settings to really improve that :(

    Please give us your PC specs though.
    CPU (processor)
    GPU (graphics card)
    RAM (DDR3 or 4, MHz and how much of it)

    Rest doesn't really matter for your problem :)

    Little advice for you to try: disable all apps (the overlay things if you may have no clue about them).
    Just move your mouse to the very right and click on the icon on top of the list "hide all apps".
    Have a look at your fps now, should be a bit higher :)
     
    • Agree Agree x 1
  3. Shadowoff

    Shadowoff

    Messages:
    108
    Ratings:
    +41
    Heyy,
    thanks for the response. Im having a Nvidia Geforce 960 GTX, i7 4790 @3,60 GHz (both slightly overclocked and I already enable mutliple cores in windows) and 8 GB ram (dont know whether DDR3 or 4, but it should be DDR3).
    Also FPS arent the problem. Im having consistent 70-90 FPS. Regardless od that I'll definetly try disabling all apps.

    *Edit: Even though I get the 99% warning my task manager tells me that the CPU is just at around 60-70%. Is there a way to find these missing 30%?
     
  4. RasmusP

    RasmusP
    AC Stuff and G27 help Staff Premium

    Messages:
    2,099
    Ratings:
    +784
    These 30 percent... Yeah I have no clue! I have a similar problem, no solution :(

    But I may have a solution for you: lock your fps at 60 or something lower than your minimum now. A general thing when gaming is that all the time either the CPU or the GPU will be at their limit if you don't lock the fps. Lowering the graphic settings will result in a CPU limit, putting all settings to the absolute max (and probably run in 4k) will result in a GPU limit.

    You have a CPU limit because of the many AI.
    Lock your fps and your hardware won't run at its limit anymore and hopefully the warning won't show up :)

    To my problem: I have fps drops below 60 fps because of the apps I run. My CPU is only at 40% and my GPU at 30%... Strange game this Assetto corsa, but I love it :p
     
    • Haha Haha x 1
  5. Shadowoff

    Shadowoff

    Messages:
    108
    Ratings:
    +41
    Haha, thanks for the advises ;)
     
  6. PhilS13

    PhilS13
    Premium

    Messages:
    221
    Ratings:
    +139
    CPU occupancy is not related to FPS. CPU occupancy is strictly about the ability to make the physics loop calculation in less than 3 milliseconds. You'll see that load on the PHY line in the render stats app.

    40 AI is going to be hard to make happen no matter the settings or FPS.

    Low CPU usage in task manager is related to AC not fully using multiple cores. If you look per core you will likely find one at max capacity.

    If I'm not mistaken all physics calcs must happen in the same core. The main thread also can't be spread over multiple cores.
     
    • Like Like x 2
    • Agree Agree x 1
  7. JoelGL

    JoelGL

    Messages:
    1,146
    Ratings:
    +84
    Just to clarify, why lock to 'minimum'? Like if fps goes between 40-70fps, then locking to 40fps will be really slow and juddery.
     
  8. RasmusP

    RasmusP
    AC Stuff and G27 help Staff Premium

    Messages:
    2,099
    Ratings:
    +784
    To give the hardware actual "headroom" it needs to be the minimum. Otherwise the hardware will reach it's limit.
    The op stated he gets 70-90 fps. I wouldn't recommend that with 40-70! :)

    In fact, I hate stuttering, tearing, flickering etc etc. 60 fps + vsync (pre rendered frames to 1) + sgssaa it is for me :p
     
    • Haha Haha x 1
  9. RasmusP

    RasmusP
    AC Stuff and G27 help Staff Premium

    Messages:
    2,099
    Ratings:
    +784
    Very interesting details that I didn't know. Thank you for that!

    A little note to the CPU cores: nope, I don't have any core at any time over 60%. But I will have a look at the PHY line and check if I can see changes when disabling apps, increasing AI numbers etc! :)
    BTW: my fps drop significantly when I disable hyperthreading. You have an idea why? Still no core at more than 60% load...
     
  10. Zoltan76

    Zoltan76
    Premium

    Messages:
    70
    Ratings:
    +18
    I run into CPU limit above 6 opponents. :D
     
    • Haha Haha x 1