1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot see anything but the SKY.MAS file when I export

Discussion in 'Bob's Track Builder' started by ThreeDays, Jul 19, 2010.

  1. Hi, everyone,

    I've had a really annoying problem with an RFactor track I'd already spent upwards of 60 hours on (which, for me, is something like 5 months because I don't have all that much spare time!): when I export, it says it's done everything OK, but then, when I open the track, all I see is the picture from the sky.mas file. The car is floating in mid-air, but there is obviously something there because I can start the car up, run on the road and hit the walls, even if I can't see them!

    I had exported this same track several times to try it out and it had worked OK, but nothing works now. I was adding objects from some Xpacks I'd made, plus others I'd downloaded from this page and it all went wrong, although I have no idea whether it is related.

    I'll post some pictures this afternoon, although there really is not that much to show!:mad:

    Any help would be really appreciated. I don't need to tell you how annoying it is to be working a bucketload of hours on a project only for it to go wrong for no apparent reason!
     
  2. Sub

    Sub

    Funny - i've had almost the same problem. Everything that i can see in front of my car loads, but the ground beneath the garages is gone and my car just floats in mid air. It's as if all the terrain is missing. It's fine if i don't pack it into an mas, but if i do it's screwed. I'll also be checking out that other thread.
     
  3. I think if you pack up a MAS file you have to edit your scn file.

    For example, after export from BTB, a few lines down in your scn file you will find:


    You then need to add the masfile you've created to that list

    Well, at least that's my understanding!
     
  4. Sub

    Sub

    FerrariMan! Thank you! I haven't tried it yet, but i definitely overlooked that step and it would make sense that that's the problem.
     
  5. I have started work again on this track, but I still have the same problem. I have done what that post says, but still no joy. Any more ideas?

    This is a long shot, but could an XPack be causing the problem?
     
  6. Its possible, there could be a conflict of materials or texture. Make sure all textures and materials have a unique name.
    If you have simed, you can open it up and get a better look at what's going on, you can use it to get data reports of missing textures etc etc. If you don't have simed, you can use the 20 day demo.
     
  7. I've tried removing the conflictive XPack and there's still no joy. How do I open it in Simed and check the conflicts?
     
  8. Go to Import and select the .scn file.

    Have you tried opening the track in scene viewer? That program sometimes gives error messages.
     
  9. Thanks, I'll check this afternoon, when I get home.