• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

beginner question

Discussion in 'Stock Car Extreme' started by baron12, Jan 6, 2014.

  1. baron12

    baron12

    Messages:
    32
    Ratings:
    +0
    Hi.
    I am new to racing games (playin for 2 weeks only) so still learning, hopefully this question is not too dumb. But I tried GSC2013 demo, had no problems with kart racing, I really liked it. But then I tried to play stock cars, my speed was stuck at 58 kmh for the whole race, it should only be for pit I guess? But it never changes, no matter which gear I drive in it's always stopped at 58kmh I don't know what settings should be changed?
     
    • Love Love x 1
  2. Nox

    Nox
    Premium

    Messages:
    6,682
    Ratings:
    +2,323
    Turn off the pit speed limiter :) Check your controller options to see what key it is mapped to.
     
    • Like Like x 1
  3. baron12

    baron12

    Messages:
    32
    Ratings:
    +0
    thanks :thumbsup:
     
  4. Bram Hengeveld

    Bram Hengeveld
    Administrator Staff Premium

    Messages:
    42,805
    Ratings:
    +16,615
    By default I think its the "L" key on your keyboard that assigned to switch on and off the pitlimiter. Don't forget to switch the limiter back on when you enter the pitlane :thumbsup:
     
    • Like Like x 1