1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC Anyone with a driving force GT can confirm this? D-pad not working

Discussion in 'Assetto Corsa' started by Mike Sterckx, Jul 7, 2015.

  1. I cannot seem to bind any keys to the D-pad on my driving force gt.

    This is the D-pad in case you're wondering
    [​IMG]

    All other buttons seem to work fine. I'm wondering if my dpad is broken or if it's like that for everyone.
     
  2. kedy89

    kedy89
    Premium Member

    Can confirm, can't assign any commands to it. Works fine with other sims.
     
  3. Some sims recognize it, some don't. Easy fix is to make the logitech software emulate keypresses and bind it that way.
     
  4. Thank you guys
     
  5. So I tried assigning those buttons to the in game keyboard controls. No luck :(. We're you able to get it working? I tried using keyboard commands and keystrokes in the logitech software.
     
  6. Its a bit silly how complicated it is compared other software but...

    Open your Logitech software. Ensure you select the profile for the sim you're binding the keys to. Find the entry for POV1 and click on it then select Select Assignment -> New POV Assignment.

    You should get a menu that opens which you can name. Its basically a binding profile for that POV hat. You then select each individual direction and THEN have to create a keystroke bind for that direction in a new pop up menu... bloody menus inside of menus inside of menus (its asinine but stick with it).

    Once you've done that for each direction (up down left right) you press okay and it should select that binding profile for the POV hat.

    Logitech are idiots for making it this laborious but it should work that way and then pressing the different directions on the POV hat in that game will produce a keystroke instead of a joybutton output. You then bind the output to the keyboard part of the control menu.
     
  7. so I had it set up right in the logitech software. In assetto there's an option to enable keyboard in the advanced settings. That did the trick :thumbsup:
     
  8. Settings upon settings. The simmer's life is a constant struggle with a UI bureaucracy.