Why is S3 locking me out of Free Content and ADAC?

Patrick Moore

100RPM
Nov 20, 2010
188
34
SOLVED! :)
(I do not see how to edit the thread title?)

Suddenly after a few weeks of enjoying ADAC GT Masters 2014 and a few months of enjoying the S3 demo cars/tracks the game is asking that I create an account to play the game (free content and ADAC) after hitting the START button on the steam page. I have downloaded and bought everything through steam.

edit
I did not copy the message down, but it says something to effect of
"all DLC content is tied to your steam account....blah blah blah"
If I see it tomorrow I will be careful and copy down entire message. I have the impression the steam game suddenly thinks I got everything from non-steam site?

I downloaded and bought everything through steam (downloaded game in Sept/Oct 2014, purchased and have been playing ADAC since around Christmas 2014), internet is fine, system is fine, game file integrity check-thingummy is fine. Game has always worked fine until this afternoon. It sounds like the S3 login info needs to be reentered since it disappeared from my computer or steam account. Tired and late here, I give up for today. thanks for the help, Mr. Goodwin!
:)
 
Last edited:

Andi Goodwin

500RPM
Jul 19, 2010
911
442
no seriously , you cant play the game without one , so at some point youve entered a n user name/email password , and in all likelyhood the server is on a tits up mission and isnt autologging you in

Andi
 
  • Like
Reactions: Patrick Moore

Patrick Moore

100RPM
Nov 20, 2010
188
34
no seriously , you cant play the game without one , so at some point youve entered a n user name/email password , and in all likelyhood the server is on a tits up mission and isnt autologging you in

Andi
OK, sounds like my PC or the steam account lost this login info! I will try tomorrow.

I checked my login/password book and I never created anything for S3 at any S3 site. I hope this for the game and was through steam and I used my steam email and password (assuming it was a steam thing).

Thanks for the help, Mr. Goodwin!
: )
 
Last edited:

Rella

25RPM
Sep 14, 2014
47
12
43
the game is asking that I create an account to play the game (free content and ADAC) after hitting the START button on the steam page. I have downloaded and bought everything through steam.
I had the same sometimes. Happens from time to time and it seems that some kind of synchronisation fails. Just exit and restart the game then it should work I think. (Sometimes I have to restart more often than once till it works)
 
  • Like
Reactions: Patrick Moore

Connor Caple

Slowest Racer in Town...
Nov 24, 2009
974
355
I get that occasionally and my fix is just to quit the game, log into my R3E account on the webpage and then start the game again. They seem to talk to eachother properly then :D
 
  • Like
Reactions: Patrick Moore

Andy_J

I hate VR. ( ͡° ͜ʖ ͡°)
Oct 2, 2010
7,797
3,635
God help us when the internet is down RRE should have an offline mode too. After all we have paid for a lot of the content now if we own various packs, cars and tracks.
 

Thomas Friedrich

DNA SimRacing
Jan 9, 2014
61
23
I'm not absolutely sure, but I think we don't "own" anything, we just bought the license to use it.... I just don't feel like looking that up in the EULA, but I'm pretty sure it's mentioned there somehow...
 

Thomasew

25RPM
Oct 14, 2009
32
5
This is something that S3 really, .. really, ... need to fix ... soon!!! I get the login screen about 50 to 60% of my attempts to start the game, .. which goes hand in hand with the error 503

... didn't get it once, .. before the last update. I purchased R3E, as well as 95% of the available content, in the last week of October. I have played it every day since then, .. and, more often than not .. load it up at least a half dozen times per day.

In frustration, .. I've stopped playing R3E until such time as the communication/connection issues are resolved ... as well as the 'finishing order' problem, .. also as a result of the last update.

These are both fairly serious issues, .. and being reported by many users/players.

.. we shouldn't have to wait for a regular monthly update, .. to resolve the problems created thru the last update.

Hope they fix this soon. I tried going back to AC, RF2, GSCE, .. etc. etc. to get my racing fix, .. but, they don't give me the same sense of racing, ... that I get from R3E. :)


Cheers
Tom
 

Andi Goodwin

500RPM
Jul 19, 2010
911
442
holidays + office move ... they are back , but a hotfix/update will need doing/testing etc ...so i dont see it happening before next week

Andi
 

Patrick Moore

100RPM
Nov 20, 2010
188
34
I tried the game this morning and it worked perfectly! After hitting the START button on steam the game opened directly to the RRRE Circle GUI. No S3 login page and everything worked. As Andi Goodwin stated above it sounds like it was a computer/server error somewhere along the path!


I had the same sometimes. Happens from time to time and it seems that some kind of synchronisation fails. Just exit and restart the game then it should work I think. (Sometimes I have to restart more often than once till it works)
I restarted my PC several times during the day and it always stopped me at the S3 login page. As mentioned above I think it must have been something with the servers or PC that corrected itself overnight.


God help us when the internet is down RRE should have an offline mode too. After all we have paid for a lot of the content now if we own various packs, cars and tracks.
Yes, it would be nice if RRRE did not have two layers of DRM.
What confused me with this S3 login problem is that I always assumed that Steam was the sole DRM for RRRE. When steam is not working or if my internet is not working I can still play all of my other steam games and I thought RRRE followed the same pattern.


Thanks again to everyone for the help!