When wiill Stock Car Extreme work on Windows 10?

Discussion in 'Stock Car Extreme' started by mrcds, Jul 29, 2015.

  1. mrcds

    mrcds

    Messages:
    4
    Ratings:
    +4
    Hi, I have today updated my PC to Windows 10 and I had the bad surprise that the game won't launch. I saw on another thread that SCE isn't compatible with the OS, but will it ever be ? And as I think it is likely to be upgraded, when will it be ?
     
  2. Alex Sawczuk

    Alex Sawczuk
    Reiza Studios

    Messages:
    1,401
    Ratings:
    +1,017
    There isn't any reason that I'm aware of as to why it shouldn't work... Someone just posted that the beta works fine... I don't have W10 yet tho to test myself.
     
  3. mrcds

    mrcds

    Messages:
    4
    Ratings:
    +4
    Oh I just did an integrity check on Steam and it works again ! Sorry for the inconveniance :)
     
    • Like Like x 1
  4. RGerke

    RGerke

    Messages:
    59
    Ratings:
    +5
    They game runs, but i have poor performance. Whats going wrong?
    My Graphig Cards have Usage to max 60% and my CPU Usage max 55%,
    but my Frames go down to 54 FPS. At WIndows 8.1 i have 80 - 120 FPS in
    ever Scene.

    Hmmm?
     
  5. mrcds

    mrcds

    Messages:
    4
    Ratings:
    +4
    Are your Graphic Drivers up-to-date ?
     
  6. RGerke

    RGerke

    Messages:
    59
    Ratings:
    +5
    yes, complete clean, 353.30 Win10
     
  7. Lou Sytsma

    Lou Sytsma

    Messages:
    550
    Ratings:
    +181
    I've been part of the Windows 10 Insider program and never had a problem with this game. Or any other. Quite the opposite. I find all the games I have run better if anything.
     
    • Agree Agree x 2
  8. PieterN

    PieterN
    Premium

    Messages:
    434
    Ratings:
    +97
    I'm still running Win 7. What do you mean by better ? Could you elaborate a bit ?
     
  9. Kurt Vanhee

    Kurt Vanhee

    Messages:
    586
    Ratings:
    +146
    Must say that everything runs fine Windows10.
    Even got a nice boost in FPS running in multiview;)
     
  10. Dave R

    Dave R

    Messages:
    619
    Ratings:
    +205
    I installed it yesterday and after about an hour or so, went back to Windows 7. When I tried to play SCE, it kept throwing an alert up in the bottom right hand corner telling me that SCE was trying to use the graphics card, well no sh@@ Sherlock. Couple that with the fact that NR2003 and Tiger Woods couldn't be played on W10, and Assetto Corsa and R3E had HUGE frame rate drops and I went back.
     
  11. RGerke

    RGerke

    Messages:
    59
    Ratings:
    +5
  12. Lou Sytsma

    Lou Sytsma

    Messages:
    550
    Ratings:
    +181
    Gained about 5-10fps moving to Windows 10.
     
    • Agree Agree x 3
  13. leon_90

    leon_90
    Columnist for RaceDepartment Staff Premium

    Messages:
    357
    Ratings:
    +281
    Everything perfectly fine here. Even very old sims like GPL, which is older than NR2003, run lovely.
    I agree, fps increase here too but nothing dramatic from Win8.1. From 1 to 5 fps depending on the game
     
    • Agree Agree x 1
  14. e345spd

    e345spd

    Messages:
    18
    Ratings:
    +1
    Works perfectly here on 10162 and every other version/driver combo I tested.

    w10 snuck the default drivers back onto my system again and I didn't even notice, thought I was still running 15.7 ;)

    Performance uplift in every title so far, including GSCE
     
    Last edited: Jul 31, 2015
  15. hex

    hex

    Messages:
    413
    Ratings:
    +157
    I did clean install with Windows 10 on my PC, so I had to reinstall the game due to d3dx9_30/d3dx9_40 issue (which was not fixed by installing DirectX nor by manually placing the files).

    Now it's all good :)
     
  16. trillbo

    trillbo

    Messages:
    1
    Ratings:
    +0
    I'm getting random spikes in framerate in Windows 10 in beta and standard versions, very noticeable on the pit straight and some corners in Taruma. Very distracting! I have a Titan X and latest drivers, so this shouldn't really be an issue. Anyone else seeing this?

    EDIT: I set Opponent Detail to low and it seemed to fix this. Just thought I'd mention in case somebody else is having the same issue!
     
    Last edited: Jul 31, 2015
    • Agree Agree x 1
  17. dsuspense

    dsuspense

    Messages:
    35
    Ratings:
    +4
    Upgrade to Windows 10 was seamless.
    GSCE runs fine on my system.
     
  18. Msportdan

    Msportdan
    Banned

    Messages:
    2,961
    Ratings:
    +555
    I'm getting the micro stuttering too. before I was well happy with GSC perf, now I'm not... tried turning off shadows a time scale doesn't really cure it, SV8 at imola at certain time of evening 30fps!!! 18 cars

    AC for me is running a dream, almost full whack @60fps (bar ultra reflections)
     
  19. Lou Sytsma

    Lou Sytsma

    Messages:
    550
    Ratings:
    +181
    Possible tweaks

    Check your config.ini file and see if it has settings that reflect your computer and video card's RAM properly:

    CPURating=5
    SystemRAM=8192
    VideoRAM=4096
    ObjDetail=5
    TexDetail=5

    Also in SCE Config util leave the Shader Level on Auto instead of DX9.