Wheel no longer works

Discussion in 'rFactor 2' started by Richard Coleman, Jun 29, 2017.

  1. Richard Coleman

    Richard Coleman

    Hi all.

    I've been playing rF2 for months with no worries with my wheel (Logitech MOMO Racing Wheel). All of a sudden rF2 will no longer detect it. I have tried rebinding a key on the standard AZ Keyboard and also tried the custom MOMO save I had. Even tried clicking DETECT on the controller page. That just gave a message like "Unable to find any controllers". So no joy with the wheel and rF2 now.

    I have tried a fresh install of rF2 (which took many hours) and that did nothing. I tried reinstalling the Logitech drivers.... same result. Even went so far as to try rF1.

    Strange thing is that rF1 detected and used the wheel. So did F1 Challenge (old but still fun game).

    Any ideas as to why this could have happened? Could a S397 Dev possibly be able to help?


  2. ALB123


    I just bought rFactor 2 and I can't do anything at all. It detects my Logitech DFGT but it's like my wheel isn't really connected. If I go onto the track, my car just spins in a circle. If I go into the controller options it will say something like Throttle Joy1 or whatever. If I click on the word Throttle to re-assign it to the actual throttle pedal, nothing happens - it won't register me pressing on the throttle pedal. If I hit a button on the keyboard it will detect that, however.

    I don't understand what's going on -- the game auto-detects my wheel.