RaceDepartment Store

Upcoming Events

AC events on Simracing.GP ACC events on Simracing.GP Automobilista 2 events RaceRoom events rFactor 2 events

Wheel and Pedals not working in AC after Win 10 update

So I let Win 10 do the latest update last night. Today I got nothing. Wheel and pedals show up and work in Windows, but when I launch the AC.......nadda:cautious: Configuration Wizard won't work because my hardware isn't showing up in the Detected Hardware panel.

I've uninstalled the wheel, pedals and relative drivers, removed the devices from windows. Restarted Windows, reinstalled everything, rebooted and still nothing. Repeated this process many times to no avail:( I have a Thrustmaster TX 458 Italia Edition and Fanatec CSP v2 pedals. If any of you guys have any idea how I can fix this, I would really appreciate it. We have a WEC 90 min race at Spa tomorrow and I'm the host soooooooooo 90 mins. is a long time to sit in the pits and watch everyone else race:unsure:

I'll be out of the loop for the rest of the day due to my awesome daughter taking me to see these guys in concert tonight:)
so I'm thanking you ahead of time for any responses or help:thumbsup:
 

Dirk Steffen

Porsche Factory Jackass™
I don’t have any direct tips regarding getting your controls back in AC (when they show in the Win controller menu and also work there, they should work in AC) but I came to write that you have an awesome daughter who is willing to drag this old fart to a concert with proper music ;-)
I love the Foo Fighters !

May I suggest to remove all controller profiles entirely (back them up) and then start AC with the AC launcher (not CM) and see if that works.
Also for trouble shooting detach ALL USB devices but either the wheel or the pedals to see if they show up and work this way in AC.

AC over the history of the different versions was always funky with periphericals and whenever an AC update, windows update or driver update was installed controls could be messed up.
 
I had this exact problem today, opt out from Steam beta from settings → account

This should be the fix. Had the exact same issue myself last night with my Fanatec devices, immediately after a Steam beta update and all sims were effected. Opting out of Steam Beta rolled back to the latest official version and all was good again.
 
LOL ok, we're in the same sinking boat then. Start bailing water:p

But we'll sink with class :roflmao::roflmao::roflmao:
timthumb.php
 
Just wanted to thank you all for your efforts and responding to me. So I went to the concert, got home and went to bed. Saturday morning I had to start taking care of the Live Stream: WEC Multiclass @ Spa OSRW - Sat 05May18 which took all of my time. Thought I wasn't gong to be able to race, but when I got caught up I started AC and a Unicorn farting Magic Pixie Dust flew in and everything worked just fine:confused::D:) I guess Steam had fixed the problem overnight and it turns out that my post may have been a little premature, but you guys know how it is. When you have a big race coming up, you'll crawl through glass on your hands and knees to able to participate.

Thanks again for your efforts. This is why you guys are the best:thumbsup:
 

manu68

Premium
I know that I am very late at answering you, but as I encountered about the same problem as you last week (after many months without simracing and update windows 10), I thought it could be useful that I post about the solution I have found.

I have a logitech G25.
After some months without simracing (real life has some kind of priority :roflmao:), I have again some more time to launch assetto corsa.
Of course, in between, Windows 10 has been updated , and of course my wheel has not been recognized anymore.
I tried to reinstall the logitech profiler, drivers etc... no way.
My wheel is recognized into windows 10, but no way to make it works with the profiler.

After checking the all thing, I have seen that I had a driver error. I mean, logitech driver not installed in a proper way.

It is only after many hours looking on x forums that I found the solution for my case.
As an idiot, I had activated the new feature "Core isolation and Memory integrity" after the windows update.
After finding the trick to deactivate again this feature (a line to change with regedit), I had no problem at all to install again the profiler lgs 5.10_X64 and make my G25 work again with assetto corsa.

The feature "core isolation" just doesn't allow the logitech profiler to be installed properly in the name of "security".

Just in case it may help
 
Top