RD Series on Simracing.GP

Daily WTCR races on Simracing.GP Weekly GT3 Endurance races on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP

Weird frame dropping with Rift S

This is more of a 'has anyone else experienced this' thing than a cry for help.
My PC is lethal good, 8700K all cores at 5GHz, 32GB RAM, RTX 2080Ti, but Assetto Corsa is struggling to run with the Rift S.
The render stats show that the HMD is at a perfect constant 80FPS with a perfectly consistent frame time, there are absolutely no spikes whatsoever, but when I move the headset I get irregular stuttering in the HMD which are reported as dropped frames... but again there are no frame time spikes or drop in FPS, and the stuttering does not appear on the headset mirror on the monitor.
I've dropped the supersampling to 0, disabled all PP effects, disabled all mods, nothing else is running, but still dropped frames.
If I run SteamVR and the HTC Vive, I can crank supersampling up to 250% with all kinds of stuff enabled and not drop a single frame, but the Rift S at stock settings is stuttering all over the place.
I've repaired the game files, tried running from CM instead of stock launcher, I've tried everything I could possibly Google, it does this when using the Rift S in OpenVR and Oculus rendering mode too.
My hunch is that Assetto Corsas Oculus Rift rendering mode is developed for the original Rift and a 90Hz display, but the 80Hz on the Rift S is conflicting with this, it's being forced frames that it can't render. I also tried Vsync and capping the FPS to 80 but this didn't stop the stuttering either.
Sorry that was a long winded explanation but if anyone replies to this, I would have probably had to explain all that at some point.
Does anyone else get this stuttering in the Rift S?
 

Ceolmor

Premium
Not much help I know, but I'm running a Rift S with a similar PC (i9-9900K@4.7GHz, 32GB RAM, RTX 2080Ti) and am not getting any stuttering that I can see. Which suggests its not an Assetto Corsa issue with the Rift S.

I use CM, Oculus (not SteamVR or OpenVR), SS at 1.5, ASW switched off, Sol mod PP effects, and most ingame setting high or more. I don't always get constant 80 fps. It depends on the combination, number of AI, which weather etc, but I don't really notice when it drops. I've had no noticable stuttering.
 
Thanks that's quite useful info. For me, if I start an empty hotlap and just sit stationary on the track at the start menu, I get clear stuttering ever second or two. I even dropped the SS down to 0.5 to the point where the resolution was 640x720 per eye, and it was still stuttering. Perhaps I need a complete game re-install but I'm hesitant to do that due to the amount of mods I've put in over the years.
Actually this would also be very helpful, are you able to use the Rift S without the game being in "Force 32bit" mode? My game was completely unable to render to the Rift S (in Oculus Rift mode) unless I enabled that setting, in 64bit mode the game couldn't detect the Vive and rendered to the monitor instead. I wasted a good 7 hours of my life before I found that!
 

Ceolmor

Premium
I always have Force32bit unchecked
flk9J3o.png


My video settings, in Content Manager
vJLeNbY.png
 
I had a very similar issue lately, stutter and dropped frames though the ingame app was showing constant 90 fps all the time.It was driving me crazy, especially since i didn't have performance issues in AC a few months back.

This was racing the ai though, hotlapping was fine and i use a 6700k, a 1080 and a fresh install of win 10 1903, so not sure if this might apply to you but i think it's worth a try.

At first i thought it might be related to some of the latest windows security patches or oculus updates.
But what finally solved my problem was deactivating hyperthreading in the uefi. Seems like all of a sudden my AC did not like virtual cores anymore, at least on my rig.

I also noticed that the irregular framedrop in GTA v disappeared, hyperthreading seems to still be an issue sometimes.
 
Thanks guys I'll match those settings and also try disabling HT, I'd rather not disable HT as I have no other issues with anything but I'll give it a shot as a process of elimination. Cheers!
 
Still no joy here. Whenever I run AC in 64bit mode, it launches the game through SteamVR even though I've got the Oculus Rendering option selected. I give up now, I want to drive some cars not spend more hours dicking about with settings! Cheers for the help
 
Ncrossy,
U still facing the problem? The stutter occurs when you look to the sides?
If yes, look at ur mobo usb ports. If your rift s is plugged in a usb 3.0 gen 2, try plug it to a gen 1. I was facing the same problem and looks like rift s wont work 100% at the gen 2 usb.
Hope it helps you
 
Top