Undetectable VR (WMR) Headset.......

Ever since I've had a WMR headset (first a Lenovo Explorer, now a Samsung Odyssey+). Windows 10 would not detect the headset until I rebooted the computer. Annoying, but I could live with it.

Now, with the latest Windows Update, my computer is very slow to restart when I select "restart". It just hangs at the "Getting Windows Ready. Don't turn off your computer" for a long time before restarting.

Is there some setting that I can check to force the WMR headset to be detected upon first boot-up?

FWIW - After re-booting, I start VR by running "Windows Mixed Reality for SteamVR" which starts Steam VR. I then have to shutdown Steam VR in order to then access Steam itself. Then, from within Steam I re-start "VR" and only then is my headset detected. All works fine after that <knock wood>,

Any thoughts on what I can try or check in order to make this whole "starting VR" process easier?

Thanks!
 
66
15
Last Windows 10 Update reintroduced the windows 10 „Fast Start“ option. Disable it and your headset should be recognized, once you fire up your system.
 

Jeremy Ford

Premium
712
463
Ever since I've had a WMR headset (first a Lenovo Explorer, now a Samsung Odyssey+). Windows 10 would not detect the headset until I rebooted the computer. Annoying, but I could live with it.

Now, with the latest Windows Update, my computer is very slow to restart when I select "restart". It just hangs at the "Getting Windows Ready. Don't turn off your computer" for a long time before restarting.

Is there some setting that I can check to force the WMR headset to be detected upon first boot-up?

FWIW - After re-booting, I start VR by running "Windows Mixed Reality for SteamVR" which starts Steam VR. I then have to shutdown Steam VR in order to then access Steam itself. Then, from within Steam I re-start "VR" and only then is my headset detected. All works fine after that <knock wood>,

Any thoughts on what I can try or check in order to make this whole "starting VR" process easier?

Thanks!

This is not normal, I never experienced anything like that with my Lenovo. Before restarting, try pulling the USB plug out and back in, see if that kickstarts things. Also, try different USB ports. Also, update your motherboard BIOS.
 

demetri

Premium
620
777
Colorado, US
Thanks! That may have done the trick! The PC does boot a bit slower, but it was slow booting even before. Now - maybe it's time to upgrade to an SSD!
The time to get an SSD for the system drive was many years ago :)
Nowadays a decent 256GB SSD (which is usually more than enough for a system drive) costs about $35 and Windows boots in mere seconds even with fast boot disabled
 
Top