UE4 Crashing

AmazingReflex

100RPM
Original poster
May 8, 2020
152
36
50
Hi,

I seem to get this crash fairly regular. Game crashes with a message about UE4 crashed, stopped or error (can't remember exactly). It can happen mid race or just at the end.

I never used to get problems with ACC. Has something changed, do others notice more crashing?

I recently upgraded from an RX580 to an RTX 3080. I wonder if that's causing the issue. I could try downclocking the GPU?
 
Dec 18, 2014
2
0
66
Same issue for me. "Fatal Error File unknown line 198. Unreal engine is exiting due to D3D device being lost. Error 0x887A0006 - Hung"
 

AmazingReflex

100RPM
Original poster
May 8, 2020
152
36
50
Your error sounds like gpu as it mentions D3D device eg. direct x gpu.

I need to look more closely when I get my crash
 
Apr 12, 2008
132
60
Overclocking?
I know with my 2080ti overclock@135 it will crash, back it off to 115 and all is good, even just raising it to 120 will give a crash.
 

AmazingReflex

100RPM
Original poster
May 8, 2020
152
36
50
I tried downclocking my 3080 by -100Hz on core but no better.

I tried not running Afterburner on Windows Startup. Still no joy.

I uninstalled ACC including removing everything in documents folder for acc and steam. Just re-installed as new. I will test later.
 

AmazingReflex

100RPM
Original poster
May 8, 2020
152
36
50
Update.

As I said before, I uninstalled ACC and deleted the ACC folder in MyDocuments then re-installed.

I had to start again with video settings exactly as before and selecting wheel profile (picked preset profile first then customised).

Ran a few 10 minute AI races and one MP session (practice, qualify and 25 min race) and seemed OK, no crash.

Not getting too excited at the moment, I'll give it some more time before passing judgement.

I do have an integrated gpu on my cpu which I use for a second monitor (main monitor on main GPU at 240Hz and 2nd monitor on integrated gpu running at 60Hz). I did disable the 2nd monitor previously (disabled in Windows but not disabled in bios) but it didn't stop the crashing. It's still disabled in Windows.

I noticed a few freezes in my last AI race last night but I had just rebooted and I think COD Warzone was updating. Why have I got that stupid game installed that I never play? Note to self, delete Warzone.

During all this I've been shutting down all the programs I don't need when running ACC (battlenet, epic etc.).

As I get more confident with the stability, I will think about enabling the 2nd screen again and leaving the other game clients running.

I wonder if issues can come about with corrupt user configuration files in relation to controllers and by deleting everything you start with a good set of working configs?

If the problem re-surfaces I will give it a damn good formatting and a clean install and see how it likes that :mad:
 

Gui Azevedo

25RPM
May 27, 2016
33
23
43
I've had similar crashes both in ACC and AMS2 in VR (Tbh, the main titles I play, so I could have had crashes in other games, I'm not sure).
I tried several things, including re-installing the games etc but ended up with a fresh windows install + dirvers + games.
Everything is running smooth now.

In fact, the main lesson I learned is: if your desktop is dedicated to sim racing, re-install everything once in while, We all know that the games we play are quite demanding, so from time to time it's a good idea just to dust off the system and start from zero.
 

AmazingReflex

100RPM
Original poster
May 8, 2020
152
36
50
Had real problems with ACC last night. There was an update I think but I didn't see it download.

It would crash on startup. I verified local files and it then downloaded one file sized around 470Mb. Still crashed on startup everytime.

I tried deleting all of mydocuments folder for ACC but still no joy.

I will try an uninstall / re-install again but I'm close to just going for a clean install. I'm also thinking about dual booting to see if that could help me going forward.
 

Gui Azevedo

25RPM
May 27, 2016
33
23
43
Had real problems with ACC last night. There was an update I think but I didn't see it download.

It would crash on startup. I verified local files and it then downloaded one file sized around 470Mb. Still crashed on startup everytime.

I tried deleting all of mydocuments folder for ACC but still no joy.

I will try an uninstall / re-install again but I'm close to just going for a clean install. I'm also thinking about dual booting to see if that could help me going forward.
Could you point out the pros of a dual booting?
 

acnut

1RPM
Oct 24, 2017
1
0
65
Could you point out the pros of a dual booting?
Any of you guys got an ASUS motherboard with Ramcache III running. I discovered this was somehow corrupting the ACC download and causing a subsequent verification failure and UE4 crash.
I uninstalled Ramcache and haven't had a problen since.
 

Gui Azevedo

25RPM
May 27, 2016
33
23
43
Any of you guys got an ASUS motherboard with Ramcache III running. I discovered this was somehow corrupting the ACC download and causing a subsequent verification failure and UE4 crash.
I uninstalled Ramcache and haven't had a problen since.
not the case, here
 

SamS1991

10RPM
Aug 15, 2019
19
1
29
Fatal Error File unknown line 198. Unreal engine is exiting due to D3D device being lost. my game keeps crashing i dont have an overclock on and i dont run on full graphics i run on medium and i have a 2060 rtx
 

Gui Azevedo

25RPM
May 27, 2016
33
23
43
So, yeah... I thought the CTD were gone but.. no. I'm still experiencing CTD / Erros in AMS2 ( I might have the same issue with ACC, but didn´t test it properly yet, since the fresh install)

For testing purposes, I just did a 45 min race agaisnt the AI. Somewhere around the 30 m mark, I got a CTD. I've monitored my temps and everything is okay ( CPU averaging 73º C with one-min interval spikes of 83 / 84º C. GPU running at 66º Celcius).

The bug report mentioned some files in Appdata/local/temp but I think it's just the location of the report doc.
I've looked at the crash file but I'm not savvy enough to see anything that could help me find the culprit.

So, yeah, I'm clueless.

EDIT: I just noticed this is a UE4 thread, where I first stated my CTD in ACC. By then, I had CTDs on both titles. I might still behaving the same issue with ACC, as I said before.

Once I do a proper test in ACC, i'll reportthe outcome here.
 
Last edited:
May 21, 2020
1
0
50
I am having the same crashing issue when i launch the game. Worked fine until yesterday, and the today i am completely unable to start the game, it crashes at startup every time. I tried most of the solutions that you find searching around, but nothing seems to work, PS: brand new PC built two weeks ago, used only for sim racing, only ACC
 

Gui Azevedo

25RPM
May 27, 2016
33
23
43
it happened in ACC...

10 min into the race and CTD. This time around not even a crash error message. nothing. Just CTD
 

Andrew_WOT

5000RPM
May 11, 2014
5,035
2,875
I had UE4 crashing issue a few updates back, nothing worked except full reinstall of ACC with its Steam and Documents folders removal. Looks like when some files get corrupted, Steam integrity check cannot properly recover.
 
Last edited:

AmazingReflex

100RPM
Original poster
May 8, 2020
152
36
50
I feel like I made progress at the weekend.

I was able to play against AI for two half hour races back to back with no crash.

I formatted C drive and re-installed Windows. I have just installed drivers and ACC, not even Fanalab.

I have an MSI Gaming X Trio RTX3080 and I was running the quiet firmware. I re-flashed with the alternative firmware that runs cooler but noisier. I increased the case fans to 50% and changed the AIO mode to balanced from quiet.

I'm thinking it's GPU related as I did get an error a little while back mentioning a D3D device failure which came up when ACC crashed. I'm wondering if I have a GPU issue or if I need to downclock a bit?

The only problem is I did get another crash at the end of yesterday. I purchased the British DLC last thing. I'm wondering if this caused an issue and I need to wipe / download the whole game again.