Trustmaster T500 RS Throttle Peddle Stuttering...

TheLittleHooligan

1RPM
Original poster
Apr 9, 2018
5
2
53
Hi all, anybody out there have a solution for the "Peddle Stutter' problem. I do hope I'm not the only one that's experienced this rather expletive inducing technical problem..:mad: I was busy doing the Porsche challenge around Monza Classic the other day and couldn't understand why the other cars where wizzing past me...:confused: in easy mode... :thumbsup: With my foot flat, going around the circuit I could hear what I first thought to be fast approaching AI... :O_o: they where... yet after being past, i continued to hear the engine stuttering... so naturally... I thought I'd broken the engine somehow...:( and resigned myself to a last place finish...:cry: However, with my next attempt I discovered the problem... a fault with the throttle pedal stuttering... seems something is amiss with the sensor, does anybody have a fix for this... ie: a mod, electronic workaround, cleaning of faulty part.. or new component purchase from RS, Mouser, Digikey, Jameco etc. PS.... the clutch is acting up as well... No wonder I keep getting penalised at the start for jumping....:O_o::confused::mad: Thanks All.
 

BrunoB

Too much Goebbels
Oct 10, 2011
1,716
907
I had a similiar problem with the rather cheap throttle pot on my handcontrolled SRW-S1 wheel.
I took the pot out and literally :) bathed it in contact cleaner (not silicone spray).
The bath procedure was executed by spray drowning the pot in a small bowl (or inside a tiny plastic bag?).
 

Turk

1000RPM
Jul 29, 2011
1,408
577
How old is the wheel, contact Thrustmaster, if it's a known issue they may just post the part out to you. Sounds like a faulty part.