RaceDepartment Store

Who will win the Saudi Arabian Grand Prix?

  • Max Verstappen

    Votes: 930 49.5%
  • Lewis Hamilton

    Votes: 811 43.2%
  • Other Driver

    Votes: 136 7.2%

Upcoming Events

AC events on Simracing.GP ACC events on Simracing.GP R3E events on Simracing.GP Weekly rFactor 2 events Join TCR Virtual today!

Trouble loading R3E in VR Quest 2

Brandon Wright

I may not be fast, but I'm wide!
Hello. I’ve been racing in R3E in VR for awhile with a CV1. Loving the ranked racing lately and it’s where I spend most of the sim time the last couple months.

Last weekend I upgraded to the Quest 2 and love it! But I’m having problems with R3E. I’m using both the Link cable and Air Link, and even tried Virtual Desktop. With every other game it all works fine, and I’ve got R3E to load up a few times but most of the time it loads up really tiny on my monitor and won’t load in my headset. Steam VR starts up, I see the Steam VR environment with the mountains in the distance, and occasionally I even see the Up Next dialogue showing that R3E is loading. But then it just loads up on my monitor really tiny in the corner and not in the headset. It has loaded in the headset a handful of times and I don’t do anything differently when it does. Anyone have any idea what’s going on?

Again, I’ve tried AC, AMS2, Microsoft Flight Sim, and all of those load upfine every time. I’ve gotten R3E to load up a handful of times so I know it can work, but most of the time it loads up really tiny on the monitor. I have -vr launch option in Steam(tried it with and without that option) and it always workedflawlessly on my CV1. I’m really at aloss why R3E won’t load and frustrated because it’s my preferredracing sim right now. I’ve addedsome pics showing what I see in theheadset and what I see on the monitor. In the monitor pic you cansee that SteamVR is showingeverything is connected properly. Sorry for the long post, just trying togive as much info as possible.

Brandon Wright

I may not be fast, but I'm wide!
Update: OpenComposite seemed to fix my issues and now R3E seems to load up in my headset without issue.

Our Latest Video

Check out the latest video of the official RaceDepartment Youtube Channel.
Don't forget to subscribe!