Texture doesn't export

Alex Kyriak

250RPM
Hi all,

I made a simple model with a texture applied - 'Bridgestone' in the attached pic. I exported it, it worked fine in RF. I then loaded an XPack made by someone else, and added one object from this. I exported the track. My original model will still export, and appear in RFactor, but the Bridgestone texture has changed to a blank blue colour. Anyone know what might cause this? The texture is a .jpg, not a .dds. Thanks alot.

ak_texprob_btb.jpg
 

martinez

500RPM
Check size of the texture (powers of 2) again. I always use .dds and never had problems like that. But for e.g. trees or banners (something like flat faces) I discovered that checking "double sided" and "render normals up" for materials in xpacks works much better. Maybe try this too.
 

Erwin Greven

retired from this site.
I had that problem when i wanted to build those shields with the village names on it. I saved the textures as a *.png-file.
I will try it again with checking "double-sided" and "render normals up".
 

Alex Kyriak

250RPM
My question was more to do with why would importing another xpack affect one that I made that was previoulsy working fine? (ie I already set textures sizes, double sided, etc). Can't work out what the problem is! Unless textures somehow are named the same?
 

Alex Kyriak

250RPM
Thanks alot Kyle - that's solved it - exactly what my problem was. The Bridgestone jpg was called bridge~1.jpg. I loaded a bridge model in from another xpack and it had the same name! I renamed my jpg, re exported my XPack, and it worked just fine. Cheers.
 
Top Bottom