T500RS One pedal not registering when pressed.

Discussion in 'Sim Racing Hardware' started by LAR555, Feb 26, 2016.

  1. LAR555


    I have went all over the internet and saw few post where people would get trouble with left pedal not registering in any software and it doesn't matter in which mode you set it, Gas Or clutch won't work. I read how people attach pedals after connecting usb so tried that yesterday and it worked for a few minutes until I restarted again and back to square zero... after many many restarts later never worked.

    Is this the problem of Windows 10 recent upgrade or my pc being to "new" with USB's too advanced for 2011 wheel because I just bought it with the latest technologies, although I ma avoiding USB 3.0 when plugging in.

    Has anyone had similar problem ? Wheel is brand new and since it worked yesterday it's 100% hardware issue....
  2. Zzyzx

    Warren Williams Premium

    Have you by any chance taken your pedals apart at some point? I did that with mine in order to fit a load cell and I got the 'cog' at the bottom of the pedal in the wrong 'tooth'. That meant it wouldn't calibrate correctly - although there was some readout on the pedal.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.