Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP Daily WTCR races on Simracing.GP

Sudden Phantom Inputs From Button Box.

I recently reconfigured my cockpit (P1-X just arrived) and a couple days in started seeing off phantom input I have tracked down to the button box. In iRacing I see inputs primarily centered around the "left arrow" and "i" keys.Specifically, it wants to lower my force feedback and turn off my engine :(. This only happens when I am moving, but does seems to happen independent of any vibration effects. I have tested extensively and it seems to happen with or without any tactile or anything else on. The button box is mounted very securely to a swing arm, connected with 5 ft cable (with an EMI shield) to an Anker USB 3.0 hub. Any idea what might cause this? Some form of EMI perhaps?

Here's what the install looks like currently:
 

Attachments

  • 67372891_395504711321887_344609797665980416_n.jpg
    67372891_395504711321887_344609797665980416_n.jpg
    268.1 KB · Views: 150
Update:

Shortly after this post it stopped working all together. I can see it as a USB controller from device manager, but the software that drives it cannot see it, and I cannot interact with it in anyway.
 

Jeremy Ford

Premium
Does it show in the (Windows) Game Controllers panel? And if it does, you can select the device from the list, hit Properties and this allows you to test all the buttons. This is what I'd test first. Also swap USB ports. Maybe even try a different USB cable.
 
Ahh, here's the one additional item that slipped my mind in the first post. It is an ignition controls advance box and is recognized as a keyboard and mapped through a program called arcaze, which cannot see it. Not recognized as a game controller.

Heard back from the creator, but all he was able to offer we're things I tried already. It was the only option on the market with a good directional controller I could find, something I really wanted for menu navigation.
 
Continueing this one-man-show the false alarm was a false alarm. Worked for a bit, now still has phantom inputs. Multiple cables tried in all configurations, firmware and software updated, still can't race without my engine shutting off.

Ordered a pair of Ricmotech boxes as it looks like this one needs a new board or a trip to Poland to visit its maker.
 
My guess is EMI. especially after reconfiguring the rig. Just as a test, try wrapping aluminum foil around the wheel and button box cables and see if it makes a difference? If it does you know for sure that's the issue and can work from there.
 
Top