• Welcome to the largest (sim) racing website in the world!
    Blurring the line between real and virtual motorsports.

Stuttering on sim racing games!

Discussion in 'Computech' started by João Miguel Martins, Jun 14, 2019.

  1. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    Hi!
    I am new here!
    My name is João Miguel and i am from Portugal, so sorry for my poor english!

    I usually play Assetto Corsa, Assetto Corsa Competizione and RF2!
    I had until a few weeks ago a computer with a i7 4770K at 4.2 GHz OC processor, 16 Gb DDR3 - ? 2133 MHz memory a MSI Z87 Power X motherboard and a MSI Gaming X GTX 1080 GPU.
    I never had any issues with it, just made an upgrade because with Oculus Rift i can´t get the 90 fps.
    So, i sold the that CPU, motherboard, memories and GPU.
    Then i bought a MSI Z390 Gaming X Carbon Pro AC motherboard, an i9 9900K CPU, 16 Gb DDR4 G.Skill 3200 MHz memories, and initially a Gigabyte RTX 2070 Windforce GPU and later changed it with a MSI RTS 2080TI Gaming X Trio GPU.
    Initially with the RTX 2070 GPU, and i had it only for 2 days, i don´t remember to have stuttering issues, i just changed it for the better RTX 2080TI because that last one was at a very good price and is much better.
    And the problems began!
    I never had stuttering with the old components that i mentioned, but now with new components i have!
    I tried this new rig with a Gigabyte RTX 2080 OC GPU and the stuttering was there too!
    I can get high FPS around 165 (with GPU at 70 per cent, and CPU below 60 per cent), but randomly i had suttering issues, 3, 4 times per lap at for example in Assetto Corsa at SPA Francorchamps.
    If i run alone i get something like 500 fps at SPA and stuttering is not notable!
    But if i run, for example, with 23 AI cars, the stuttering is there!
    Maybe i have to discard the hypoteses of GPU to be mad, as i tried it with the Gigabyte RTS 2080 OC and had the same problem.
    I think i have tried almost everithing:
    - CPU at normal speed, CPU OC at 4,7, 4.8, 4,9 and 5.0 GHz;
    - CPU ratio mode at dynamic and fixed (at fixed mode is better, but not perfect, stuttering still exist);
    - memory at normal speed, memory with XMP profile;
    - Intel C State enabled, C State disabled (with this disabled is better, but not perfect, stuttering still exist)
    - Enabled and disabled hyper threading;
    - etc;
    And i still can get rid oth this stuttering problem!
    I read somthing about disable multicore at Steam game aplication settings, but i dont know how to do that or if that can help in my problem!
    Can someone help me in this, please?

    Thanks in advance
    João Miguel
     
  2. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    I forgot to mention, but i also installed windows 10 v1809 and v1903, the last 3 nvidia drivers and the nvidia version 325.31, and stuttering is present in all situations!!!

    João Miguel
     
  3. RasmusP

    RasmusP
    Premium

    Messages:
    5,420
    Ratings:
    +1,981
    Hey João,
    this can have a lot, and I mean a lot reasons. So be prepared to dig around until you want to throw your pc out of the window.
    I'll give you everything that comes to my mind:
    1. Your gpu not running in 3d clock speed due to low gpu load. Go into the nvidia 3d settings/profiles and change the "power consumption", "energy mode", whatever it's called to "prefer maximum performance".
    It's probably set to "adaptive" or "optimal".
    I had that problem with Automobilista. Gpu running at 700-1300 MHz instead of 1500+.
    Fps were fine but the stutter was unreal!

    2. Vsync on/off/wrong mode. Also Oculus specific stuff.
    You say you get 500 fps. With the Oculus you should be stuck/locked at 90 fps. So could you explain exactly how you run the VR headset, what fps you get with it running etc? We need more details.
    Sadly I don't have VR so I can't help you throughout the details but others can.

    3. Windows 10 doing weird stuff.
    I'm on win 7 but I know that win 10 enforces vsync in windowed mode and borderless. It also has some features that can screw up your experience.
    @Martin Fiala knows a lot about this. I sadly can't help you there.

    4. How many hud apps you have active in ac? Because even a 5 GHz 9900k might not be able to maintain 90 fps if you add 23 AI with too many hud elements on the screen. They all run on one cpu thread (spread across all cores in task manager though) and can't really make use of your multiple cpu cores.
    So while your cpu is only running at 50% or even below, it might hit the "Single thread limit".
    So deactivate/hide all apps and check again.

    Hope that gives you a starting point :)
     
  4. Denis Betty

    Denis Betty
    Staff Premium

    Messages:
    5,135
    Ratings:
    +1,840
    I think I read that the vsynch field in NVCP should be set to Off for VR. Can't find it now though.
     
  5. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    1 - I had it ar maximum performance already.

    2 - I said 500 fps, but this is on my 166 LG gaming monitor, and playing alone
    On Oculus Rift it is at 90 fps or around that value.
    When i have the stuttering isues the FPS don´t go down.

    3 - i tried it with V-Sync On and Off.

    4- I also tried it with no apps open while runing Assetto Corsa.

    Thanks
    João Miguel
     
  6. RasmusP

    RasmusP
    Premium

    Messages:
    5,420
    Ratings:
    +1,981
    OK do it's not the obvious stuff.
    I'd suggest downloading the little tool "openhardwaremonitor", run it and select "show plot" in the settings.
    Then you'll have to select where you want that plot to be.
    Then select the now appearing checkboxes left to the 8 cores frequencies and also the gpu frequency.

    The scaling of the plot is weird. Dragging is done via click&hold on the axis, scrolling is done via mouse wheel and hovering above the axis or window.

    Anyway, plot all the frequencies, run ac until the stuttering happens, continue to play for a minute to get some "clearing" behind the stuttering in the plot.
    Then quit or minimize ac and check the plot.
    Check if any core is clocking down etc.
     
  7. Martin Fiala

    Martin Fiala
    Premium

    Messages:
    5,192
    Ratings:
    +4,313
    Are you running in fullscreen or in windowed mode? Have you tried limiting your framerate (what is the point of running at 500 fps anyway)? And what does "stuttering" mean, exactly? Does the framerate drop? I mean, with unlocked framerate, you will always get moments when the image does not appear smooth, simply because the framerate is not equal to your refresh rate. More so in windowed mode, but not exclusively.
     
  8. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    I already have that program too, but i just used it to see the loads and tempreratures, didn´t know that it could save it, i ll try to do like you mentioned, let me see if i can do it correctly.

    Thanks!
    .
     
    • Like Like x 1
  9. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    I usually dont limit the fps, but even if i do it the result is always the same, stutering still present.
    When i used the built FPS app of Asetto Corsa or CAM to monotoring the frames, i allways have the same result, the frames never droped, but the stuttering happens anyway.
    I mean with "stuttering" that the game is runing flow (i have a G-Sync monitor with 166 Hz), and suddenly the image "Chokes" (stop and go, stop and go, stop and go, and so one) for 1 second or less and then returns to be flow again ...
    I always played in full screen mode.

    Thanks
    João Miguel
     
  10. RasmusP

    RasmusP
    Premium

    Messages:
    5,420
    Ratings:
    +1,981
    Just to elaborate on this:
    I had some stuttering every 10-30 seconds in Rocket League 2 years ago. No idea why, absolutely everything seemed fine.
    Then I did what I just told you and found out that every now and then, one of the 4 cores dropped its frequency just a little bit.
    So I had these 4 graphs and you could see a little notch, randomly on one of the cores every 10-30 seconds.
    So I went into the bios and disabled everything energsysaving related. C states all disabled, speedstep too.

    Stuttering was gone :)

    In theory msi afterburner can log+plot it more accurately since you can set it to 0.1s refresh rate instead of the 1.0s of openhardwaremonitor.
    But it shows the 8 cpu threads of my i7 2600k instead of just the 4 real cores. And somehow these 8 graphs are not mirrored in pairs...

    Anyway, if you disable all downlcocking features, all 16 threads in msi afterburner will be locked like they will be in openhardwaremonitor.
     
  11. Fernando Deutsch

    Fernando Deutsch

    Messages:
    782
    Ratings:
    +403
    Make sure you have HPET disabled on BIOS and on windows.
     
    • Like Like x 1
    • Agree Agree x 1
    • Disagree Disagree x 1
  12. Terry Rock

    Terry Rock

    Messages:
    1,892
    Ratings:
    +710
    What does you cooling temp look like during gaming?
     
  13. deceda

    deceda
    Premium

    Messages:
    47
    Ratings:
    +9
    Which PSU? Could possibly be to weak for the components used.
     
  14. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    Temperature is good, around 50º C
     
  15. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    Corsair RM750 with about 5 years
     
  16. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    upload_2019-6-14_21-4-9.png

    upload_2019-6-14_21-4-37.png
    Here are the Open Hardware Monitor graphic with me playing Assetto Corsa

    João Miguel
     

    Attached Files:

    • Like Like x 1
  17. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    During the play on the above graphic I had a lot of micro stuttering!

    João Miguel
     
  18. João Miguel Martins

    João Miguel Martins

    Messages:
    53
    Ratings:
    +2
    I will do that!
     
  19. RasmusP

    RasmusP
    Premium

    Messages:
    5,420
    Ratings:
    +1,981
    Well, you have the same problems a friend of mine had with his 8700k:
    No clock speeds in openhardwaremonitor...

    You need to download the latest alpha, which can be found in the second post, here:
    https://github.com/openhardwaremonitor/openhardwaremonitor/issues/991

    That will hopefully show the clock speeds. The CPU loads are not useful at all if not hitting 100%.

    Although I have to say your core #7 looks pretty stressed. Any idea why? Did you run anything in the background?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.