Stuck in loading screen

dbwhisky

1RPM
Original poster
Mar 18, 2019
4
1
29
So, I ran in to a problem. Ever since race at Baku my game wont load in practice sessions, just stays at black screen with loading text at the top left corner. Quali and race itself work fine tho.
Edit: Well, now it wont load in to career mode. Funzy :D

Any idea what could cause it or how to fix it since I'm not really fond of starting my 100% career from zero.

Cheers.
 
Last edited:
  • Like
Reactions: kikikumi

SinAporia

25RPM
Jul 12, 2016
32
3
36
I ran into the same issue. But different track. Did try to load another track first, seems to fix the issue once... but still freezes after the session is over.. -.-''
 

SinAporia

25RPM
Jul 12, 2016
32
3
36
Ok, after a long long night... -.-''

i fixed it for me, reinstalled the entire game twice, reinstalled my video driver and after that it worked again. Just DX 11 even though i could use DX12.. but hey, at least its working again.

It looks like for some users the patch isn't complete....
 

dbwhisky

1RPM
Original poster
Mar 18, 2019
4
1
29
Ok, after a long long night... -.-''

i fixed it for me, reinstalled the entire game twice, reinstalled my video driver and after that it worked again. Just DX 11 even though i could use DX12.. but hey, at least its working again.

It looks like for some users the patch isn't complete....
Ended up doing the same and now I can drive again. Allso just on DX11, DX12 seems to randomly crash the game
 
Sep 17, 2018
14
1
30
This happens me in DX11. I have not been able to play the game in DX12 since the game release. Codemasters really need to do something