Solved My Z-fighting in RaceRoom

Bonehead

100RPM
Premium
Sep 29, 2008
180
286
Hello everyone. I had many hours of hair pulling trying to get RaceRoom to look like I though it should. I had Z-fighting and blinking everywhere, and almost gave up on the sim. RaceRoom went from a blinking mess to it being beautiful for me with these settings. I posted this in another Race Department forum, and though I would post it here. I hope this helps someone.

I am using an Nvidia 1070 with a 50 inch TV screen in 'Game Mode'. 4096 X 2160 @60Hz. Full screen Vsync on, and an FOV of 1X.

First thing I did was set the graphics in RaceRoom to MEDIUM, not High. Then I adjusted the graphics as the screenshots below show. Then in Nvidia Control I set these parameters. Please note to use ENHANCE, and not Overide.
 

Attachments

Ross Garland

Spiritseer
Staff
Premium
Sep 28, 2009
9,865
4,789
I'm not sure why you were getting those issues (I had to look up "z-fighting") but I'm not sure it was the sim, to be honest. I've never seen anything like that and I've been playing it for years. Perhaps it's the very large resolution you're using, something R3E was probably not designed for given it's age.
 

Bonehead

100RPM
Premium
Sep 29, 2008
180
286
@Ross Garland I have used a 27" monitor, a 31" Widescreen monitor, and the 50" TV I am using now with the same flickering, blinking issue with RaceRoom for some odd reason. Even with the lower screen resolutions on smaller screens that I have tried previously, the Z-fighting was there. RaceRoom does support the very high resolution, as I chose it from their video settings. If I chose a lower resolution the Z-fighting was far more obvious. I also discovered that this issue wasn't that uncommon with RaceRoom drivers, so that is why I posted my settings, so as to help others that may be suffering from it. Kinda my little way of maybe helping this great web site.

Have a great 2020 Ross, and thanks for RaceDepartment! Jack :)
 

Jens Roos

500RPM
Premium
Feb 23, 2017
767
1,104
47
thx for posting, have the same issue on triples 1440p. Did not bother me much to be honest, but I try your suggestions and see if it gets better.

btw, had to google it when noted in the other thread, there is a name for everything :)
 
  • Like
Reactions: Bonehead

Bonehead

100RPM
Premium
Sep 29, 2008
180
286
thx for posting, have the same issue on triples 1440p. Did not bother me much to be honest, but I try your suggestions and see if it gets better.

btw, had to google it when noted in the other thread, there is a name for everything :)
I use a single monitor, and I hope this helps you.
 

Bonehead

100RPM
Premium
Sep 29, 2008
180
286
Good inspiration @Bonehead :thumbsup:
Question: Is there a reason to use both supersampling(SSAA) and MFAA?
Not really I guess. This is what works the best on my system and these settings are not carved in stone. Maybe a different combination might work better for you.
 

BrunoB

1000RPM
Premium
Oct 10, 2011
1,250
493
I just ask because I have MFAA to off - and the reason is that even Im unsure then I intuitively guess that setting 2 different AAs to on could be contraproductive.
Yeah and using trial and error is difficult because the difference is often rather few fps and also hard to see.
 
  • Like
Reactions: Bonehead