Sol

Misc Sol 1.3.1

No permission to download
Hi, guys, I’d like some advice.
I want to organize a race with day night transition using mod Sol . how can I check that all the members have only active? , is there a server-side app that can help me in this? That is, who has no active server cannot enter the contest server.
Excuse my bad English.
 

Ghoults

1000RPM
Is the water spray somehow shader related? Does the road surface need certain shader so in the rain the spray appears? I am trying to figure out how to set up my wet track and the water spray just doesn't appear without DIRT_Additive=1. Other tracks work fine. The dry version of my track uses the ksMultilayer_fresnel_nm for the road surface and that is the typical shader used for roads. And in rain weather the spray also appears on that version. But the wet version uses ksPerPixelMultiMap_NMDetail and no spray. That shader is the only difference I can find. My logs are clean and I have no errors.
 

Andrew_WOT

2000RPM
Hi all! I am absolutely in love with this mod and I dont want to be nitpicky, but something that has been bothering me is that most tracks at night seem to be too well lit, even the pitboxes and aux. buildings. I managed to turn the cars' headlights a bit dimmer, but that just made the mentioned issue even more visible. My question is, that is there a way to dim the tracks' lights in general, or I have to do them one by one in the config files. Thanks!
Lighting FX/Brightness. Default is 300%, Peter recommends 100%, play with that and with numbers in between to find the value you like.
 
go CM->settings->CustomShadersPatch->Track Configs
and update imola by right click and selecting "Install now"

if still not working, check folders, you only need one cfg, preferably in
"assettocorsa\extension\config\tracks\loaded"
(config-file-name: "imola.ini")

check if there is another in
"assettocorsa\extension\config\tracks\"
(if so -> delete it)

if still failing dl config manually from

(right click "Raw", then "Save as...")
 
Last edited:

Zuotoski

25RPM
Actually to try it I found that it`s a bit tricky. After you load the game and get the unwanted brightness at night (better tested stationary in front of start grid of kunos cars ...) you change the values in editor and see no effect - you have to change the PP-filters forth and back, and then move the view in cockpit with "Neck FX" > right click dragging so the AE picks the new values (or glance back/ switch "F5" and "F1" for a second). Tried it with
TARGET=0.45 ; target average brigthness that auto exp is trying to achieve (0 -> 1)
changed to "TARGET=0.85" and moved the head. Works like a charm. To assure the AE keeps the dynamic exposure from exceeding the threshold I decreased the static exposure to 0 (hold PgDown until reaching it).
Hi!
Sorry for taking so long to give a feedback.
It worked, but still is odd. It is still a little bit too dark outside the car and some tracks are just too bright where the lights are (unde bridges, at the starting line, poles, etc..). Something happened after some changes made to SOL and Custom Shaders Patch, it was better before. Yes, I know, sometimes it is necessary to go through some changes to achieve something better, the "problem" is that it has so many variables that it's hard to know exactly where is the issue and how to solve it. So, I rather to leave it alone and try it again later when a new version come out. It is also happening to the smoke, in particular the TK's smoke mod, that just doesn't work with SOL anymore - i tried so many things, wasted so much time trying to make it work that it just became a frustration, while I should be racing and having fun instead.
Don't get wrong, I am not blaming anybody, even less the developers and modders that work so hard to give us so many wonderful things, for nothing most of the time. It's just that sometimes you have to accept that somethings won't work for you, and let it be, focus on other things and have fun.
Anyway, thank you very much for your tips and tutorials, it really helped.
Cheers :thumbsup:
 

alekabul

250RPM
later when a new version come out
I should have mentioned it sooner but still, I`m using CSP v0.1.25-preview140 (recommended version).
When "Weather FX" is disabled the overexposure at night can happen so I think it`s not related too much with Sol. I hope the next CSP update hepls you with that problem.
Cheers!
 

Zuotoski

25RPM
I should have mentioned it sooner but still, I`m using CSP v0.1.25-preview140 (recommended version).
When "Weather FX" is disabled the overexposure at night can happen so I think it`s not related too much with Sol. I hope the next CSP update hepls you with that problem.
Cheers!
Yeap, I am using CSP v0.1.25-preview205, because SOL v1.2 requires it.
Sure, it looks like to be a CSP problem, but as SOL interacts with it, it may be a mix of tweaks. But I will never go back to the raw game, I am dedicating the last videos on my channel just for Assetto Corsa with SOL and CSP, it's so rewarding as a racing cars passionate guy.
Cheers! :)
 

Ghoults

1000RPM
I have a weird issue with the latest shaderspatch and sol. Everytime I start cm the date reverts back to 22th of june (6/22). Also my car lights keep flashing randomly as I drive around the track. I have disabled all the settings that I've found that could cause that (the automatic lights stuff under car instruments). I think I figured out a potential solution to this a while back (had to change something from some app?) but I have no idea what I did. I have 0.1.30 of the shaderspatch but the issue is there on at least 2 other versions I tried (recommended one is just a red sky and later one had the same issue).

Also is there a way to disable the new grass fx stuff in extensions.ini? I've gone through all kinds of combinations and I can't luck into any kind of parameters that change anything so I'd rather kill it than have jungle skidmarks appear when a car goes off.
 
0.1.30 has all kinds of probs, downgrade.

remove the hole section in an existing track config starting with [GRASS_FX]
or disable grassFX in cm-settings-customshaderspatch-grassfx tab
 

Ghoults

1000RPM
0.1.30 has all kinds of probs, downgrade.

remove the hole section in an existing track config starting with [GRASS_FX]
or disable grassFX in cm-settings-customshaderspatch-grassfx tab
I've tried at least 5 different patches. The car lights just flash randomly.

Also I don't have any grass fx stuff in my extensions ini and I still get the bright grass particles appear when I go off the track. Is there any way to turn that off in the track's extension file?
 
oh thats actually a bug, you cannot turn off, downgrade for that too, lasst version without grass at all is v0.1.25-preview205, where also the lights should work
 

Ghoults

1000RPM
oh thats actually a bug, you cannot turn off, downgrade for that too, lasst version without grass at all is v0.1.25-preview205, where also the lights should work
Do you know what else do/can I need to turn off? This is 0.1.25 prev 205 and I still get flashing under braking and randomly around track. It feels more like it just ignores those settings completely. It seems disabling car instruments totally does the trick.
lights.png
 
Top Bottom