Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP Daily WTCR races on Simracing.GP

Share your VR graphic settings

Thanks for the input guys.
anyone has figured some specific acc settings to be used in the Skyrim file and/or in acc that improve the result?
It really depends on your HMD res and how powerful your PC is as your initial settings will be different. For me (G2 / 3090) I have done:

engine.ini:
Lowered this to get a bit more stable image
r.TemporalAACurrentFrameWeight=0.05

This was -1 to boost sharpness but gave too much shimmering and not needed with CAS
Could even go lower
r.MipMapLODBias=-0.5

ReShadePreset.ini:
[VR_CAS_Color.fx]
Brightness=1.000000
CASContrast=0.750000
Contrast=1.000000
MaxDelta=0.050000
Saturation=1.000000
Sharpening=2.500000
SharpeningRadius=0.400000

SteamVR res 50%
PD 145%
Res scale 55%
Sharpness 150%
Advanced Sharpening filter off


I altered the CAS fx file to move the foveated regions in slightly too so that they matched more with the sharper areas of the G2:
fromCenter = float2(texcoord.x < 0.5 ? 0.3 : 0.7, 0.5) - texcoord;
 

vannib

Premium
It really depends on your HMD res and how powerful your PC is as your initial settings will be different. For me (G2 / 3090) I have done:

engine.ini:
Lowered this to get a bit more stable image
r.TemporalAACurrentFrameWeight=0.05

This was -1 to boost sharpness but gave too much shimmering and not needed with CAS
Could even go lower
r.MipMapLODBias=-0.5

ReShadePreset.ini:
[VR_CAS_Color.fx]
Brightness=1.000000
CASContrast=0.750000
Contrast=1.000000
MaxDelta=0.050000
Saturation=1.000000
Sharpening=2.500000
SharpeningRadius=0.400000

SteamVR res 50%
PD 145%
Res scale 55%
Sharpness 150%
Advanced Sharpening filter off


I altered the CAS fx file to move the foveated regions in slightly too so that they matched more with the sharper areas of the G2:
fromCenter = float2(texcoord.x < 0.5 ? 0.3 : 0.7, 0.5) - texcoord;

Thanks: at what framerate are you going? Reprojection?

I have a G2 and 3080.
 
Thanks: at what framerate are you going? Reprojection?

I have a G2 and 3080.
90fps constant including race start, 18 cars visible, dawn with low sun and headlights casting shadows. No reprojection. PD is actually at 150%. If you're not bothered about the race start being 90fps there's probably a bit more headroom. Attached my current graphics and engine settings.
 

Attachments

  • 90hz reshade.json
    1 KB · Views: 111
  • Engine.ini
    1.6 KB · Views: 128
Yeah dude thanks for insisting on this! It actually works GREAT, didn't realize I had the settings all wrong on ReShade, now after installing everything fresh it makes a HUGE difference, at least to me. It's like a 30% increase in pixel density. This is awesome!
On oculus?
 
90fps constant including race start, 18 cars visible, dawn with low sun and headlights casting shadows. No reprojection. PD is actually at 150%. If you're not bothered about the race start being 90fps there's probably a bit more headroom. Attached my current graphics and engine settings.
ReShade works in ACC? Just tried, it loads on my monitor but I get a Fatal Error when launching the game in VR with ReShade.
 

Attachments

  • reshade.zip.txt
    1.6 MB · Views: 80
90fps constant including race start, 18 cars visible, dawn with low sun and headlights casting shadows. No reprojection. PD is actually at 150%. If you're not bothered about the race start being 90fps there's probably a bit more headroom. Attached my current graphics and engine settings.
with this settings i have 45 fps at the start with 20 cars :(

i7700 without boost, 3080, G2
 
with this settings i have 45 fps at the start with 20 cars :(

i7700 without boost, 3080, G2
That'll be with reprojection on auto though I guess? As soon as it goes below 90 it will sync to 45, and reprojection takes a bit of power too so you're more likely to go under 90 with reproj enabled. Best to disable it completely and run at 90 with slightly lower settings or 60 with higher settings. With an i7700 your CPU will be bottlenecking with high numbers of cars visible too, need to go down to 12 or 10 I expect.
 
That'll be with reprojection on auto though I guess? As soon as it goes below 90 it will sync to 45, and reprojection takes a bit of power too so you're more likely to go under 90 with reproj enabled. Best to disable it completely and run at 90 with slightly lower settings or 60 with higher settings. With an i7700 your CPU will be bottlenecking with high numbers of cars visible too, need to go down to 12 or 10 I expect.
"reprojection on auto" could you please clirify which setting do you mean?
 
Hey @Andrew_WOT, I'm using the g2 and the only link to an .ini file from you i could find says it's no longer available on google drive. Any chance you could share these settings again? Having a rough time finding the proper new ones in this thread :)
 

Andrew_WOT

Premium
Hey @Andrew_WOT, I'm using the g2 and the only link to an .ini file from you i could find says it's no longer available on google drive. Any chance you could share these settings again? Having a rough time finding the proper new ones in this thread :)
 
hello, help with g2, my configuration is amd 5600x, msi 3070 ventus 2 oc, msi x570 gaming plus motherboard, 32gb ram 3200. Corsair m600pro nvm for gaming. i have to say chw balancing on g2 with Acc is terrible, now i use 60hz, with steamvr resolution at 100%. here everything is fine, in Acc I tried different configurations, but I always find myself eliminating AA this causes me blue screens in the viewer, in addition to weapons a more blurred view, post processing off this loads too much on the percentage of use of the GPU. for me it is practically impossible to use AA even lowering all the filters to the minimum, I know there are problems with the 570. I would like to have a hand to configure my vr better, and not have that damn blur effect already at 15m. my g2 is connected to a powered usb hub, to solve audio switch problems
 
Last edited:
Finally got hold of a Zen3 CPU (5800x) and that has solved all the issues of not being able to consistently hit 90fps. Can now run the G2 at native 90fps (reproj disabled) with a mix of high and ultra settings, 18 cars visible, AO enabled. Still takes a large hit at Nurburgring at night in rain, so I have a night gfx setting that knocks down a few values to keep the 90fps. Very happy, well worth going from the 3900x to 5800x!
Hey NuScorpii,

seems like you are coming from a 3900x and went with a 5800X. Do you really see a big improvement in frametime with this? I am on a 3700X and 3080 and my CPU load is very low and the GPU is running at ~95% or so, so i do not quite get that improvement. Or is that due to single cores being overloaded and the 5800X's higher single-core performance doing the trick?

Can you put numbers to the improvements you are seeing? What GPU are you using?

I was also thinking about replacing my 3700X with a 5800X, but discarded that thought due to the general consensus, that for 4k/ultrawide/VR, the GPU is the only major factor for graphics performance.

Btw, i also improved my settings, most importantly for me the sharpness and frametime at the same time by lowering resolution and upping VR PixelDensity thanks to this thread :)
 
Last edited:
Another thing: with my current settings I am getting around 70 FPS alone and 50-60 while doing a race and I have to say While I can appreciate racing at 90 FPS, it does not really bother me and the image quality is great.

Now about motion smoothing: I know how it should work, but turning it on and off does not really do anything I can see (disabled vs. always forced on). Also when on should fpsVR not read 45fps constantly? I am getting between 50 and 70 FPS no matter whether it is turned on or off.

Any thoughts or ideas?

EDIT: Most of you will know, but found that the SteamVR Motion Smoothing setting is not doing anything before editing the VRsettings.ini. It works now as intended, but I am not yet sure, what I like more. Definitively feeling the smoothness with it turned on and the GPU load went down to 80% or so, but fast horizontal motion like cars passing by or moving my head to take a look at the cockpit shows the engine actually running at 45 FPS. Might also try to slightly increase VRPixelDensity as for me blurriness is really a showstopper. Any other RTX-users craving for a DLSS-implementation btw? ;)
 
Last edited:
Hi,

I'm driving with Valve Index at 120hz with the following specs.

  • CPU : i7 9700K @ 5.0GHz
  • COOLER: Fractal Design Celsius S36
  • GPU : RTX 3070
  • RAM : Vengeance LPX Black 32GB / 3600MHz
  • PSU : HX750 750W 80+ Platinum
  • Chassi : Fractal Design Define R6
  • Monitor : Asus ROG Swift PG349Q 34" 120Hz
  • HDD : 1x Samsung 970 EVO Plus series SSD 1TB M.2

Attached my ingame and Nvidia settings aswell.

Everything is working great, have tried racing with 40 ai's in the grid and no problems so far.
 

Attachments

  • ACC Video 1.jpg
    ACC Video 1.jpg
    147.5 KB · Views: 151
  • ACC Video 2.jpg
    ACC Video 2.jpg
    69.3 KB · Views: 138
  • ACC Video 3.jpg
    ACC Video 3.jpg
    73.4 KB · Views: 141
  • ACC Nvidia Settings 1.jpg
    ACC Nvidia Settings 1.jpg
    58.7 KB · Views: 141
  • ACC Nvidia Settings 2.jpg
    ACC Nvidia Settings 2.jpg
    58.7 KB · Views: 131
  • ACC Nvidia Settings 3.jpg
    ACC Nvidia Settings 3.jpg
    55.9 KB · Views: 152
Hi, thanks for your parameters, I noticed just today that online the graphics are much worse than when playing with the same graphic setting off line, some of you have noticed this. I also found the right balance, but online everything drops drastically. There is someone who has the same configuration as me. I will post photos of my ACC settings
 
For all of you guys and girls who are fortunate enough to call a RTX 3080 their own and who are happy with (only) 72 fps.
Here is my engine.ini I worked on for hours.
The game runs with everything on EPIC except Shadows (High), Material (High) and Foliage LOD (High).
Resolution: 4218x2096 ... 100%
Pixeldensity: 120%
visible AI: All
And I think it looks as good as it gets....

[ConsoleVariables]
vr.InstancedStereo=1
r.RHICmdBypass=0
r.AllowHDR=0
r.TemporalAA.Algorithm=1
r.TemporalAA.Upsampling=1
r.TemporalAASharpen=0.2
r.TemporalAADynamicSharpen=0.1
r.ScreenPercentage=100
r.UsePreExposure=1
r.TemporalAA.R11G11B10History=0
r.TemporalAASamples=8
r.TemporalAAPauseCorrect=1
r.TemporalAA.Upscaler=1
r.TemporalAAFilterSize=1.0
r.Upscale.Quality=3
r.OneFrameThreadLag=1
r.FinishCurrentFrame=0
r.PostProcessAAQuality=6

[/script/engine.renderersettings]
a.URO.ForceAnimRate=2
a.URO.ForceInterpolation=1
r.OptimizeForUAVPerformance=1
r.Streaming.FullyLoadUsedTextures=1
r.Streaming.DefragDynamicBounds=1
r.Streaming.FramesForFullUpdate=60
r.Streaming.HLODStrategy=1
r.Shaders.FastMath=1
r.UseShaderCaching=1
r.UseShaderPredraw=1
r.Streaming.PoolSize=0
r.Streaming.Boost=1.2
r.Streaming.MinMipForSplitRequest=1
r.Streaming.UseMaterialData=1
r.bForceCPUAccessToGPUSkinVerts=True

Tested with Nürburgring with 30 Cars in the night and it runs constantly (except the start) with 72fps.

Another tip for those with a CPU that has more than 8 (real) Cores ... Disable HT! There are a lot of fps to gain!

Anyway...
for those trying to achieve 90fps, I think it gives a good starting point with good/better AA.
 
another go at the engine.ini...
!!! Looks really nice !!!
everything on EPIC except for Shadows (High)
Resolution: 4218x2096 ... 100%
Pixeldensity: 110% ... went down to 110% but pushed sharpness at the cost of aliasing
visible AI: All

[ConsoleVariables]
vr.InstancedStereo=1
r.RHICmdBypass=0
r.AllowHDR=0
r.TemporalAA.Algorithm=1
r.TemporalAA.Upsampling=1
r.TemporalAASharpen=0.2
r.TemporalAADynamicSharpen=0.2
r.TemporalAASharpness=0.2
r.ScreenPercentage=100
vr.PixelDensity=1.1
r.TemporalAA.R11G11B10History=0
r.TemporalAASamples=64
r.TemporalAAPauseCorrect=1
r.TemporalAA.Upscaler=1
r.TemporalAAFilterSize=0.7
r.Tonemapper.Sharpen=0.9
r.EyeAdaptationQuality=3
r.Upscale.Quality=3
r.OneFrameThreadLag=1
r.FinishCurrentFrame=0
r.PostProcessAAQuality=5

[/script/engine.renderersettings]
a.URO.ForceAnimRate=2
a.URO.ForceInterpolation=1
r.OptimizeForUAVPerformance=1
r.Streaming.FullyLoadUsedTextures=1
r.Streaming.DefragDynamicBounds=1
r.bForceCPUAccessToGPUSkinVerts=True
r.Streaming.LimitPoolSizeToVRAM=1
r.UsePreExposure=True
 
Last edited:
Top