Share your VR graphic settings

Here are some extreme settings, i tested some minutes ago. Maybe you like it. I`ve got 130% Supersampling. Maybe you like it. It`s very sharpy! :-D the mipbias -4.62 is because of some calculation. My desktop resolution is 1920x1080. The Oculus Rift resolution is 2160x1200. 2160 x1.3 (SS) = 2808. 2808 divided through 1920 = 1,4625. So i took 4.62 out of this result and i hope, the mipmaps are matching with 1.3 SS resolution. Maybe shimmering and so are less. I don`t know. Because auf temporal upsampling and sharpen to 300% activated and even currentframeweight set t 0.16 it`s ok. And sharp!! :-D

[ConsoleVariables]
r.MaxAnisotropy=16
r.Streaming.FullyLoadUsedTextures=1
r.Streaming.DefragDynamicBounds=1
r.TemporalAACurrentFrameWeight=0.16
r.TemporalAASamples=4
r.SeparateTranslucency=0
r.DepthOfFieldQuality=0
r.SceneColorFormat=2
r.SceneColorFringeQuality=0
r.BlurGBuffer=0
r.HZBOcclusion=0
r.SSR.Quality=1
r.SSR.MaxRoughness=0
r.RHICmdBypass=0
r.streaming.MipBias=-4.62
r.mipmaplodbias=-4.62
r.LightShaftDownSampleFactor=4
r.TiledReflectionEnvironmentMinimumCount=10
r.TranslucencyLightingVolume=0
r.TranslucencyLightingVolumeDim=24
r.FastBlurThreshold=0
r.AmbientOcclusionLevels=2
r.FinishCurrentFrame=0
r.CustomDepth=0

[/Script/Engine.RendererSettings]
r.DefaultFeature.AmbientOcclusion=False
r.DefaultFeature.AmbientOcclusionStaticFraction=False
r.EarlyZPass=1
r.EarlyZPassMovable=True
 

DEXT3R

25RPM
Hi guys,

i'm a pimax 5k+ user and maybe i find a little tip to push the limit of the "pixel Density" setting.

1- launch ACC in VR Mode (obviously)
2- alt-tab on SteamVR and Settings/applications
3- set the minimum resolution as you can for the AC2-Win64-shipping.exe
(it's seems to have no impact on my VR Headset resolution?!)
upload_2019-7-17_16-7-13.png


4- Close the game and SteamVR
5- Launch ACC and set the pixel Density in the option to the limit of your graphic card and voilà!

I Don't know how but in my case i've got a better result in this way than scaling down the resolution and raise the pixel Density in the graphic option. Maybe it's a placebo effect. or maybe it could help! ;)

Edit²: pitool set to 1 / ACC graphic option : resolution scale 100%! and pixel Density set to 200 with my RTX2080ti = the clearest visibility, way better than the default settings
 
Last edited:
Hello again,

at the moment i`m very satisfied with my "extreme settings". I downloaded Nvidia Profile Inspector and looked into it. I found a method, to get rid of flimmering lines (like the Porsche Dashboard).

Open Nvidia Profile Inspector and choose Assetto Corsa Competizione. Go to "Texture Filtering" and set it like i did in the picture. Hope you will see a difference all over like i do. And test my extreme settings. :)

EDIT: This also helps in AC1 to reduce line flickering.

nvidia inspector anisotropic ACC.JPG
 
Last edited:

Jordan Dion

Bluestar Racing
Premium
Hello again,

at the moment i`m very satisfied with my "extreme settings". I downloaded Nvidia Profile Inspector and looked into it. I found a method, to get rid of flimmering lines (like the Porsche Dashboard).

Open Nvidia Profile Inspector and choose Assetto Corsa Competizione. Go to "Texture Filtering" and set it like i did in the picture. Hope you will see a difference all over like i do. And test my extreme settings. :)

EDIT: This also helps in AC1 to reduce line flickering.

View attachment 315821
I dont know how you do this, but whit 8700k and my 2080 ti im lagging whit your setting engine.ini file.

What is your SS settings?
I'm at 130
I used sharpen at 185
And mid setting for every thing except AA..
 
I dont know how you do this, but whit 8700k and my 2080 ti im lagging whit your setting engine.ini file.

What is your SS settings?
I'm at 130
I used sharpen at 185
And mid setting for every thing except AA..
My SS is 130, too. Sharpness is set to 240%.

Hmm, interesting. My specs are a AMD Ryzen 2600 @ 3.8Ghz, 16GB DDR4 Ram, Mainboard with B450 chipset and a Nvidia GTX 1070ti stock, no OC. Every driver are up to date. I just got my minor lags when starting a race with 18 KI, but after some corners these small lags are gone. practice everything is fine. Maybe you should set your mirror resolution down to low, as Kunos claimed, that it's no good in VR.

Do have ASW activated? Did you increase your pagefile set it static? I set my pagefile to 12000MB. It's an known issue with Unreal Engine 4. If you have a SSD and set pagefile to non, UE4 games could lag heavily or even crash completely.
Maybe you've got some other tasks running in the background while playing ACC. Your hardware should easily handle ACC with these settings.

The Nvidia settings are just effecting Anisotropic filtering. Your 2080ti should handle it easily!

These engine setting.ini should increase the performance. I just changed the texture LOD Bias to an extreme value and added the value temporalaacurrentframeweight. This value decreases the Temporal Antialiasing a bit by 16%, I think. The image will be a bit sharper with this value without losing the complete smoothness of Temporal Antialiasing. The settings are nearly the same then ever, except the extreme LODbias value and a little less temporal Antialiasing for sharpness (currentframeweight=0.16).
 
Last edited:

Jordan Dion

Bluestar Racing
Premium
My SS is 130, too. Sharpness is set to 240%.

Hmm, interesting. My specs are a AMD Ryzen 2600 @ 3.8Ghz, 16GB DDR4 Ram, Mainboard with B450 chipset and a Nvidia GTX 1070ti stock, no OC. Every driver are up to date. I just got my minor lags when starting a race with 18 KI, but after some corners these small lags are gone. practice everything is fine. Maybe you should set your mirror resolution down to low, as Kunos claimed, that it's no good in VR.

Do have ASW activated? Did you increase your pagefile set it static? I set my pagefile to 12000MB. It's an known issue with Unreal Engine 4. If you have a SSD and set pagefile to non, UE4 games could lag heavily or even crash completely.
Maybe you've got some other tasks running in the background while playing ACC. Your hardware should easily handle ACC with these settings.

The Nvidia settings are just effecting Anisotropic filtering. Your 2080ti should handle it easily!

These engine setting.ini should increase the performance. I just changed the texture LOD Bias to an extreme value and added the value temporalaacurrentframeweight. This value decreases the Temporal Antialiasing a bit by 16%, I think. The image will be a bit sharper with this value without losing the complete smoothness of Temporal Antialiasing. The settings are nearly the same then ever, except the extreme LODbias value and a little less temporal Antialiasing for sharpness (currentframeweight=0.16).
I will look at rhiys after my vacation!
ACC is hard on my PC.
For the page file setting...it makes my pc crash on the past
 

QWASZX

100RPM
Premium
Guys,

Using Oculus S, 1080, 8700k.

Can you please summarize the best current settings possible?

I am really lost on this, and reading through 19 pages doesn’t help...

Thanks so much in advance!
 

anton_Chez

1000RPM
Premium
Really Rob? I had issues with rebinding the recenter to a button, but Ctrl + Space I'm pretty sure re centers the view.
 
I have just tried all settings i could find on the latest pages, but it was horrible to look at. Distorted in the distance mostly. So i decided to take out all the settings from engine.ini, and fiddle ingame settings. This is on version 1.07 of acc. It looks so much better now and with my current settings i have almost no stuttering anymore. I run a 1080ti overclocked (max clock 2000), i7-5930k overclocked at 4.2ghz and 32gb ram with Oculus Rift. My settings are now like this, vr pixel density at 130%:
upload_2019-8-10_11-1-12.png

upload_2019-8-10_11-1-49.png

upload_2019-8-10_11-2-50.png
 
Last edited:
Here are some extreme settings, i tested some minutes ago. Maybe you like it. I`ve got 130% Supersampling. Maybe you like it. It`s very sharpy! :-D the mipbias -4.62 is because of some calculation. My desktop resolution is 1920x1080. The Oculus Rift resolution is 2160x1200. 2160 x1.3 (SS) = 2808. 2808 divided through 1920 = 1,4625. So i took 4.62 out of this result and i hope, the mipmaps are matching with 1.3 SS resolution. Maybe shimmering and so are less. I don`t know. Because auf temporal upsampling and sharpen to 300% activated and even currentframeweight set t 0.16 it`s ok. And sharp!! :-D

[ConsoleVariables]
r.MaxAnisotropy=16
r.Streaming.FullyLoadUsedTextures=1
r.Streaming.DefragDynamicBounds=1
r.TemporalAACurrentFrameWeight=0.16
r.TemporalAASamples=4
r.SeparateTranslucency=0
r.DepthOfFieldQuality=0
r.SceneColorFormat=2
r.SceneColorFringeQuality=0
r.BlurGBuffer=0
r.HZBOcclusion=0
r.SSR.Quality=1
r.SSR.MaxRoughness=0
r.RHICmdBypass=0
r.streaming.MipBias=-4.62
r.mipmaplodbias=-4.62
r.LightShaftDownSampleFactor=4
r.TiledReflectionEnvironmentMinimumCount=10
r.TranslucencyLightingVolume=0
r.TranslucencyLightingVolumeDim=24
r.FastBlurThreshold=0
r.AmbientOcclusionLevels=2
r.FinishCurrentFrame=0
r.CustomDepth=0

[/Script/Engine.RendererSettings]
r.DefaultFeature.AmbientOcclusion=False
r.DefaultFeature.AmbientOcclusionStaticFraction=False
r.EarlyZPass=1
r.EarlyZPassMovable=True
Wow thank you. Tested it before the latest update (together with the Nvidia Inspector settings suggested) and run like a beauty.
Tested also after installing the 1.0.7 update and still runs great! Finally... Thanks a lot for sharing all your hard work.
 

QWASZX

100RPM
Premium
I have just tried all settings i could find on the latest pages, but it was horrible to look at. Distorted in the distance mostly. So i decided to take out all the settings from engine.ini, and fiddle ingame settings. This is on version 1.07 of acc. It looks so much better now and with my current settings i have almost no stuttering anymore. I run a 1080ti overclocked (max clock 2000), i7-5930k overclocked at 4.2ghz and 32gb ram with Oculus Rift. My settings are now like this, vr pixel density at 130%:View attachment 319362
View attachment 319363
View attachment 319364
Hi Pieter,

I have tried your settings (with a few High turned into Mid because I have a 1080) but no matter what I do,
the (very close!) distance is still very blurry to the point that I can't identify any breaking points on time.

The game seems to run smooth (only tested in practice alone at Nurburgring) but very blurry at distance - probably the worst out of all sims out there today.

Is that to be expected?
What are other settings are you using: Nvidia panel, Windows, INI file, GTX driver version?

Thanks so much in advance.
 
Hi Pieter,

I have tried your settings (with a few High turned into Mid because I have a 1080) but no matter what I do,
the (very close!) distance is still very blurry to the point that I can't identify any breaking points on time.

The game seems to run smooth (only tested in practice alone at Nurburgring) but very blurry at distance - probably the worst out of all sims out there today.

Is that to be expected?
What are other settings are you using: Nvidia panel, Windows, INI file, GTX driver version?

Thanks so much in advance.
Strange. It should be quite ok to look at with these settings. I have latest Nvidia drivers, didn't change anything in Nvidia panel, but I can make a screenshot when I come home. The ini file will be automatically updated by the game with the settings. No need to go there. I suggest to lower shadows, but up aa and post-processing. In oculus tray tool I have aws set to auto. Did you put supersampling to 130%?
 

QWASZX

100RPM
Premium
Strange. It should be quite ok to look at with these settings. I have latest Nvidia drivers, didn't change anything in Nvidia panel, but I can make a screenshot when I come home. The ini file will be automatically updated by the game with the settings. No need to go there. I suggest to lower shadows, but up aa and post-processing. In oculus tray tool I have aws set to auto. Did you put supersampling to 130%?
I have used the exact settings you posted.
I will look into it further when I get home.

I really want to enjoy this sim, but current VR performance isn’t acceptable unfortunately.
 

Metzger82

100RPM
I have used the exact settings you posted.
I will look into it further when I get home.

I really want to enjoy this sim, but current VR performance isn’t acceptable unfortunately.
Did you try this ?

https://www.assettocorsa.net/forum/index.php?threads/the-best-performance-ive-achieved.58766/

Set SS in game to 150-160, set temporal AA to high and it is sharp and smooth, turn off Volumetric fog too.


Rift S 1080TI and 8700K, performance is very acceptable for me. With ASW on, I have no issues at all.
 
Top Bottom