Share your VR graphic settings

Angeltheartist

250RPM
Premium
Good evening, Is there anyone using Oculus Rift that can suggest or post graphic settings so that VR can run smoothly. Thank you.
 

Jordan Dion

Bluestar Racing
Premium
Hi!
1080ti
8700k
16gb ddr4
Rift

Everything to maximum..
I use the resolution scaling at 130...

Not sure if i should use 200 and reduce other settings?
Since it is really blurry for me...
 
Set resolution scale to high as you can go, view distance High, textures high, everything else low, turn AA off.

Then go to: Users/Yourusername/AppData/Local/AC2/Saved/Config/WindowsNoEditor
Open the Engine.ini file

Then write this below it:

[ConsoleVariables]
r.Tonemapper.Sharpen=3
 

schlitty

100RPM
Thanks for that tip Echo291191. Something worth playing around with. The AA is really blurry/soft. I don't got a beast so resolution scale suffers but I'd much rather be able to see things clearly with jaggies rather than no smooth but blurry. Plenty fine, especially still being Early Access.

Good thread idea, I'm all for more tweaks and tips.
 

ThugUK

500RPM
I don't find it that blurry, well, no more than any other game.
What I do like is that you can change settings on the fly and see what improvements they make without exiting the game session.
 

Tberg

500RPM
This will seriously fix VR visuals for now:

You can play with the vr.PixelDensity value vs. ingame Resolution Scale, haven't experimented much if it overwrites one another or what.
I prefer AA set to Temporal, High (delete r.PostProcessAAQuality=4 if you want ingame options to work). Don't use Epic, not worth it.

\Users\you\AppData\Local\AC2\Saved\Config\WindowsNoEditor
Open "engine.ini" and insert this at the bottom of the rest:

[ConsoleVariables]
r.TemporalAACatmullRom=1
r.TemporalAAPauseCorrect=1
r.TemporalAASamples=4
r.Tonemapper.Sharpen=4
vr.PixelDensity=1.4
r.SeparateTranslucency=0
r.HZBOcclusion=0
r.MotionBlurQuality=0
r.PostProcessAAQuality=4
r.BloomQuality=0
r.EyeAdaptationQuality=0
r.AmbientOcclusionLevels=0
r.SSR.Quality=1
r.DepthOfFieldQuality=0
r.SceneColorFormat=3
r.TranslucencyVolumeBlur=0
r.TranslucencyLightingVolumeDim=48
r.LensFlareQuality=0
r.SceneColorFringeQuality=0
r.FastBlurThreshold=0
r.SSR.MaxRoughness=0.1
r.RHICmdBypass=0
r.DetailMode=1
r.RefractionQuality=2
r.MaterialQualityLevel=1
sg.ShadowQuality=2
 
Last edited:

Ian Cameron

250RPM
This will seriously fix VR visuals for now:

You can play with the vr.PixelDensity value vs. ingame Resolution Scale, haven't experimented much if it overwrites one another or what.
I prefer AA set to Temporal, High. Don't use Epic, not worth it.

\Users\you\AppData\Local\AC2\Saved\Config\WindowsNoEditor
Open "engine.ini" and insert this at the bottom of the rest:

[ConsoleVariables]
r.TemporalAACatmullRom=1
r.TemporalAAPauseCorrect=1
r.TemporalAASamples=4
r.Tonemapper.Sharpen=4
vr.PixelDensity=1.4
r.SeparateTranslucency=0
r.HZBOcclusion=0
r.MotionBlurQuality=0
r.PostProcessAAQuality=4
r.BloomQuality=0
r.EyeAdaptationQuality=0
r.AmbientOcclusionLevels=0
r.SSR.Quality=1
r.DepthOfFieldQuality=0
r.SceneColorFormat=3
r.TranslucencyVolumeBlur=0
r.TranslucencyLightingVolumeDim=48
r.LensFlareQuality=0
r.SceneColorFringeQuality=0
r.FastBlurThreshold=0
r.SSR.MaxRoughness=0.1
r.RHICmdBypass=0
r.DetailMode=1
r.RefractionQuality=2
r.MaterialQualityLevel=1
sg.ShadowQuality=2
Very much improved visually, thanks. However still getting quite a bit of stuttering.
What do you recommend I set the other video settings at, I have a 1070 card
 

Tberg

500RPM
Very much improved visually, thanks. However still getting quite a bit of stuttering.
What do you recommend I set the other video settings at, I have a 1070 card
Hard to tell what is optimal, there's a lot of things that needs optimization, but for what I've experienced:
(I'm on a 1080ti/i5 4690K on the Rift CV1)

  • using temporal AA induces some ghosting, which looks stuttering if you can't run 90fps. Try FXAA.
  • if you run with Oculus ASW on, 45fps, ACC seems to have issues with locking in using Auto ASW. Try CTRL+Numpad1 and cycle through CTRL+Np2, 3 and 4, see what gives the best result.
  • Foilage takes a big hit on fps, set it to low, doesn't make a huge difference at all visually.
  • Textures can be set to low as well, it affects anything at a distance >10-20meters from the car, which isn't that important in VR vs. fps.
  • Shadow to Mid
  • Post process to Mid, or low if you can live with the colors and lack of ligthing.
  • finally, vr.PixelDensity takes a big toll the lower card you have. Set Resolution Scale ingame to 100%, then try lowering vr.PD to 1.3
 

Ian Cameron

250RPM
Hard to tell what is optimal, there's a lot of things that needs optimization, but for what I've experienced:
(I'm on a 1080ti/i5 4690K on the Rift CV1)

  • using temporal AA induces some ghosting, which looks stuttering if you can't run 90fps. Try FXAA.
  • if you run with Oculus ASW on, 45fps, ACC seems to have issues with locking in using Auto ASW. Try CTRL+Numpad1 and cycle through CTRL+Np2, 3 and 4, see what gives the best result.
  • Foilage takes a big hit on fps, set it to low, doesn't make a huge difference at all visually.
  • Textures can be set to low as well, it affects anything at a distance >10-20meters from the car, which isn't that important in VR vs. fps.
  • Shadow to Mid
  • Post process to Mid, or low if you can live with the colors and lack of ligthing.
  • finally, vr.PixelDensity takes a big toll the lower card you have. Set Resolution Scale ingame to 100%, then try lowering vr.PD to 1.3
VR quality has greatly improved with those settings but stutter is still really bad. Have tried all your suggestions, still no change.
 

Tberg

500RPM
VR quality has greatly improved with those settings but stutter is still really bad. Have tried all your suggestions, still no change.
Do you run 45fps or 90fps? Rift or Vive, or a 3rd HMD?

It might not at all be related to fps though.

Edit: oh, try turning off Radio comms in audio, I've read some had issues with stutters because of it.
 
i found that if you set the game to use a resolution lower than the one on your desktop and on window mode, it runs much fluid, and when you exit from the game it closes correctly and it do not causes a SteamVr crash.
 
Thanks everyone for all the tips.

Could someone kindly explain how to check FPS ingame in VR mode?

Windows 7 Ultimate Pro + Oculus Rift CV1 here.

Thanks a lot
 

scottiedawg66

Race Events Host
Staff
Premium
VR quality has greatly improved with those settings but stutter is still really bad. Have tried all your suggestions, still no change.
Ian if you have any updates please post them. I also have a 1070 and am curious if it will support ACC in VR. are you on a rift?
 

Ian Cameron

250RPM
Do you run 45fps or 90fps? Rift or Vive, or a 3rd HMD?

It might not at all be related to fps though.

Edit: oh, try turning off Radio comms in audio, I've read some had issues with stutters because of it.
Ian if you have any updates please post them. I also have a 1070 and am curious if it will support ACC in VR. are you on a rift?
Yes a 1070 works fine with my rift. I'm just playing around with settings and will post them soon.
 

Ian Cameron

250RPM
Okay here are my settings.
Oculus Rift, GTX 1070 Graphics

ACC Video.jpg

Oculus Tray Tool.jpg

In sound I have turned off Radio Comms. resolution scale does make an impact on stuttering.
Also might want to check this out, which makes a huge impact on CPU.
https://www.reddit.com/r/oculus/comments/8uf1sm/oculushomeless_use_dash_without_home_20/

In all a massive change from before, still not perfect, still have a few slight stutters but vast improvement.
Thanks to Tberg for his suggestions.
Have to say at such an early stage of development this game is pretty damn good and can't wait for future updates.
 

scottiedawg66

Race Events Host
Staff
Premium
thanks for a detailed response! Is your VR pixel density still at 1.4 or 1.3 with these settings as per Tbergs post
 

Tberg

500RPM
Okay here are my settings.
Oculus Rift, GTX 1070 Graphics

View attachment 274249
View attachment 274250
In sound I have turned off Radio Comms. resolution scale does make an impact on stuttering.
Also might want to check this out, which makes a huge impact on CPU.
https://www.reddit.com/r/oculus/comments/8uf1sm/oculushomeless_use_dash_without_home_20/

In all a massive change from before, still not perfect, still have a few slight stutters but vast improvement.
Thanks to Tberg for his suggestions.
Have to say at such an early stage of development this game is pretty damn good and can't wait for future updates.
Quite pleased to see a workaround to getting rid of Home, I really dislike that it is forced now by Oculus. Thanks for the link, first thing when I get home :)
 
Top Bottom