rFactor with a gamepad.

passenger

250RPM
Jul 6, 2019
335
361
36
Hey guys,

After several years, I´ve reinstalled rFactor 1 on an old machine so it is played by a kid with a
gamepad (he can not master a wheel and its pedals yet), and I need your help on a small
subjet.

The gamepad is not as smooth as it could be, it´s jerky. I´ve set up the 'Digital Steering Rate'
at its minimum, 10%, and its 'Speed Sensivity' at the minimum too, 0%, but the movement
of the wheel is still a bit jerky. How could I configure it so it is smooth? Is there a way to
achive this within the Controls menu? Or perhaps editing a configuration file?

This same gamepad works perfectly smooth in Automobilista.

Thanks!

Cheers.
 

Ho3n3r

5000RPM
Oct 20, 2010
5,567
1,831
Hey guys,

After several years, I´ve reinstalled rFactor 1 on an old machine so it is played by a kid with a
gamepad (he can not master a wheel and its pedals yet), and I need your help on a small
subjet.

The gamepad is not as smooth as it could be, it´s jerky. I´ve set up the 'Digital Steering Rate'
at its minimum, 10%, and its 'Speed Sensivity' at the minimum too, 0%, but the movement
of the wheel is still a bit jerky. How could I configure it so it is smooth? Is there a way to
achive this within the Controls menu? Or perhaps editing a configuration file?

This same gamepad works perfectly smooth in Automobilista.

Thanks!

Cheers.
Try speed sensitivity at 100% and work it down from there. That should help a lot. At 0%, you should really be using a wheel.
 

passenger

250RPM
Jul 6, 2019
335
361
36
Speed Sensivity is at 0% in Automobilista and it works smooth there... if I increase it, the animation becomes jerky.

Alright, I´ve tried decreasing several steps the Speed Sensivity from 100% to 0%, but to no avail... 0% is the smoothest, but still jerky. Since Automobilista can do it, there should be a way to edit this feature so the animation plays back perfectly smooth... perhaps a minus figure somewhere?
 
Last edited:

boern69

100RPM
Jun 9, 2010
127
41
what gamepad are u using ?

try changing

Steer Ratio Speed="20.00000" // Speed at which low speed steering lock override ends (for pit navigation, units are meters/sec, 0.0 to disable)
Speed Sensitive Steering="0.50345

in gamepad.ini file
 
  • Like
Reactions: passenger

passenger

250RPM
Jul 6, 2019
335
361
36
OK, so I tried that setting, Speed Sensitive Steering="0.50345", but there is
no improvement, the animation of the wheel remains jerky.

Thanks anyway.