rFactor shuts down?

Status
Not open for further replies.

Danny Clarke

75RPM
Feb 17, 2009
78
11
Hi everyone.

After too long of looking at screenshots and videos of rFactor, i finally got my new computer and now i can run rFactor.

I downloaded the Lite version of rFactor, since i have a download limit.

Before installing any mods, i decided to just quickly give it a test run with the stock rFactor car at Toban. However when i try to load the track, rFactor shuts down.

Is it because i havent installed any of the car sound and track packs from here?

Im runnning Vista 64 bit.

Help will be much appreciated.

Many thanks, Danny.
 

Ramon van Rijn

RaceDepartment Co-Founder
Premium
May 19, 2007
5,419
258
49
I guess what you can select in game is already installed. I have no experience with the lite version, always install the full version here.
 
Aug 26, 2008
2,550
28
rF lite is the only way forward for a clean install, but it sounds like you have installed a mod / file incorrectly which is causing it to shut down, try deleting what you install and reinstalling again.
 

Danny Clarke

75RPM
Feb 17, 2009
78
11
Thanks for the help guys.

Yeah, i've reinstalled it a couple of times. But it still closes down on a completly clean version.

I also installed a track mod correctly afterwards, but it still closes down and returns to the desktop.
 

Danny Clarke

75RPM
Feb 17, 2009
78
11
Nope, im a newbie to rFactor. Never installed it before.

There isn't an error when loading a track, just closes it down.
 
Aug 26, 2008
2,550
28
Am not sure if rFactor supports the HD4330 mobility. Need to check it out, had it running on a simaler laptop spec though.

What other games can you play on that lappy?
 
A

Andrew Evans

if all else fails you could try starting it in debug.... you need to add

-trace=1000

as a command line argument on the shortcut....

that should produce a trace.txt somewhere in one of the userdata or log folders and it might yield a vital clue as to what's going wrong....
 

Danny Clarke

75RPM
Feb 17, 2009
78
11
Thanks.

Here it is. I completly reinstalled rFactor again. So this is the first run.

TRACE LEVEL = 1000
NetComm.cpp 11193: NetComm checking command line: "-trace=1000"
game.cpp 1211: Entered Game::Enter()
osman.cpp 540: Entered OSMan::Enter()
plrfile.cpp 2314: Entered PlayerFile::Enter()
NetComm.cpp 14056: NetComm: Error opening banlist xml file
vidman.cpp 1229: Entered VidMan::Enter()
specialfx.cp 3795: Entered SpecialFX::Enter()
dynman.cpp 613: Entered DynMan::Enter()
sound.cpp 727: Entered Sound::Enter()
hwinput.cpp 7979: Entered HWInput::Enter()
hwinput.cpp 7980: HKL=0x08090809
onscreen.cpp 1787: Entered OnScreen::Enter()
gamestats.cp 906: RaceCast Location set to: racecast.rfactor.net
game.cpp 1296: Entered Game::Setup()
hwinput.cpp 8024: Entered HWInput::Setup()
options.cpp 1911: Entered Options::Setup()
O_AppObj.cpp 2813: Initiate options object creation
O_OSC.cpp 2652: Entered Options_OSC_Reader::ReadOSC()
vidman.cpp 1023: Trying to Play Bink File: MOVIEFILES\ISILogo.bik
vidman.cpp 1119: Bink file video play success
vidman.cpp 1023: Trying to Play Bink File: MOVIEFILES\.bik
vidman.cpp 1023: Trying to Play Bink File: MOVIEFILES\PreGame.bik
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
tire_manager 1249: Non-existent tire brand ""
tire_manager 1249: Non-existent tire brand ""
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_OSC.cpp 2727: Exited Options_OSC_Reader::ReadOSC()
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
tire_manager 1249: Non-existent tire brand ""
tire_manager 1249: Non-existent tire brand ""
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppGz.cpp 33845: Could not open RFM\
O_AppObj.cpp 2876: Options object creation successful
plrfile.cpp 1727: Attempting to save to USERDATA\Danny Clarke\Danny Clarke.TMP
plrfile.cpp 1757: Retcode: 0 for renaming to USERDATA\Danny Clarke\Danny Clarke.PLR
setup.cpp 2313: Could not find HAMMER/HAMMER.MAS
setup.cpp 2313: Could not find Hammer_PC_Skin.dds
setup.cpp 768: Not using vehicle GAMEDATA\VEHICLES\PACECAR\HAMMER_PC\HAMMER_PC.VEH because one or more important references could not be found
setup.cpp 1892: Did not add vehicle GAMEDATA\VEHICLES\PACECAR\HAMMER_PC\HAMMER_PC.VEH (either because it did not pass filter or error)
gamestats.cp 906: RaceCast Location set to: racecast.rfactor.net
NetCommUtil. 853: NetCommUtil: Error opening friends list xml file
NetCommUtil. 671: NetCommUtil: Error opening friends list xml file
util.cpp 542: Unable to adjust texture for material: wcwindow, tex0=GAMEDATA\VEHICLES\ZR\SRGP\RFACTOR\rft_02window.dds, tex1=GAMEDATA\VEHICLES\ZR\SRGP\RFACTOR\Misc\rft_02window.dds, tex2=GAMEDATA\VEHICLES\ZR\SRGP\RFACTOR\rft_02window.DDS
util.cpp 542: Unable to adjust texture for material: wcwindow, tex0=GAMEDATA\VEHICLES\ZR\SRGP\RFACTOR\rft_02window.dds, tex1=GAMEDATA\VEHICLES\ZR\SRGP\RFACTOR\Misc\rft_02window.dds, tex2=GAMEDATA\VEHICLES\ZR\SRGP\RFACTOR\rft_02window.DDS
specialfx.cp 3801: Entered SpecialFX::Setup()
steward.cpp 6454: Entered Steward::Setup()
dynman.cpp 641: Entered DynMan::Setup()
sound.cpp 740: Entered Sound::Setup()
onscreen.cpp 1793: Entered OnScreen::Setup()
vidman.cpp 1378: Entered Vidman::Setup()
game.cpp 1826: Entered Game::Exit()
sound.cpp 846: Entered Sound::Exit()
specialfx.cp 4529: Entered SpecialFX::Exit()
hwinput.cpp 8128: Entered HWInput::Exit()
dynman.cpp 1849: Entered DynMan::Exit()
onscreen.cpp 1964: Entered OnScreen::Exit()
vidman.cpp 2092: Entered VidMan::Exit()
osman.cpp 583: Entered OSMan::Exit()
 

Danny Clarke

75RPM
Feb 17, 2009
78
11
Yep, i can get into the game's main screen. Choose my car and track. But when i click load track, rFactor closes.
 

Bram Hengeveld

RaceDepartment Founder
Staff
Premium
Dec 26, 2006
45,833
19,404
I am not sure with rF but other ISI engined always say they are not compatible with laptops
 
Status
Not open for further replies.