rFactor pauses

Discussion in 'rFactor' started by wilf42, Mar 31, 2009.

Thread Status:
Not open for further replies.
  1. wilf42

    wilf42

    Messages:
    5
    Ratings:
    +0
    Hi all. New to the forums and sim racing (I don't even have a wheel yet!). I've been trying demos of various sims to see what I like but I'm having a bit of a problem with rFactor. Every so often (about twice a lap on average) the screen and sound freezes for a few seconds. During this pause there is no response to any controls. Then it will start up again as if nothing had happened. If I watch a replay it looks as though the car stops, reverses for a few yards, then drives forward past where it originally stopped, pauses for a few seconds and then drives on.

    I am running the program on a laptop (not ideal I know) with an Intel Core 2 Duo T7300, 2 gig RAM and a GeForce 8600M graphics card. The OS is Vista Home Premium 32-bit. I have tried reinstalling the software and running as administrator but nothing seems to make any difference. I'm just hoping that you good people might have a suggestion for me, because if it wasn't for this I like rFactor a lot. I just don't think I'm going to be very competitive if my car stops a couple of times a lap! :laugh2:

    Regards

    Andrew
     
  2. Ramon van Rijn

    Ramon van Rijn

    Messages:
    5,399
    Ratings:
    +235
    Just to make sure, the laptop was not on battery?
    Laptops run on lower frequency and fps when on battery.
    But I guess we can exclude that one?

    Have you downloaded the latest directx 9 drivers and have tried other demo's like Race07 or GTR Evolution?
     
  3. wilf42

    wilf42

    Messages:
    5
    Ratings:
    +0
    I have been running the laptop on mains power, so that's OK. I have also been able to run GTR Evo and Netkar Pro without problems. But I did miss updating DX9, so I'll have a go at that and report back. Thanks for the input.

    Quick edit - Tried updating DX9 but I still have the problem.

    Regards

    Andrew
     
  4. Ramon van Rijn

    Ramon van Rijn

    Messages:
    5,399
    Ratings:
    +235
    Can you try to run rF windowed? See if that differs. Its in the rF config.
    Also try different settings like resolution and anti-alias.
    Btw, often problems in games are related to soundcards. Try to lower it in the same rF config. Even try software audio.
     
  5. wilf42

    wilf42

    Messages:
    5
    Ratings:
    +0
    Thanks for the suggestions. I'll give those a go when I get back from work.
     
  6. wilf42

    wilf42

    Messages:
    5
    Ratings:
    +0
    Well I spent the evening tweaking settings and making changes in Config.ini. I had the graphics and audio settings with everything turned right down and everything turned right up and I still get this little pause every so often. It's beginning to look like GTR Evo for me.
     
  7. Dave Robinson

    Dave Robinson

    Messages:
    229
    Ratings:
    +12
    Right click on the rfactor icon on your desk top. Select properties, then click on the Shortcut tab. In the target box add this
    +fullproc +highprio
    Mine looks like this but you will have rfactor installed in a different location
    C:\Games\rFactor\rFactor.exe +fullproc +highprio

    Might solve the pauses I know it has for other people.
     
  8. James Johnson

    James Johnson
    The Weatherman

    Messages:
    5,457
    Ratings:
    +219
    i only get it online in server? :S

    Edit: on server now but it isnt there now :)
     
  9. wilf42

    wilf42

    Messages:
    5
    Ratings:
    +0
    Thanks for this. I had found the +fullproc argument but not the +highprio. I'll try them together and see if that helps.
     
  10. Dave Robinson

    Dave Robinson

    Messages:
    229
    Ratings:
    +12
    So did it solve the problem or not wilf?
     
Thread Status:
Not open for further replies.