Rfactor crashes when loading track due to RAM 64bit version?

nouse4aname

1RPM
Original poster
Mar 19, 2011
6
0
Hi everyone i'm hoping someone can help me.

Rfactor 2 has been working on my system with out any problems what so ever until now.

When I load up a track (any track) the loading bar reaches the end and then a error pops up informing me that there is a memory allocation issue and that the 32bit version of rfactor cant use more than 3gb and it wants to use around 6Gb.
Now that would be fine however Im not using the 32 version of Rfactor 2.
- i don't have the force 32bit option enabled.
- According to a couple of google searches if i alt tab to the task manger and if i see a *32 next to Rfactor2 then I'm running the 32bit version however this is not the case for me which tells me I am running the 64bit version.
- I have tried starting rfactor2 64bit directly from within the bin64 folder and I still receive the same error.
-the only thing that has changed is I purchased both Sebring and the new GT3 pack that's it unless Windows 10 has changed something without me knowing.
-I have also verified my local files through steam and there was no issues found.


Any help would be greatly appreciated.
 

Tardy Tony

250RPM
Mar 11, 2018
312
103
53
I had the same. I am pretty sure a full PC shutdown and restart did the track, not seen the issue again.
 

Tardy Tony

250RPM
Mar 11, 2018
312
103
53
Actually, I think I went through and removed a load of mods too. I may have disabled all but the essential plugins. Anyway, good luck getting it sorted.
 

makan

250RPM
Nov 14, 2015
257
253
35
@nouse4aname
From the devs :
"
Hey guys,

We have noticed a few of you having issues with crashing on the new build. This appears to be from 3rd party unsporrted plugins which are causing problems.

So to fix - Please clean your installation by simply deleting the "Bin64 folder" and let Steam verify your files.

Thanks
,"
 

Marcel Offermans

Studio 397
Aug 9, 2010
934
2,133
Now that would be fine however Im not using the 32 version of Rfactor 2.
I would take a look at the suggestion @makan offered above, just to be sure, but the message you are getting suggests that you ran out of memory. The message that states that you were running a 32 bits version is actually wrong (I just checked the code and that's a small mistake on our part and will be fixed in the next code update). You are running the 64 bits version. So you might have run out of memory, or the memory was somehow too fragmented. If a reboot did not help, please let me know how much physical and virtual memory you have on your PC.
 
  • Like
Reactions: Frank Murphy

Frank Murphy

10RPM
Jun 25, 2017
11
61
49
Hi guys, hi Marcel,

I had the same issue but without any kind of message. Yesterday I've tried to start rF2 after a few days (Dec. 28th), but it crashed at the end of loading the track. I've tried to check all files in Steam, have uninstalled some 3rd party content, updated my graphic card driver and after that, I've checked my graphic settings which ever worked fine (in VR). There I found something: With lowest settings, the game starts. So I tried to test each point - with following results: Now it runs fine with all options in highest mode, but only the SHADOWS must be disabled. If I set the shadows on "low" the game will crash. This happens too if I disable each other point (or set it to "low"). So I think it's not a performance problem, it looks like a bug.
After testing I find out: The game starts and works stable with more highest settings than before, but without shadows. But the loading time of the selection menue rised up from 20 sec to 1,5 - 2 min.

I think, it could be possible that this issue based on the latest Win10 update a few days ago.
To everyone, who has the same problems: At the 1st step try to set down your graphic settings 'till the next update.

My system: i7-6700K CPU | 16GB Ram | Gforce GTX1080 | 512GB SSD | Win10 Prof 64bit | Oculus Rift / 24" Tripplescreen
 
  • Like
Reactions: Tardy Tony

Denis Betty

The older I get, the better I was.
Staff
Premium
Jun 18, 2013
8,104
4,057
This sounds like a problem that's been fairly common recently.
It's discussed and there is a solution over at S397 forum. LINK
First look for a d3d9.dll file in your Bin64 folder, back it up and remove it.
If that doesnt work, delete your Bin64 folder and get Steam to verify your rF2 files.
If all else fails, disable shadows completely from the in game settings.
Let us know how you get on.
Cheers. :)