rFactor 2 | December Development Roadmap

dajdosta

100RPM
Jun 4, 2017
218
117
43
Anyone knows why in packages menu of new UI I can't uninstall any local content except MultiCmp?
For all other components uninstall button is disabled!?
 

davehenrie

500RPM
Jun 4, 2017
645
420
63
Anyone knows why in packages menu of new UI I can't uninstall any local content except MultiCmp?
For all other components uninstall button is disabled!?
I saw that as well. I had some old car mods and ended up using windows to delete the files. Packages "should" be able to do that. I understand GT's frustration, I'm certainly not saying this UI is fully functional or even equal to the features of the old version. But this is the road S397 is determined to travel.
 

Denis Betty

The older I get, the better I was.
Staff
Premium
Jun 18, 2013
7,928
3,950
I saw that as well. I had some old car mods and ended up using windows to delete the files. Packages "should" be able to do that. I understand GT's frustration, I'm certainly not saying this UI is fully functional or even equal to the features of the old version. But this is the road S397 is determined to travel.
I also had this. I had connected to a server which downloaded some content that I didn't want. I tried using the Mod Manager from Bin32 to remove it, but I couldn't work out how to do it with that either.
In the end, I rolled back to the old UI - only took a few minutes.
There are other known bugs with the new UI, eg Tab doesn't bring up name tags when out on track.
For me, I'll use the new UI when it's fully functional or when I'm forced to, whichever comes first. To each his own. :)
 
Last edited:
  • Like
Reactions: Sam12H and rand777

GuitarTech

500RPM
Premium
Sep 25, 2011
799
586
I also had this. I had connected to a server which downloaded some content that I didn't want. I tried using the Mod Manager from Bin32 to remove it, but I couldn't work out how to do it with that either.
In the end, I rolled back to the old UI - only took a few minutes.
There are other known bugs with the new UI, eg Tab doesn't bring up name tags when out on track.
For me, I'll use the new UI when it's fully functional or when I'm forced to, whichever comes first. To each his own. :)
I 've tried to like the new UI, I really have. But in the sum of things, I can't really see what it does for me. After all the trouble getting the mouse cursor to work in VR so I could even begin to use it, I'm trying to see what is better about it. I only drive offline anyway, the new competition system doesn't interest me much, even if it worked properly . Until all the features from the old UI are in the new one, I'll be staying with the old UI, till such time as I'm forced to use the new UI.
It is beyond my understanding how they could need over four years for this pile of poo...what were the beta testers doing for over a year?
 
Last edited:

dajdosta

100RPM
Jun 4, 2017
218
117
43
I saw that as well. I had some old car mods and ended up using windows to delete the files. Packages "should" be able to do that. I understand GT's frustration, I'm certainly not saying this UI is fully functional or even equal to the features of the old version. But this is the road S397 is determined to travel.
Are you saying you have the same problem?
I expect this to work for most users otherwise it would be reported everywhere?
 

davehenrie

500RPM
Jun 4, 2017
645
420
63
Are you saying you have the same problem?
I expect this to work for most users otherwise it would be reported everywhere?
There was an update this evening and when I went to packages, I was able to un-install and delete content. Maybe it's fixed.
 

davehenrie

500RPM
Jun 4, 2017
645
420
63
You then generally get a field full of McLaren's due to the World Series skins dominating the remaining cars.
I understand, that is why the Vmod is the most precise solution. You create a mod in Devmode and only allow the cars and tracks you want. I THINK that new versions of cars or tracks will break the mod and you will have to repeat the procedure with the updated car files.
 

stenovitz

100RPM
Aug 22, 2014
125
171
48
Well, what happened? I've just been away a couple of weeks from rF2 and now this UI?
In fact I wasn't about to play, just wanted to check some setting possibilities before entering bed. Now, past my bedtime, I was lurked into trying a lap, but had'nt plugged my racing gear to, so just wanted to change to personal keyboard settings. After setting up and pressing save and moving on to other settings like Display - just white screen?? Is this S397's version of blue screen of death? Afraid I have to kill rF2 job now, waiting almost 10 mins with white screen.
There's no background dialog telling about an error or so?
Apart from that I think, I can get used to the new UI - My first impression is, that the UI is primarily aimed for online simmers. Which is not me (ok 2% of my sim time, maybe), but it's ok with me, just hope the new UI hasn't crashed anything or setting a higher bar for hardware or so on (I'm on the low side here).
Anyway, will look into this on wednesday.

Edit: OK, so no sleep :D
Did a game restart and edited to my personal keyboard settings, but trying to entering other settings, as 'Display', etc., stille just white screen :confused:
But now just wanted to do a drive. Apparently Callaway Corvette C7 @ Nordschleife and setting to 24x time acceleration and scripted weather. Just after the first four rounds - what a blast! And the Live menu with gps data - wow! And even seems rF2 engine working much better witth my mid-low spec PC (6th Gen Intel Core i5-6600T and Sapphire RX 580) but now at a blistering 70-110 FPS. And all the new features - hey S397, I see you're lurking me into online racing, you might even get luck with the job :D OK my plan for my free wednesday originally was to dig a more into AMS2 as a newcomer there, but this experience really got me grow even more for rF2.

Splendid job, S397.
 
Last edited: