rF2 won't launch - gMotor2 Error - Error creating standard default shader

Discussion in 'rFactor 2' started by Celtic Pharaoh, Jan 29, 2012.

  1. Celtic Pharaoh

    Celtic Pharaoh
    Always strive to achieve more Premium

    Hi all. I recently got rF2 but I keep getting a strange error. rF2 won't even get to the menu screen. I tried reinstalling it onto my C:\ partition as I read from a couple threads over at the ISI forums that can fix it. For some people, it did, yes but no difference with me. I've tried disabling AA and AF from Catalyst and made sure the Filter wasn't Edge-Detect, but the error is still there. I've tried setting the rFactor2.exe to run as administrator, but still, no difference. I tried was the folder attributes where I unchecked Read-Only as I thought it might be a write error, but still, no go. I then tried it on my laptop which is a different system to my desktop (AMD / Intel and ATI / NVIDIA) but I get the same error on the laptop as well. The last thing I tried was trying alternative OS on my desktop, Windows XP but the error is on there too so I feel like I've exhausted all possible options so would anyone know how to fix this? Thanks.
  2. Andy White

    Andy White

    Seems like it isn't a problem with your system. As you say, you've tried it on other systems. Sounds like the installer might be corrupt. Try re-downloading the files and re-install again. HTH