Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Rookie friendly WTCR sereis Weekly rFactor 2 events

Reducing AC CPU usage

Messages
907
Points
952
Edit: this appears to be mostly related to AMD Crossfire - if you have any experience with that, please contribute anything you can! there is plenty of cpu available with a single GPU.

This is not anything about the 99% occupancy warning which the game hasn't given me for quite a while - I've just been tweaking my current rig and finding it's noticeably CPU bound.

Last benchmark results - was fiddling with AA ( no FXAA & 2xAA makes a big difference ) and reflections ( basically no difference between everything full & everything as low as it'll go without crossfire artifacts ).

Code:
AC VERSION: 1.16.3 (x64)
POINTS: 8541
FPS: AVG=58 MIN=30 MAX=117 VARIANCE=19 CPU=96%

LOADING TIME: 16s
GPU: Radeon RX 580 Series (7680x1440)
OS-Version: 6.1.7601 (Service Pack 1) 0x100-0x1
CPU CORES: 12
FULLSCREEN: ON
AA:2X AF:16X SHDW:2048 BLUR:0
WORLD DETAIL: 5 SMOKE:2
PP: QLT:5 HDR:1 FXAA:0 GLR:5 DOF:0 RAYS:1 HEAT:1

I have FFBClip running in the background usually ( and helicorsa but I don't think that'll make a noticeable difference anywhere ) and FFB half update rate - has anyone got any other tips to lean out CPU use a bit? I do notice a little grumbling from the game when it's sending a lot of FFB info ( admittedly that's usually in a corner when there's also a lot of screen movement ).

CPU is an i3930k O/C'd to 4.4Ghz, it's not going to go any faster unfortunately.
 
Last edited:
Messages
907
Points
952
Well, that was ... I'm not sure if it's really reassuring or what, but I disabled crossfire & ran a couple more benchmarks with the same settings. I get a pause at the start of benchmarking for some reason so I tend to ignore the average FPS & just look at max + variance, but anyway:

single screen:
Code:
AC VERSION: 1.16.3 (x64)
POINTS: 13780
FPS: AVG=94 MIN=9 MAX=163 VARIANCE=0 CPU=51%

LOADING TIME: 15s
GPU: Radeon RX 580 Series (2560x1440)
OS-Version: 6.1.7601 (Service Pack 1) 0x100-0x1
CPU CORES: 12
FULLSCREEN: ON
AA:2X AF:16X SHDW:2048 BLUR:0
WORLD DETAIL: 5 SMOKE:2
PP: QLT:5 HDR:1 FXAA:0 GLR:5 DOF:0 RAYS:1 HEAT:1

Triple using eyefinity:
Code:
AC VERSION: 1.16.3 (x64)
POINTS: 6069
FPS: AVG=41 MIN=32 MAX=47 VARIANCE=0 CPU=29%

LOADING TIME: 15s
GPU: Radeon RX 580 Series (7680x1440)
OS-Version: 6.1.7601 (Service Pack 1) 0x100-0x1
CPU CORES: 12
FULLSCREEN: ON
AA:2X AF:16X SHDW:2048 BLUR:0
WORLD DETAIL: 5 SMOKE:2
PP: QLT:5 HDR:1 FXAA:0 GLR:5 DOF:0 RAYS:1 HEAT:1

So definitely something crossfire related I think ( although even with just the RX580 that looks like it's still underperforming compared to the 1070 ). I ran a number of 3dmark tests and losing the second GPU is about a 60% hit in both the GPU and the combined GPU & CPU test so this excessive CPU use does also seem AC related.
 
Messages
269
Points
452
( although even with just the RX580 that looks like it's still underperforming compared to the 1070 )
Just for the record, as that's omitted from benchmark results, i'm running static reflections and no high quality mirror (which afair turns on reflections in mirrors)

Don't think AC is optimized for SLI/Xfire so this might be a pickle. Maybe there would be something in "radeonMod" that would flip a switch to make Xfire work better.
 
Messages
907
Points
952
Don't think AC is optimized for SLI/Xfire so this might be a pickle. Maybe there would be something in "radeonMod" that would flip a switch to make Xfire work better.

With the results I'm getting I'm leaning towards "actively working against" multi-gpu... best I've managed so far for the second GPU is another ~2k benchmark points.

Anyone else actually using crossfire? any way of telling if the game profile is being applied to ACS rather than just the launcher?
 
Messages
2,921
Points
2,092
Turning off any apps not directly graphically rendered, will 'unload' the CPU to better allow it to support the GPU's demands.
Here are a few of my scores on a similar system...I7-3820@ 3.8 GHz and non-o/c GTX-1070.
The first, is with everything set to low and the other is with everything set to max...(except depth of field and blur)...neither of which I ever use.

AC VERSION: --- CHANGELOG of gbwSuite --- (x64)
POINTS: 39008
FPS: AVG=266 MIN=60 MAX=373 VARIANCE=20 CPU=84%
LOADING TIME: 17s
GPU: NVIDIA GeForce GTX 1070 (1920x1080)
OS-Version: 6.2.9200 () 0x100-0x1
CPU CORES: 8
FULLSCREEN: ON
AA:1X AF:0X SHDW:512 BLUR:0
WORLD DETAIL: 0 SMOKE:0
PP: QLT:0 HDR:0 FXAA:0 GLR:0 DOF:0 RAYS:0 HEAT:0
-----------------------------------------------------------------------------------------
AC VERSION: --- CHANGELOG of gbwSuite --- (x64)
POINTS: 16931
FPS: AVG=115 MIN=44 MAX=149 VARIANCE=2 CPU=65%
LOADING TIME: 30s
GPU: NVIDIA GeForce GTX 1070 (1920x1080)
OS-Version: 6.2.9200 () 0x100-0x1
CPU CORES: 8
FULLSCREEN: ON
AA:4X AF:16X SHDW:4096 BLUR:0
WORLD DETAIL: 5 SMOKE:5
PP: QLT:5 HDR:1 FXAA:1 GLR:5 DOF:0 RAYS:1 HEAT:1
 
Top