[RACER Crash] Fatal error - the program will exit

Discussion in 'Racer' started by nuvolarossa, Nov 20, 2011.

  1. nuvolarossa


    tried to use Racer today, after a while...
    I get a "Fatal error - the program will exit" window even before the Racer's menu.
    Tried with 0.8.35 and 0.8.36.

    exact screen:


    Sun Nov 20 19:56:17 (INFO): [racer/4244] --- application start ---
    Sun Nov 20 19:56:17 (INFO): [racer/4244] Racer version: 0.8.35 (Sep 22 2011/19:09:27) - customer: Internet
    Sun Nov 20 19:56:18 (INFO): [racer/4244] Physics engine: NEWTON v2.29
    Sun Nov 20 19:56:18 (INFO): [racer/4244] Crash detected - attempting to recover some data before displaying the crash dialog
    Sun Nov 20 19:56:19 (FATAL): [racer/4244] Exception 0xC0000005, flags 0, Address 0x6F462F5D
    (this dialog text is stored in QLOG.txt)
    OS-Version: 6.1.7601 (Service Pack 1) 0x100-0x1
    0x6F462F5D [nvoglv32]: (filename not available): DrvPresentBuffers
    0x6F463086 [nvoglv32]: (filename not available): DrvPresentBuffers
    0x6ECC8436 [nvoglv32]: (filename not available): (function-name not available)
    0x6F3E43CE [nvoglv32]: (filename not available): DrvPresentBuffers
    0x6ECB080B [nvoglv32]: (filename not available): (function-name not available)
    0x6ECB0A45 [nvoglv32]: (filename not available): (function-name not available)
    0x6ECB16EF [nvoglv32]: (filename not available): (function-name not available)
    0x6ECD43E5 [nvoglv32]: (filename not available): (function-name not available)
    0x6ECD4378 [nvoglv32]: (filename not available): (function-name not available)
    0x6F2E1CAB [nvoglv32]: (filename not available): (function-name not available)
    0x6ECD424D [nvoglv32]: (filename not available): (function-name not available)
    0x6F2E5A17 [nvoglv32]: (filename not available): (function-name not available)
    0x6F2E6579 [nvoglv32]: (filename not available): (function-name not available)
    0x6F2E6C20 [nvoglv32]: (filename not available): (function-name not available)
    0x6ED7CC27 [nvoglv32]: (filename not available): (function-name not available)
    0x0044ACA5 d:\source\trunk\dev\src\libs\d3\dtexture.cpp (line 837): DBitMapTexture::FromBitMap()
    0x0044AE7C d:\source\trunk\dev\src\libs\d3\dtexture.cpp (line 729): DBitMapTexture::DBitMapTexture()
    0x0044F044 d:\source\trunk\dev\src\libs\d3\dtexturemgr.cpp (line 54): DTextureManager::MakeObject()
    0x0057B0D1 d:\source\trunk\dev\src\libs\qlib\qobjectmgr.cpp (line 209): QObjectManager::Get()
    0x00445A07 d:\source\trunk\dev\src\libs\d3\dflat.cpp (line 182): d3GetTextureRef()
    0x00460B98 d:\source\trunk\dev_racer\src\lib\rmanager.cpp (line 1446): RManager::Create()
    0x00403463 d:\source\trunk\dev_racer\src\mrun.cpp (line 1666): Setup()
    0x00403A7E d:\source\trunk\dev_racer\src\mrun.cpp (line 2019): Run()
    0x00401534 d:\source\trunk\dev_racer\src\main.cpp (line 241): main()
    0x004015A3 d:\source\trunk\dev_racer\src\main.cpp (line 248): WinMain()
    0x0055DD7B f:\dd\vctools\crt_bld\self_x86\crt\src\crt0.c (line 263): __tmainCRTStartup()
    0x759E339A [kernel32]: (filename not available): BaseThreadInitThunk
    0x76F09ED2 [ntdll]: (filename not available): RtlInitializeExceptionChain
    0x76F09EA5 [ntdll]: (filename not available): RtlInitializeExceptionChain
    What it could be?

    i7 Laptop running Nvidia Quadro 1000M, W7 64bit. I played Racer many times on it...

    Reinstalled the Nvidia drivers, deleted and reinstalled Racer, still the same.
  2. nuvolarossa



    The culprit was a beta driver from Nvidia. Downgraded to the latest STABLE/certified and now it works fine :cool: