R3E won't start in VR!

GuitarTech

500RPM
Original poster
Premium
Sep 25, 2011
843
629
So: I have an Acer WMR headset, using the Steam VR app. rF2, PC2. DR, and ACC all work fine
without any problems.
R3E, on the other hand, refuses to start in VR mode. It churns and churns. and then I get a pop up message "Can't connect to server, Error Code 17991 "
And in Chrome the tab says " 505 Bad Gateway "
All the relevant drivers are up to date, and all my other games run fine.
I've tried a file integrity check, and a complete new install after deleting all R3E folders on my computer ( twice )
I have " -vr " as start option, and I always start it from within Steam, after first starting the Steam VR app.
It used to work until the latest big update, but now it only works in 2D mode, VR is broken.
Anybody have any ideas?
 

Richlevy

10RPM
Aug 24, 2015
24
13
40
Go to the steam store, do a search on "windows" select the steamvr specific for window vr headsets, not the steamvr. That is probably the situation. Good luck.
 

Richlevy

10RPM
Aug 24, 2015
24
13
40
Oops, sorry, I did not read all the way thru your post. As of yesterday my samsung odyssey was working fine. I'm using the latest steam drivers and updates
 

Cote Dazur

SIM Addict
May 21, 2013
2,097
2,334
I had the same issue a few weeks back, after a few days, without doing anything it came back.
 

GuitarTech

500RPM
Original poster
Premium
Sep 25, 2011
843
629
I had the same issue a few weeks back, after a few days, without doing anything it came back.
Until now I haven't found a better solution either, it's only my third favorite game, after rF2 and PC2, so it's not so bad. Merry Christmas:)
 

GuitarTech

500RPM
Original poster
Premium
Sep 25, 2011
843
629
I thought I'd bump this one up, now that Christmas is over, and things are back to normal.
Does anybody have a solution to my problem? R3E is not my first choice when I want to race, but I've spent a lot on addons, and not being able to use it in VR is a bit irksome.
My system is modern and up to date. rF2, Dirt Rally and PC2 run really well, and start every time without complications. Why can't Sector 3 get their act together? Does anybody from over there even hang out here?
 

Goffik

RMG Motorsports
Staff
Premium
Sep 28, 2009
12,340
9,084
The game definitely starts fine in normal mode (non-VR), right? Have you tried removing the -vr command and starting the game with the included VR options instead? Also try both 32bit and 64bit versions, just to eliminate it as a possibility. Finally, try starting the game without starting SteamVR first and let it open automatically. (I remember the game used to crash on me if I started SVR first, but that was some time ago.)
R3E_Options.png
 

GuitarTech

500RPM
Original poster
Premium
Sep 25, 2011
843
629
The game definitely starts fine in normal mode (non-VR), right? Have you tried removing the -vr command and starting the game with the included VR options instead? Also try both 32bit and 64bit versions, just to eliminate it as a possibility. Finally, try starting the game without starting SteamVR first and let it open automatically. (I remember the game used to crash on me if I started SVR first, but that was some time ago.)
View attachment 284975
I just de-installed it, and am re-installing it again, after deleting every R3E folder I could find on my computer. Just before I de-installed it, I found out that it wouldn't even start in normal mode any more, despite using the desktop Icon to start and deleting the "-vr" in the start options.
At least rF2, Dirt Rally, and PC2 are all running fine, without having to jump through hoops and spend hours buggering about trying this and that :thumbsup:
Until now, I'm underwhelmed with the "support" on the dedicated Sector 3 forum: a link to another thread where someone has (had?) the same problem where they suggested doing some things that don't apply at all in my case, but otherwise no real help. I'll wait till I have a vanilla install to play with tomorrow, and then see if that made any difference. But thanks for trying to help :thumbsup:
 
  • Like
Reactions: Goffik

GuitarTech

500RPM
Original poster
Premium
Sep 25, 2011
843
629
Update: after installing it again, no change. Won't even start from the desktop icon. And no answer on the "support" forum. :thumbsdown: Goodbye R3E for now, life goes on ;)
 

BrunoB

Too much Goebbels
Oct 10, 2011
1,716
907
Just an idea.
You could try in the sector3studios forum to PM one of the devs asking for help.
I mean you have payed for their game so...;)
 

RKip455

Attack Life, its going to Kill you Anyway!
Sep 5, 2008
251
51
60
Same issue still??? Won't start in VR for me
 

GuitarTech

500RPM
Original poster
Premium
Sep 25, 2011
843
629
I solved my problem in that I got rid of the Acer WMD VR headset that I had, as I found out that it wouldn't always play ball with the steam VR App. Bought a Rift S, and haven't looked back. It's a better headset in all respects anyway. The steam VR App context menu has an extra setting for "start in Oculus VR mode", and then it just works. :D
YMMV, the Steam software is as buggy as hell, it's been in beta for like the last 3 (?) years, and they're still fiddling around with it. Good luck with finding a solution :)
 
  • Like
Reactions: RKip455

Dux

Simracer since 99 / 3D Engineer & Game Developer
Premium
Oct 14, 2012
1,638
757
31
I just get
1573293177313.png


Anyone for solution?

[EDIT] OK suddenly started working.
 
Last edited:

RKip455

Attack Life, its going to Kill you Anyway!
Sep 5, 2008
251
51
60
I solved my problem in that I got rid of the Acer WMD VR headset that I had, as I found out that it wouldn't always play ball with the steam VR App. Bought a Rift S, and haven't looked back. It's a better headset in all respects anyway. The steam VR App context menu has an extra setting for "start in Oculus VR mode", and then it just works. :D
YMMV, the Steam software is as buggy as hell, it's been in beta for like the last 3 (?) years, and they're still fiddling around with it. Good luck with finding a solution :)
how to get to vr context setting???
 

VelocityBraker

1RPM
Premium
Nov 1, 2017
1
0
55
Gents, try joining the sim using the VR (32-bit) portal.

I have a 64-bit machine and the above worked for me.