Public Beta 1.0.3 Out now

o Tiger Feet o

250RPM
Original poster
Apr 4, 2018
288
161
1.0.3 Preview:

GENERAL:
- Audio optmizations to lower the memory footprint.
- Fixes to overall game stability and added logging.

GAMEPLAY:
- Fixed a rare bug that failed to turn on the ignition in AI cars.
- Fixed driver swap missing in Race 2 of career race weekends.
- Fixed autosave not storing tyre set wear data.
- Fixed random weather not randomizing ambient temperature.
- Fixed potential issue not auto saving replays

GRAPHICS:
- Fixed disabled driver foot animations in the Mercedes-AMG GT3.

UI/HUD:
- Revamped controller options menu, allowing keyboard, direct-input and X-input customization.
NOTE: old controller presets will continue to work.
- Fixed widget position when the car crosses the finish line.
- Camera movement and look-with-wheel sliders activate/deactivate in relevant camera modes.
- Fixed a bug on the weather page that allowed rain level without cloud level when after entering the page.
- Fixed confusing behaviour of random track button on the weather UI.
- Fixed weather summary incorrectly reporting dynamic weather disabled with random weather on.
- Fixed podium sequence not responding to mapped pause key.
- Fixed championship AI aggression being incorrectly limited to 80-100%.
- Default championship settings updated.
- Resume button added inside the main Championship and Career pages.
- Revised layout organization of race-end messages.
- Fixed wind speed not being absolute value.

VR:
- Mouse in VR: added wheel and scroll bar support.
- Fix to the HUD stereo layer clipping with the car geometry.

RATING & MULTIPLAYER:
- The "too slow for Eau Rouge" fix introduced in 1.0.1 is now more accurate.
- Fixed a an issue where cars can load without setup (=no ABS/TC) applied / HUD invisible.
- Entrylists can now use "isAdmin" as intended.
- Entrylists can now use "overrideDriverInfo" as intended.
- Added ServerAdminHandbook v1 to the server folder.

https://www.assettocorsa.net/forum/index.php?threads/public-beta-1-0-3.58388/
 

cerebralvortex

250RPM
Premium
Dec 14, 2010
323
173
Great stuff ! I think I will finally put more time into ACC now the VR quirks are getting fixed. Thanks a lot Kunos !
 

Gergo Panker

pankykapus
Oct 13, 2011
312
780
What has changed with the 2nd update?

RATING & MULTIPLAYER:
- Solved "No CP server in your region" display for users that should actually see them.
- Server pings are now displayed accurately in the UI.
 
Feb 28, 2013
33
59
Several cars are oversteer monsters, and several are pretty light on their feet. Maybe it's your driving?
 

Cedric Germain

250RPM
Premium
Jan 26, 2010
416
89
I tried to play today after installing this update: "CPU usage 99%" game crash, I have to reboot the PC.
Before this update yesterday, no problem...

EDIT: ok it works... sometimes. I still have random crashes (fo example: no sound at all, crashed as I wanted to watch replay online, crashed in a training session... strange. Hope they fix it later)

--> 1.0.4 is there with the fix :)
 
Last edited:

o Tiger Feet o

250RPM
Original poster
Apr 4, 2018
288
161
I had a good session last night in VR. Using 2 different headsets, Odyssey+ and Pimax 5K+. Both worked really well and looked really good. Especially in wet weather.... wow. (I prefer the O+ but thats a different thread).

I played quick race, multiplayer, multiplayer on a private server and everything ran like clock work without any serious issues.

The only niggle was when I came 3rd in a SP race I think its suppose to cut to a podium scene or something? But I was stuck in the trees listening to some 'up lifting, yea you did type music'. It was hard to get out of as it kept looping. (Eventually i realised if I press esc at exactly the right time a menu would come up where if I was quick enough I could mouse to exit)
 

Greg Latty

1000RPM
Mar 1, 2014
1,088
504
39
I had a good session last night in VR. Using 2 different headsets, Odyssey+ and Pimax 5K+. Both worked really well and looked really good. Especially in wet weather.... wow. (I prefer the O+ but thats a different thread).
mind sharing your settings? and what are your computer specs? While i finally got vr to a point where it runs decently, anything that is not the cockpit looks blurry as hell. This kills the immersion for me. And i really want to love this game because i really like how it feels when driving. my rig is a 2080ti, 9700k and 16gb ram and im using a odyssey + as well
 

RasmusP

6000RPM
Premium
Oct 7, 2016
6,543
3,418
It's funny how we all have different thoughts on ffb because to me, it's the best ffb I've ever experienced in a sim with my T300.
It seems like ACC feels great on belt driven wheels. On my G27 it was too lifely and rough. You can't feel a lot with a G27 anyway and ACC did hide details and hints even more.
Then with the TS-PC it felt great and with the CSW 2.5 it's glorious imo too.

It seems however that with a DD wheel it goes worse again somehow. Maybe it needs the little "rubbery feel" of belt driven wheels...
 
Feb 12, 2014
824
421
51
It seems like ACC feels great on belt driven wheels. On my G27 it was too lifely and rough. You can't feel a lot with a G27 anyway and ACC did hide details and hints even more.
Then with the TS-PC it felt great and with the CSW 2.5 it's glorious imo too.

It seems however that with a DD wheel it goes worse again somehow. Maybe it needs the little "rubbery feel" of belt driven wheels...
Did you try with the ff post processing and using a LUT and gamma? I have a G27 and with the pp is awesome. No more rattling, the wheel feels more connected to the tires. Very nice.

At the end of the month I am going to receive a Thrustmaster TX. I am very impatient to know how it is going to feel compared to the G27. I will probably create a thread later about how to proper config it, but that is another story.
 

RasmusP

6000RPM
Premium
Oct 7, 2016
6,543
3,418
Did you try with the ff post processing and using a LUT and gamma? I have a G27 and with the pp is awesome.
Sadly not. My g27 is stored away in a corner of the basement in its original packaging. Waiting to be needed at some point in the future.
With my csw, no FF pp is needed. But since the minimum force % I used back then matches the settings I used in ac1, I bet my old lut + settings would feel very well :)
 
  • Like
Reactions: Fernando Deutsch