RaceDepartment Store

Upcoming Events

AC events on Simracing.GP ACC events on Simracing.GP Automobilista 2 events RaceRoom events rFactor 2 events

problem with r factor 2 install

hi guys i just updated to the new build with a complete uninstall and reinstall of the game , the problem is that the game remembers all these old mods that were installed ages ago like version 1 of monte carlo and a few more tracks and car mods , and some of them actually run even though the package folder is empty , when i start up mod manager all these mods show up as damaged mods ,all written in red , and it want let me uninstall it as it states it is being used by another damaged mod which i cannot uninstall , does anyone else had this problem cheers noel
 
hi guys i just updated to the new build with a complete uninstall and reinstall of the game , the problem is that the game remembers all these old mods that were installed ages ago like version 1 of monte carlo and a few more tracks and car mods , and some of them actually run even though the package folder is empty , when i start up mod manager all these mods show up as damaged mods ,all written in red , and it want let me uninstall it as it states it is being used by another damaged mod which i cannot uninstall , does anyone else had this problem cheers noel

Hi Noel,

I had the same problem.
Here is what I did:
I moved the package and userdata folder from the data folder to a new made folder which I called ..\rf2_backup (within my d:\temp folder).
Than I uninstalled the game and deleted the rfactor2 game folder in total.
I installed a fresh copy of build 298.
Next I copied my userdata folder (with an emptied log folder) back into the fresh installed data folder.
The next thing I did was move all ISI mods from the rf2_backup\package folder to the new fresh installed game.
Used the mod manager to install firstly all original content from ISI.
Booted the game and see if I could play.
Next I updated the game to build 300 and started moving mods from the rf2_backup\package folder to fresh copy and started installing them. It worked like a charm. :)

Hope this helps m8. :)
 
cheers for reply stefan , i think i pretty much did that but the only thing is i did a new reinstall of build 300 1gig download , so its got me tossed why its seeing all these old mods
 
Noel did you alsop deleted all the old folders that rfactor2 left when you un-installed the game? So program files/rfactor2 and the folders in My Documents section? Perhaps the old folders make the game think they are still installed, can't think of anything else what should cause that..
 

Marco Bijl

Axe Travels
Yes, its an update with a twitch, Best thing is to do a complete reinstall, in a different folder. No copy of user data. (at least not the whole folder :)).
 

Justin Swan

RD-DVLC
Yes, its an update with a twitch, Best thing is to do a complete reinstall, in a different folder. No copy of user data. (at least not the whole folder :)).
I've just done the 298 update followed by the 300 update. All seems to be OK but I don't have many mods installed as of yet. I keep meaning to spend more time on rF2 but there's are rubber band between me and Race 07 :D
 
Top