Problem with gear selection on some cars

markturner

25RPM
Mar 6, 2015
26
3
59
Hi, new here, so hello. Just installed the sim and my G25 wheel and everything seems to be working fine, except certain cars, I select a gear in the pits and get no drive. This is without changing any settings in controllers. I can for example drive the Mcclaren, both mercedes, and various other downloaded cars, but the BMWM3 and various others, when I put in gear to pull away, it says 1st gear, but no drive......can anyone suggest what I am doing wrong? I am using the paddle shift on my wheel, not the stick shifter. Thank you
 

Ben Goymer

100RPM
Jul 3, 2013
128
40
35
I don't have a g25, but did you add the manual shifter to the config when setting up the wheel? I wonder if assetto corsa sees that you have a manual shifter so wants you to use it on cars with a manual gearbox? Maybe try removing the bindings for the manual gears in the options section.
 

Radu Oros

1000RPM
Jul 25, 2014
1,329
409
I don't have a g25, but did you add the manual shifter to the config when setting up the wheel? I wonder if assetto corsa sees that you have a manual shifter so wants you to use it on cars with a manual gearbox? Maybe try removing the bindings for the manual gears in the options section.
yea if you untick the "use separate shifter" in controls page, then the game no longer wants you to use h-shifter with manual cars.
But for the g25 you need to activate the manual shifter button right.
See this post about the g25. http://www.assettocorsa.net/forum/index.php?threads/g25-sequential-manual-shifter.18891/#post-339546