• 23000+ Members! Dear Guest, join the community on the official RD Discord server today.   learn more

Port forwarding issue

Jul 15, 2019
2
0
28
I am setting up a server in Assetto Corsa through dedicated server tool. The router I am using is Belkin. The server settings I got from "Assetto Corsa Server Manager" are as below:

UDP Port: 9600 TCP Port: 9600 HTTP Port: 8081

The ports I have added in my router are as below:

In bound port: 80 - 80, Type: TCP, IP address: *** Private port: 9600 - 9600

In bound port: 88 - 88, Type: UDP, IP address: *** Private port: 9600 - 9600

In bound port: 82 - 82, Type: TCP, IP address: *** Private port: 8081 - 8081

I have used the IPv4 address, which I got from CMD -> ipconfig, in the IP address field.

The message I am receiving when I run acServer application "RESPONSE: ERROR,INVALID SERVER,CHECK YOUR PORT FORWARDING SETTINGS"

I was doubting mainly the inbound port setting. I have tried multiple ports for the TCP setting of HTTP server such as 81-86. Also, I have tried to set up the HTTP server as both TCP, and UDP using 3074 in bound port.

I am stuck there please help.
 

Mr_C

10RPM
Jun 28, 2019
12
2
Apologies if you have done this but I did not see any mention of allowing the ports through any software firewall as well, for example the standard windows firewall.
 
  • Like
Reactions: Neilski
Jul 15, 2019
2
0
28
Thank you for your reply. This is the first time I try port forwarding. I looked couple of guide videos and posts prior to making this post.

To answer your question I am not sure if disabling both router and windows fire wall would be enough or I should allow it manually.
 
Last edited:

Neilski

3000RPM
Staff member
Premium
Jan 7, 2017
3,302
1,429
Now and then I find it useful to use an external server to check if I've opened ports correctly on my home box(es).
If you don't have a remote shell account anywhere then you can still achieve this: try googling "check open ports" and you'll find a few options out there which are designed to help people check if port forwarding is switched on properly (or indeed off again!). They can even be considered security tools if you want to use them the other way around...
 
Sep 26, 2017
196
80
60
Thank you for your reply. This is the first time I try port forwarding. I looked couple of guide videos and posts prior to making this post.

To answer your question I am not sure if disabling both router and windows fire wall would be enough or I should allow it manually.
Don't disable the firewalls (other than testing for very short periods) windows firewall has options to let the desired applications through.

As mentioned above there are loads of sites that you can used to scan your router for open ports.
https://ping.eu/port-chk/
Also for checking (from memory without looking into it again) you need to ensure the router is configured to respond to ping (disable ping once you have completed testing for security reasons ) or alternatively that the ac server is running.

Make sure the server has a static IP address or it could change any time and mess your configuration up.
 
Last edited: