Pop up with the "We value your privacy message"

garyjpaterson

Premium
3,268
6,029
Scotland
Anyone else getting this popup (literally got it just as I was starting this post) almost all the time on RD? Surely it should be a one time thing, its getting really irritating tbh :roflmao:

plsstahp.JPG
 

alexSchmurtz

SpeedyMite Racing
Staff
Premium
4,206
2,510
I'm pretty sure it has something with your browser settings refusing all cookies, or third parties cookies; one is needed to store the choice you made with this popup.

@Ole Marius Myrvold I got it a couple times when I'm not logged in. When you are logged in, I guess it takes into account that we already approved the TOS.
 

garyjpaterson

Premium
3,268
6,029
Scotland
I'm pretty sure it has something with your browser settings refusing all cookies, or third parties cookies; one is needed to store the choice you made with this popup.

@Ole Marius Myrvold I got it a couple times when I'm not logged in. When you are logged in, I guess it takes into account that we already approved the TOS.
I don't have any cookies blocked on RD that I know of.
 

Ole Marius Myrvold

JWB 96-13
Staff
Premium
10,667
6,648
Norway
I'm pretty sure it has something with your browser settings refusing all cookies, or third parties cookies; one is needed to store the choice you made with this popup.

@Ole Marius Myrvold I got it a couple times when I'm not logged in. When you are logged in, I guess it takes into account that we already approved the TOS.

Just logged out to check. You are correct.
All was set to off for me :)
 

Gevatter

The James May of Simracing
Premium
1,328
1,187
Since today I receive them several times. First one when the site loads, secend when I click Forums, und from then on roughly every 2nd or 3rd link I click. I am logged in and approved the TOS every time I see it. Cookies are at default settings for Firefox, clearing cookis/cahce didn't do anything.
 
Last edited:

garyjpaterson

Premium
3,268
6,029
Scotland
Since today I receive them several times. First one when the site loads, secend when I click Forums, und from then on roughly every 2nd or 3rd link I click. I am logged in and approved the TOS every time I see it. Cookies are at default settings for Firefox, clearing cookis/cahce didn't do anything.
Yeah its been significantly worse today, been getting it for a while but today i cant click on anything without it popping up.
 

Gevatter

The James May of Simracing
Premium
1,328
1,187
I also keep getting those messages when using the Pale Moon browser, which is a Firefox Stub - interestingly I dont have those messages at work in my Fireox. Cookie settings are identical at home and at work. Is there something else I could check in my browser settings? Racedepartment is the only site I have this issue with.
 

Goffik

RMG Motorsports
Staff
Premium
12,691
9,476
I also get this message all the time whenever I visit RD in IE not logged in. Accept every time, no cookies blocked, yet it comes back persistently.

My main browser is Chrome but I'm always logged in on there so not sure if the issue is the same.
 

Dave Stephenson

RaceDepartment Technical Administrator
Staff
Premium
Third party cookies are required as well as first party for it to function correctly. The choice cookies are set on a neutral domain. Doing so enables the ad providers to also make requests to that domain to retrieve your settings and act appropriately.

Even when accepting all you will still see it from time to time. This is a result of the add network adding new vendors. The choices box will show itself so you can make your decision on them.

Those who aren't seeing it logged in are premium. We of course don't include any add related scripts in the page for them.

@Ross Garland what version of IE?
 
This is a result of the add network adding new vendors. The choices box will show itself so you can make your decision on them.

Just wanted to suggest to only display it in case something changed but it looks like you're already doing it. Seeing how often I have to view this thing means vendors are changed quite often aren't they? Is this really necessary?

/edit: I mean the frequency of changes not the popup itself.
 

Dave Stephenson

RaceDepartment Technical Administrator
Staff
Premium
Just wanted to suggest to only display it in case something changed but it looks like you're already doing it. Seeing how often I have to view this thing means vendors are changed quite often aren't they? Is this really necessary?

/edit: I mean the frequency of changes not the popup itself.
Initially there was a lot of change as ad providers got on board with the scheme. The rate of change has dropped a lot now to a level thta's somewhat less oppressive.

I've since also found a change in the default settings in the last update which I missed when it was implemented. This will have resulted in the form being displayed more often over the past couple of weeks. I have tweaked the settings a few days ago to reduce the frequency.
 
1,004
488
I'm experiencing a problem with the forum lately and I don't know how to fix it. The problem is that I'm always getting the pop up with the "We value your privacy message". No matter how many times I hit "I accept", the message come again, every time I open a message, change to a different forum, every time I load any link under racedepartment.com/. Any idea? It's very annoying. Thanks.
 

Neilski

Staff
Premium
3,752
1
1,747
UK
Have you started using any new privacy settings or content blockers?
I think your symptoms mean that the cookie for our consent management provider (which is at quantcast.mgr.consensu.org, so I think this makes it a 3rd party cookie) is being blocked...
 
Top